Problèmes de virtualisation de fichiers communs et du Registre dans Windows Vista

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Important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986 Description du Registre de Microsoft Windows
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Sommaire

Symptômes

Lorsque vous utilisez la fonction de virtualisation de Windows Vista, vous pouvez rencontrer les problèmes de virtualisation de fichier et du Registre qui sont décrits dans les scénarios suivants.

Scénario 1 : Réception de messages d'erreur lors de l'installation, de la mise à niveau ou de l'utilisation d'une application

Lorsque vous installez, mettez à niveau ou utilisez une application, vous pouvez recevoir divers messages d'erreur indiquant que l'accès vous est refusé. Par exemple, vous pouvez rencontrer l'un des problèmes suivants :
  • Après avoir installé une application dans un dossier autre que le dossier %programfiles%, vous recevez des messages d'erreur « Accès refusé ». En outre, l'application ne fonctionne pas comme prévu.
  • Des messages d'erreur d'application semblables aux suivants s'affichent :
    Impossible de créer le dossier dans C:\MonApp\Temp
    Impossible de créer le fichier dans C:\MonApp\Temp\output.dat
  • Des messages d'erreur semblables au suivant s'affichent :
    Erreur d'écriture dans MonFichier.exe
    Ce problème peut se produire si vous effectuez l'une des actions suivantes :
    • Vous créez des liens dans des emplacements virtualisés.
    • Vous cryptez des fichiers à l'aide du système de fichiers EFS.
    • Vous tentez d'afficher des fichiers compressés.
    • Vous utilisez l'invite de commandes pour copier un fichier .exe, .sys ou .dll dans un emplacement virtualisable.
  • Des portions de l'application qui requièrent une entrée ou une sortie de fichier ne fonctionnent plus correctement.

Scénario 2 : Impossibilité de trouver le fichier ou le dossier que vous venez de créer

Lorsque vous utilisez une application pour laquelle la virtualisation est activée, vous créez des fichiers de données dans des emplacements virtualisables du système de fichiers. Lorsque vous utilisez une autre application ou l'Explorateur Windows pour accéder à ces nouveaux fichiers, vous ne parvenez pas à les trouver. Par exemple, si vous enregistrez un fichier dans une application d'édition de photos dans les dossiers %programfiles%, %systemroot% ou %programdata%, vous ne parvenez pas à localiser ce fichier.

Scénario 3 : Comportement inattendu d'un programme à la suite de sa mise à niveau

Après avoir mis à niveau une application, un message d'erreur semblable au suivant s'affiche :
Erreur. Mettez à niveau l'application.
En outre, l'application ne fonctionne pas comme prévu. Elle semble utiliser des données incorrectes ou antérieures à la mise à niveau.

Scénario 4 : Fichiers toujours présents sur l'ordinateur malgré la désinstallation de l'application

Dans ce scénario, vous rencontrez l'un des symptômes suivants :
  • Dans une autre application, vous remarquez que les fichiers et dossiers de l'application désinstallée existent toujours dans les dossiers %programfiles%, %programdata% ou %systemroot%.
  • Le dossier %userprofile%\AppData\Local\VirtualStore est plus gros que prévu. Lorsque vous avez désinstallé l'application, les fichiers virtualisés créés lors de l'exécution de l'application n'ont pas été supprimés.

Cause

Ces problèmes peuvent se produire lorsqu'une ou plusieurs des conditions suivantes sont remplies :
  • L'application tente de créer des fichiers ou dossiers en dehors de certains dossiers virtualisés spécifiés.
  • Les fichiers enregistrés par une application dans le dossier %programfiles% peuvent être orientés vers un dossier autre que le dossier de stockage virtuel de l'utilisateur.
  • L'application utilise un fichier qui n'est pas pris en charge par la fonction de virtualisation.
.

Résolution

Scénario 1

Pour savoir si vous avez rencontré le problème décrit dans le Scénario 1, consultez les événements FileCreateVirtualExclude dans l'Observateur d'événements. Pour cela, procédez comme suit :
  1. Cliquez sur Démarrer
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    bouton Démarrer
    , tapez eventvwr dans la zone Rechercher, puis cliquez sur eventvwr.exe dans la liste Programmes.

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    Contrôle de compte utilisateur
    Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer une opération, entrez votre mot de passe, ou cliquez sur Continuer.
  2. Développez Journaux des applications et des services, Microsoft, Windows, UacFileVirtualization, puis sélectionnez Opérationnel. Si l'ID d'événement est 5000, un événement FileCreateVirtualExclude s'est produit.
Pour résoudre ce problème, appliquez l'une des méthodes ci-dessous.
  • Réinstallez l'application dans le dossier %programfiles% si le programme n'est pas encore installé dans ce dossier.
  • Utilisez un compte d'administrateur pour exécuter cette application. Pour cela, localisez le raccourci d'accès à l'application et cliquez dessus avec le bouton droit, puis cliquez sur Exécuter en tant qu'administrateur.

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    Contrôle de compte utilisateur
    Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer une opération, entrez votre mot de passe, ou cliquez sur Continuer.
  • Exécutez l'application à partir d'une invite de commandes disposant de droits utilisateur élevés. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer
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      bouton Démarrer
      , puis tapez cmd dans la zone Rechercher, et cliquez sur cmd.exe dans la liste Programmes.
    2. Dans la liste Programmes, cliquez avec le bouton droit sur cmd, puis cliquez sur Exécuter en tant qu'administrateur.

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      Contrôle de compte utilisateur
      Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer une opération, entrez votre mot de passe, ou cliquez sur Continuer.
    3. Tapez MonCheminApp/MonApp, puis appuyez sur ENTRÉE. MonCheminApp/MonApp représente le chemin et le nom de l'application.
  • Modifiez les paramètres de sécurité dans le dossier de l'application. Pour cela, procédez comme suit :
    1. Connectez-vous en tant qu'utilisateur possédant des droits d'administrateur, puis ouvrez le dossier de l'application à partir de l'Explorateur Windows.
    2. Cliquez avec le bouton droit sur le dossier de l'application, puis cliquez sur Propriétés.
    3. Sous l'onglet Sécurité, cliquez sur Modifier.

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      Contrôle de compte utilisateur
      Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer une opération, entrez votre mot de passe, ou cliquez sur Continuer.
    4. Sous Noms d'utilisateur ou de groupe, cliquez sur votre compte utilisateur.
    5. Sous Autorisations pour utilisateurs, cliquez sur Autoriser pour les autorisations suivantes :
      • Modifier
      • Lire et exécuter
      • Afficher le contenu du dossier
      • Lire
      • Écrire
    6. Cliquez sur OK.

Scénario 2

Pour résoudre ce problème, appliquez l'une des méthodes ci-dessous.
  • Cliquez sur le bouton Fichiers de compatibilité qui s'affiche dans la barre de l'Explorateur pour afficher les fichiers virtualisés du dossier. Le bouton Fichiers de compatibilité ne s'affiche que s'il existe des fichiers virtualisés dans le dossier.
  • Ouvrez le dossier C:\Users\nom_util\AppData\Local\VirtualStore pour localiser les fichiers et les dossiers.
  • Enregistrez les données de l'application dans un dossier sous votre profil utilisateur.

Scénario 3

Avertissement Toute modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou d'une autre méthode peut entraîner des problèmes sérieux. Ces problèmes peuvent vous obliger à réinstaller le système d'exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous assumez l'ensemble des risques liés à la modification du Registre.

Pour résoudre ce problème, appliquez l'une des méthodes ci-dessous.
  • Exécutez l'application à partir d'une invite de commandes disposant de droits utilisateur élevés. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer
      Réduire cette imageAgrandir cette image
      bouton Démarrer
      , tapez cmd dans la zone Rechercher, puis cliquez sur cmd.exe dans la liste Programmes.

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      Contrôle de compte utilisateur
      Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer une opération, entrez votre mot de passe, ou cliquez sur Continuer.
    2. Tapez MonCheminApp/MonApp. MonCheminApp/MonApp représente le chemin et le nom de l'application. Appuyez ensuite sur ENTRÉE.
  • Ouvrez le magasin virtuel, puis supprimez les anciens fichiers de données d'application. Pour cela, ouvrez le dossier C:\Users\nom_util\AppData\Local\VirtualStore\Program Files\ MonApp à l'aide de l'Explorateur Windows, puis supprimez les fichiers qui ne figurent pas dans vos documents ou fichiers de données.
  • Supprimez le magasin virtuel du Registre.

    Pour localiser le magasin virtuel dans le Registre et supprimer les clés inutiles, procédez comme suit :
    1. Cliquez sur Démarrer
      Réduire cette imageAgrandir cette image
      bouton Démarrer
      , tapez regedit dans la zone Rechercher, puis cliquez sur regedit.exe dans la liste Programmes.

      Réduire cette imageAgrandir cette image
      Contrôle de compte utilisateur
      Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer une opération, tapez votre mot de passe, ou cliquez sur Continuer.
    2. Recherchez la sous-clé de Registre suivante et cliquez dessus :
      HKEY_CURRENT_USER\Software\Classes\VirtualStore
    3. Si vous trouvez une clé de Registre pour l'application qui est devenue inutile, cliquez dessus avec le bouton droit, cliquez sur Supprimer, puis sur Oui.

Scénario 4

Pour résoudre ce problème, ouvrez le dossier C:\Users\nom_util\AppData\Local\VirtualStore\MonApp à l'aide de l'Explorateur Windows, puis supprimez les données d'application obsolètes.

Plus d'informations

La fonction de virtualisation de fichiers et du Registre permet aux utilisateurs disposant de droits d'accès limités au système de fichiers et au Registre d'écrire sur ces zones protégées. La fonction de virtualisation crée une copie « par utilisateur », puis redirige les opérations sur les données successives. Par exemple, supposons qu'une application s'exécute sous un compte d'utilisateur limité ou sous des comptes qui requièrent des contrôles de compte utilisateur. Lorsque cette application écrit dans un emplacement système (par exemple, le dossier %programfiles%), Windows Vista redirige les opérations d'écriture et de lecture vers un emplacement utilisateur spécifique du dossier du profil utilisateur (%localappdata%\VirtualStore). Par défaut, cet emplacement est C:\Users\nom_util\AppData\Local\VirtualStore\Program Files\nom_application. La virtualisation du Registre fonctionne de manière similaire mais concerne les clés du Registre situées sous l'arborescence HKEY_LOCAL_MACHINE\SOFTWARE. Les clés et données situées sous cette arborescence sont redirigées vers la sous-clé
HKEY_CURRENT_USER\Software\Classes\VirtualStore
.

Pour plus d'informations, reportez-vous au site Web de Microsoft à l'adresse suivante (en anglais) :
http://msdn2.microsoft.com/en-us/library/aa480150.aspx

Propriétés

Numéro d'article: 927387 - Dernière mise à jour: jeudi 29 mars 2007 - Version: 2.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows Vista Professionnel
  • Windows Vista Entreprise
  • Windows Vista Édition Familiale Premium
  • Windows Vista Édition Familiale Basique
  • Windows Vista Édition Intégrale
  • Windows Vista Professionnel 64 bits
  • Windows Vista Entreprise 64 bits
  • Windows Vista Édition Familiale Premium 64 bits
  • Windows Vista Édition Familiale Basique 64 bits
  • Windows Vista Édition Intégrale 64 bits
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