Messaggio di errore all'avvio di Windows Vista: "Il file dei dati di configurazione di avvio di Windows non contiene alcune informazioni necessarie"

Traduzione articoli Traduzione articoli
Identificativo articolo: 927391 - Visualizza i prodotti a cui si riferisce l?articolo.
-

Per continuare a ricevere gli aggiornamenti della protezione per Windows, assicurarsi di eseguire Windows Vista con Service Pack 2 (SP2). Per ulteriori informazioni, fare riferimento a questa pagina Web Microsoft: Per alcune versioni di Windows il servizio di supporto non ? pi? disponibile

Il supporto per Windows Vista senza alcun Service Pack installato non è più disponibile dal 13 aprile 2010. Per continuare a ricevere gli aggiornamenti della protezione per Windows, assicurarsi di utilizzare Windows Vista con Service Pack 2 (SP2). Per ulteriori informazioni, fare riferimento a questa pagina Web Microsoft: Per alcune versioni di Windows il servizio di supporto non è più disponibile

Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

All'avvio di Windows Vista, viene visualizzato il seguente messaggio di errore:
File: \Boot\BCD
Stato: 0xc0000034
Informazioni: Il file dei dati di configurazione di avvio di Windows non contiene alcune informazioni necessarie

Cause

Questo errore si verifica quando si presenta una delle seguenti condizioni:
  • La voce Windows Boot Manager (Bootmgr) non è presente nell'archivio dei dati di configurazione di avvio (BCD).
  • Il file Boot\BCD nella partizione attiva è danneggiato o mancante.

Risoluzione

Per risolvere il problema, utilizzare i metodi descritti di seguito nell'ordine in cui vengono elencati.

Metodo 1: Ripristinare l'archivio BCD mediante l'opzione Ripristino all'avvio

È possibile utilizzare l'opzione Ripristino all'avvio nell'Ambiente ripristino Windows per ripristinare l'archivio BCD. A tale scopo, attenersi alla seguente procedura:
  1. Inserire il disco di installazione di Windows Vista nell'unità disco, quindi avviare il computer.
  2. Premere un tasto quando richiesto.
  3. Selezionare una lingua, un'ora, una valuta e una tastiera o un altro metodo di input, quindi fare clic su Avanti.
  4. Fare clic su Ripristina il computer.
  5. Selezionare il sistema operativo da ripristinare, quindi scegliere Avanti.
  6. Nella finestra di dialogo Opzioni ripristino di sistema, fare clic su Ripristino all'avvio.
  7. Riavviare il computer.

Metodo 2: Rigenerare l'archivio BCD mediante lo strumento Bootrec.exe

Se il metodo precedente non consente di risolvere il problema, è possibile rigenerare l'archivio BCD mediante lo strumento Bootrec.exe nell'Ambiente ripristino Windows. A tale scopo, attenersi alla seguente procedura:
  1. Inserire il disco di installazione di Windows Vista nell'unità disco, quindi avviare il computer.
  2. Premere un tasto quando richiesto.
  3. Selezionare una lingua, un'ora, una valuta e una tastiera o un altro metodo di input, quindi fare clic su Avanti.
  4. Fare clic su Ripristina il computer.
  5. Selezionare il sistema operativo da ripristinare, quindi scegliere Avanti.
  6. Nella finestra di dialogo Opzioni ripristino di sistema scegliere Prompt dei comandi.
  7. Digitare Bootrec /RebuildBcd, quindi premere INVIO.
    • Se lo strumento Bootrec.exe viene eseguito correttamente, si presenta con un percorso di installazione di una directory di Windows. Per aggiungere la voce nell'archivio BCD, digitare . Viene visualizzato un messaggio di conferma che indica che la voce è stata aggiunta correttamente.
    • Se lo strumento Bootrec.exe non individua alcuna installazione di Windows mancante, è necessario rimuovere l'archivio BCD, e ricrearlo. Per eseguire questa operazione, digitare i seguenti comandi nell'ordine in cui sono presentati. Premere INVIO dopo ciascun comando.
      Bcdedit /export C:\BCD_Backup
      ren c:\boot\bcd bcd.old
      Bootrec /rebuildbcd
  8. Riavviare il computer.

Metodo 3: Rigenerare manualmente l'archivio BCD mediante lo strumento Bcdedit.exe

Se il metodo precedente non consente di risolvere il problema, è possibile rigenerare manualmente l'archivio BCD mediante lo strumento Bcdedit.exe nell'Ambiente ripristino Windows. A tale scopo, attenersi alla seguente procedura:
  1. Inserire il disco di installazione di Windows Vista nell'unità disco, quindi avviare il computer.
  2. Premere un tasto quando richiesto.
  3. Selezionare una lingua, un'ora, una valuta e una tastiera o un altro metodo di input, quindi fare clic su Avanti.
  4. Fare clic su Ripristina il computer.
  5. Selezionare il sistema operativo da ripristinare, quindi scegliere Avanti.
  6. Nella finestra di dialogo Opzioni ripristino di sistema scegliere Prompt dei comandi.
  7. Digitare il seguente comando, quindi premere INVIO:
    cd /d Partizione:\Windows\System32
    Nota Partizione rappresenta la lettera della partizione in cui è installato Windows Vista. Solitamente è la partizione C.
  8. Digitare il seguente comando, quindi premere INVIO:
    bcdedit /enum all
    Nella sezione Caricatore di avvio di Windows dell'output da questo comando, prendere nota del GUID elencato per resumeobject. Tale GUID verrà utilizzato in un secondo momento.
  9. Digitare il seguente comando, quindi premere INVIO:
    bcdedit -create {bootmgr} -d "Descrizione"
    Nota Descrizione rappresenta la descrizione per questa nuova voce.
  10. Digitare il seguente comando, quindi premere INVIO:
    bcdedit -set {bootmgr} device partition=Partizione:
    Nota Partizione rappresenta la lettera della partizione. Solitamente è la lettera C.
  11. Digitare il seguente comando, quindi premere INVIO:
    bcdedit /displayorder {GUID}
    Nota GUID rappresenta il GUID ottenuto al passaggio 8.
  12. Digitare il seguente comando, quindi premere INVIO:
    bcdedit /default {GUID}
    Nota GUID rappresenta il GUID ottenuto al passaggio 8.
  13. Digitare il seguente comando, quindi premere INVIO:
    bcdedit /timeout Valore
    Nota Valore rappresenta il tempo in secondi prima che Windows Boot Manager selezioni la voce predefinita che è stata creata al passaggio 12.
  14. Riavviare il computer.

Proprietà

Identificativo articolo: 927391 - Ultima modifica: domenica 25 settembre 2011 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Ultimate 64-bit edition
Chiavi: 
kbexpertiseadvanced kbtshoot kbprb KB927391
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com