ImpossibilitÓ di disinstallare un programma dopo l'aggiornamento a Windows Vista

Traduzione articoli Traduzione articoli
Identificativo articolo: 927395 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo vengono descritti i metodi da utilizzare quando risulta problematica la disinstallazione di un programma in Windows Vista dopo l'aggiornamento del computer da una versione precedente di Windows. Questo problema pu˛ presentarsi quando l'applicazione o il relativo programma di installazione non Ŕ compatibile con Windows Vista. In questo articolo vengono fornite istruzioni dettagliate per disinstallare il programma.

Sintomi

Dopo l'aggiornamento a Windows Vista da una versione precedente di Windows non risulta possibile disinstallare un programma. Questo problema si verifica sia che si utilizzi lo strumento Programmi e funzionalitÓ del Pannello di controllo sia che si utilizzi il programma di installazione dell'applicazione in questione.

Cause

Questo problema pu˛ presentarsi quando l'applicazione o il relativo programma di installazione non Ŕ compatibile con Windows Vista.

Risoluzione

Per risolvere il problema, utilizzare i metodi descritti di seguito nell'ordine in cui vengono presentati.

Metodo 1: Utilizzo dello strumento Programmi e funzionalitÓ del Pannello di controllo per disinstallare l'applicazione

Se non si Ŕ giÓ provato a utilizzare lo strumento Programmi e funzionalitÓ del Pannello di controllo per disinstallare l'applicazione, attenersi alla procedura seguente:
  1. Fare clic sul pulsante Start
    Riduci l'immagineEspandi l'immagine
    Pulsante Start
    , digitare appwiz.cpl nella casella Inizia ricerca, quindi fare clic su appwiz.cpl nell'elenco Programmi.

    Riduci l'immagineEspandi l'immagine
    Autorizzazione Controllo di accesso
				utente
    Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Continua.
  2. Fare clic con il pulsante destro del mouse sul programma e scegliere Disinstalla.
  3. Seguire le istruzioni per disinstallare il programma.

Metodo 2: Disinstallazione del programma mediante il relativo file del programma di installazione originale

Se il programma non Ŕ elencato in Programmi e funzionalitÓ, Ŕ possibile disinstallarlo mediante il relativo programma di installazione. A questo scopo, utilizzare uno dei metodi riportati di seguito.

Avvio del programma di installazione mediante il menu Start

Per avviare il programma di installazione mediante il menu Start, attenersi alla procedura seguente:
  1. Fare clic sul pulsante Start
    Riduci l'immagineEspandi l'immagine
    Pulsante Start
    , scegliere Tutti i programmi e individuare la cartella del programma.
  2. Fare clic sul programma di installazione presente in tale cartella.

    Riduci l'immagineEspandi l'immagine
    Autorizzazione Controllo di accesso
				utente
    Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Consenti.
  3. Seguire le istruzioni per disinstallare il programma.

Avvio del programma di installazione dalla cartella di installazione dell'applicazione

Per avviare il programma di installazione dalla cartella di installazione dell'applicazione, attenersi alla procedura seguente:
  1. Fare clic sul pulsante Start
    Riduci l'immagineEspandi l'immagine
    Pulsante Start
    , quindi digitare il nome del programma nella casella Inizia ricerca.
  2. Fare clic con il pulsante destro del mouse sul programma nell'elenco Programmi, quindi fare clic su Apri percorso file.
  3. Individuare il programma di installazione e fare doppio clic su di esso.

    Riduci l'immagineEspandi l'immagine
    Autorizzazione Controllo di accesso
				utente
    Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Consenti.
  4. Seguire le istruzioni per disinstallare il programma.

Avvio del programma di installazione dal supporto di installazione dell'applicazione

Se il programma di installazione non Ŕ presente nel menu Start o nella cartella di installazione, Ŕ possibile trovarlo sul supporto di installazione dell'applicazione, che potrebbe essere ad esempio un CD o un DVD.

Se viene visualizzato un messaggio di errore quando si esegue il programma di installazione o se quest'ultimo non disinstalla l'applicazione, utilizzare uno dei metodi riportati di seguito.

Utilizzo di Risoluzione problemi compatibilitÓ programmi per reinstallare il programma di installazione dell'applicazione

Se il programma di installazione non funziona correttamente, Ŕ possibile che Risoluzione problemi compatibilitÓ programmi si avvii automaticamente. Per utilizzare Risoluzione problemi compatibilitÓ programmi, attenersi alla procedura seguente:
  1. Fare clic su Reinstalla utilizzando impostazioni consigliate.

    Riduci l'immagineEspandi l'immagine
    Autorizzazione Controllo di accesso
				utente
    Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Consenti.
  2. Seguire le istruzioni per disinstallare il programma.

Configurazione del programma di installazione originale per l'utilizzo della modalitÓ compatibile

Per configurare il programma di installazione originale per l'utilizzo della modalitÓ compatibile, attenersi alla procedura seguente:
  1. Fare clic con il pulsante destro del mouse sul programma di installazione dell'applicazione, quindi scegliere ProprietÓ.
  2. Scegliere la scheda CompatibilitÓ.
  3. Selezionare la casella di controllo Esegui il programma in modalitÓ compatibile per.
  4. Nell'elenco scegliere Windows XP (Service Pack 2), quindi fare clic su OK.
  5. Fare doppio clic sul programma di installazione.

    Riduci l'immagineEspandi l'immagine
    Autorizzazione Controllo di accesso
				utente
    Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Consenti.
  6. Seguire le istruzioni per disinstallare il programma.

Metodo 3: Utilizzo del pacchetto msi dell'applicazione per disinstallarla

Per utilizzare il pacchetto msi dell'applicazione per disinstallarla, attenersi alla procedura seguente:
  1. Fare clic sul pulsante Start
    Riduci l'immagineEspandi l'immagine
    Pulsante Start
    , digitare %windir%\Installer nella casella Inizia ricerca, quindi premere INVIO.

    Si apre la cartella del programma di installazione.
  2. Scegliere Dettagli dal menu Visualizza.
  3. Fare clic con il pulsante destro del mouse sulla colonna Nome, quindi scegliere Altro.
  4. Selezionare la casella di controllo Oggetto, digitare 340 nella casella Larghezza della colonna selezionata (in pixel), quindi scegliere OK.

    Nota Potrebbero essere necessari diversi minuti prima che gli oggetti vengano visualizzati accanto a tutti i file msi.
  5. Fare doppio clic sul file msi dell'applicazione.
  6. Seguire le istruzioni per disinstallare il programma.

Metodo 4: Utilizzo del pacchetto msi dell'applicazione con la registrazione del programma di installazione attivata

Per creare un registro del processo di disinstallazione dell'applicazione, attenersi alla procedura seguente:
  1. Fare clic sul pulsante Start
    Riduci l'immagineEspandi l'immagine
    Pulsante Start
    , digitare cmd nella casella Inizia ricerca, fare clic con il pulsante destro del mouse su cmd.exe nell'elenco Programmi, quindi scegliere Esegui come amministratore.

    Riduci l'immagineEspandi l'immagine
    Autorizzazione Controllo di accesso
				utente
    Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Continua.
  2. Al prompt dei comandi digitare msiexec /x <nomepacchetto> /lv* "%userprofile%\desktop\msi.log", dove <nomepacchetto> Ŕ il percorso e il nome del file msi dell'applicazione che si sta tentando di disinstallare, quindi premere INVIO.

    Per ulteriori informazioni sul prompt dei comandi con privilegi elevati in Windows Vista, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
    http://www.microsoft.com/technet/windowsvista/evaluate/feat/uaprot.mspx
  3. Seguire le istruzioni per disinstallare il programma.
  4. Aprire il file .msi.log sul desktop. ╚ possibile utilizzare questo file registro per ricercare i problemi che si verificano durante il processo di disinstallazione dell'applicazione.

    Nota Se durante il processo di disinstallazione si verifica un errore, creare una copia del file di registro prima di terminare o annullare il processo di disinstallazione. ╚ quindi possibile esaminare il punto del file di registro in cui si Ŕ verificato l'errore.
Per ulteriori informazioni su come attivare la registrazione, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito (il contenuto potrebbe essere in inglese):
314852 Attivazione della registrazione di Windows Installer in Windows XP

Metodo 5: Utilizzo del sito Web del produttore dell'applicazione

Visitare il sito Web del produttore dell'applicazione. Il produttore potrebbe avere reso disponibili un programma di disinstallazione, un pacchetto msi aggiornato o istruzioni per la rimozione manuale.

ProprietÓ

Identificativo articolo: 927395 - Ultima modifica: lunedý 19 marzo 2007 - Revisione: 1.2
Le informazioni in questo articolo si applicano a
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
Chiavi:á
kbexpertisebeginner kbtshoot kbwindowsinstaller kbuninstall kbprb KB927395
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com