Não é possível desinstalar um programa depois de atualizar para o Windows Vista

Traduções deste artigo Traduções deste artigo
ID do artigo: 927395 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

Esse artigo descreve métodos a serem usados quando tiver problema para desinstalar um programa no Windows Vista após a atualização do computador de uma versão anterior do Windows. Você pode encontrar esse problema quando o programa ou o instalador é incompatível com o Windows Vista. Esse artigo contém instruções detalhadas para desinstalar o programa.

Sintomas

Após a atualização de uma versão anterior do Windows para o Windows Vista, não é possível desinstalar o programa. Esse problema ocorre se você usar o item Programas e Recursos do Painel de Controle ou o instalador do programa.

Causa

Esse problema ocorre quando o programa ou o instalador é incompatível com o Windows Vista.

Resolução

Para resolver esse problema, use os métodos a seguir na ordem em que são apresentados.

Método 1: Usar o item Programas e Recursos do Painel de Controle para desinstalar o programa

Se você ainda não tentou usar o item Programas e Recursos do Painel de Controle para desinstalar o programa, execute as seguintes etapas:
  1. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    o botão Iniciar
    , digite appwiz.cpl na caixa Iniciar pesquisa e clique em appwiz.cpl na lista Programas.

    Recolher esta imagemExpandir esta imagem
    Permissão Controle de Conta de Usuário
    Caso seja solicitada a senha de administrador ou a confirmação, digite a senha ou clique em Continuar.
  2. Clique com o botão direito do mouse no programa e clique em Desinstalar.

    Observação Você pode clicar na opção Desinstalar e alterar ou Desinstalar/Alterar no menu pop-up ao clicar com o botão direito do mouse em outros programas.
  3. Execute as instruções para desinstalar o programa.

Método 2: Desinstalar o programa usando o arquivo do instalador original do programa

Se o programa não aparece em Programas e Recursos, pode ser possível desinstalá-lo usando o instalador do programa. Para fazer isso, use um dos métodos a seguir.

Iniciar o instalador usando o menu Iniciar

Para iniciar o instalador usando o menu Iniciar, execute as seguintes etapas:
  1. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    o botão Iniciar
    , clique em Todos os programas e localize a pasta do programa.
  2. Clique no programa instalador nesta pasta.

    Recolher esta imagemExpandir esta imagem
    Permissão Controle de Conta de Usuário
    Caso seja solicitada a senha de administrador ou a confirmação, digite a senha ou clique em Permitir.
  3. Execute as instruções para desinstalar o programa.

Iniciar o instalador na pasta de instalação do programa

Para iniciar o instalador na pasta de instalação do programa, execute as seguintes etapas:
  1. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    o botão Iniciar
    e digite o nome do programa na caixa Iniciar pesquisa.
  2. Clique com o botão direito do mouse na lista Programas e clique em Abrir local do arquivo.
  3. Localize e clique com o botão direito do mouse no instalador.

    Recolher esta imagemExpandir esta imagem
    Permissão Controle de Conta de Usuário
    Caso seja solicitada a senha de administrador ou a confirmação, digite a senha ou clique em Permitir.
  4. Execute as instruções para desinstalar o programa.

Iniciar o instalador pela mídia de instalação do programa

Se o instalador não estiver no menu Iniciar ou na pasta de instalação, será possível encontrá-lo na mídia de instalação do programa. Por exemplo, a mídia pode ser um CD ou um DVD.

Se uma mensagem de erro for exibida ao executar o instalador ou se o instalador não desinstalar o programa, use um dos métodos a seguir.

Usar o Assistente de Compatibilidade de Programa para reinstalar o instalador do programa

Se o instalador não funcionar corretamente, o Assistente de Compatibilidade de Programa poderá ser iniciado automaticamente. Para usar o Assistente de Compatibilidade de Programa, execute as seguintes etapas:
  1. Clique em Reinstalar usando configurações recomendadas.

    Recolher esta imagemExpandir esta imagem
    Permissão Controle de Conta de Usuário
    Caso seja solicitada a senha de administrador ou a confirmação, digite a senha ou clique em Permitir.
  2. Execute as instruções para desinstalar o programa.

Configurar o instalador original para usar o modo de compatibilidade

Para configurar o instalador original para usar o modo de compatibilidade, execute as seguintes etapas:
  1. Clique com o botão direito do mouse no instalador do programa e clique em Propriedades.
  2. Clique na guia Compatibilidade.
  3. Marque a caixa de seleção Executar este programa no modo de compatibilidade.
  4. Na lista, clique em Windows XP (Service Pack 2) e em OK.
  5. Clique duas vezes no instalador.

    Recolher esta imagemExpandir esta imagem
    Permissão Controle de Conta de Usuário
    Caso seja solicitada a senha de administrador ou a confirmação, digite a senha ou clique em Permitir.
  6. Execute as instruções para desinstalar o programa.

Método 3: Usar o pacote .msi do programa para desinstalar o programa

Para usar o pacote .msi do programa para desinstalar o programa, execute as seguintes etapas:
  1. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    o botão Iniciar
    , digite %windir%\Installer na caixa Iniciar pesquisa e pressione ENTER.

    A pasta do instalador é aberta.
  2. No menu Modo de exibição, clique em Detalhes.
  3. Clique com o botão direito do mouse na coluna Nome e clique em Mais.
  4. Marque a caixa de seleção Assunto, digite 340 na caixa Largura da coluna selecionada (em pixels) e clique em OK.

    Observação O processo pode demorar alguns minutos para que os assuntos apareçam ao lado de todos os arquivos .msi.
  5. Clique duas vezes no arquivo .msi do programa.
  6. Execute as instruções para desinstalar o programa.

Método 4: Usar o pacote .msi do programa com o registro do instalador habilitado

Para criar um registro do processo de desinstalação do programa, execute as seguintes etapas:
  1. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    Botão Iniciar
    , digite cmd na caixa Iniciar pesquisa, clique com o botão direito do mouse em cmd.exe na lista Programas e clique em Executar como administrador

    Recolher esta imagemExpandir esta imagem
    Permissão Controle de Conta de Usuário
    Caso seja solicitada a senha de administrador ou a confirmação, digite a senha ou clique em Continuar.
  2. No prompt de comando, digite msiexec /x <nome_do_pacote> /lv* "%userprofile%\desktop\msi.log", onde <nome_do_pacote> é o caminho e o nome do arquivo .msi do programa que você está tentando desinstalar, e pressione ENTER:

    Para obter mais informações sobre o prompt de comando elevado no Windows Vista, visite o seguinte site da Microsoft (em inglês):
    http://technet2.microsoft.com/WindowsVista/en/library/00d04415-2b2f-422c-b70e-b18ff918c2811033.mspx
  3. Execute as instruções para desinstalar o programa.
  4. Abra o arquivo de log .msi na sua área de trabalho. É possível usar esse arquivo de log para pesquisar problemas que ocorram durante o processo de desinstalação do programa.

    Observação Se o processo de desinstalação encontrar um erro, faça uma cópia do arquivo de registro antes de concluir ou cancelar a desinstalação. É possível revisar o arquivo de log no ponto em que o erro ocorreu.
Para obter informações adicionais sobre como habilitar o registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
314852 Como ativar o log do Windows Installer no Windows XP

Método 5: Visitar o site do fornecedor do programa

Visite o site do fornecedor do programa. O fornecedor pode fornecer um desinstalador, um pacote .msi atualizado ou as instruções sobre a remoção manual.

Propriedades

ID do artigo: 927395 - Última revisão: quinta-feira, 21 de fevereiro de 2008 - Revisão: 1.6
A informação contida neste artigo aplica-se a:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
Palavras-chave: 
kbtshoot kbprb kbuninstall kbwindowsinstaller kbexpertisebeginner KB927395

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com