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Setup program crashes when you try to install a 2007 Office suite on a 64-bit version of Windows Server 2003

Article ID:927476
Last Review:October 15, 2007
Revision:3.3

SYMPTOMS

When you try to install a 2007 Microsoft Office suite on a 64-bit version of Microsoft Windows Server 2003, the 2007 Office suite Setup program may abruptly exit or crash.

You may also receive the following error message in the installation log file:
Error: failed MsiEnumProducts ErrorCode: 2(0x2).
Additionally, you may receive the following error when you try to install a 2007 Office suite on a 64-bit Terminal Server:
Setup did not complete successfully. We are sorry for the inconvenience.

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CAUSE

This problem may occur when the 64-bit version of Windows Server 2003 is running Terminal Services in relaxed security mode. The 2007 Office suite Setup program is only supported when Terminal Services is running in full security mode.
Relaxed security mode provides an environment that is compatible with most legacy programs. It also emulates the Windows NT Server 4.0, Terminal Server Edition permissions compatibility mode.
Full security mode helps provides a secure environment, and programs must be written to run in the context of an ordinary user.

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WORKAROUND

To work around this issue, you must run Terminal Services in full security mode. When you run Terminal Services in full security mode, Terminal Server users will have the same permissions as members of the Users group. To do this, follow these steps:
1.Open Terminal Services Configuration.
2.Click Server Settings.
3.Right-click Permission Compatibility, and then click Properties.
4.Click to select the Full Security check box, and then click OK.
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows


Alternatively, follow these steps to work around this issue:
1.Click Start, click Run, type regedit, and then click OK.
2. Expand HKEY_CLASSES_ROOT, right-click Wow6432Node, point to New, and then click Key.
3.Right-click the new registry subkey, click Rename, type Installer, and then press ENTER.
4. Right-click Installer, point to New, and then click Key.
5. Right-click the new registry subkey, click Rename, type Products, and then press ENTER.
6. Exit Registry Editor.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

If you are using a Retail version of a 2007 Office suite or program, the suite or program may not run. For more information, click the following article number about this issue to view the article about this issue in the Microsoft Knowledge Base:
924622 (http://support.microsoft.com/kb/924622/) Error message when you try to start a 2007 Office program within a Terminal Server client session: "This copy of Microsoft Office <Program> cannot be used on Terminal Server"

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APPLIES TO
Microsoft Office Professional Plus 2007
Microsoft Office Enterprise 2007
Microsoft Office Ultimate 2007
Microsoft Office Professional 2007
Microsoft Office Standard 2007
Microsoft Office Home and Student 2007
Microsoft Office Basic 2007
Microsoft Office Groove 2007
Microsoft Office Access 2007
Microsoft Office Excel 2007
Microsoft Office OneNote 2007
Microsoft Office Outlook 2007
Microsoft Office PowerPoint 2007
Microsoft Office Publisher 2007
Microsoft Office Word 2007
Microsoft Office InfoPath 2007
Microsoft Office Project Professional 2007
Microsoft Office Project Standard 2007
Microsoft Office Visio Professional 2007
Microsoft Office Visio Standard 2007

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Keywords: 
kbinstallation kbsetup kbexpertisebeginner kbtshoot kbprb KB927476

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