Impossibile selezionare o formattare una partizione sul disco rigido quando si installa Windows Vista, Windows 7 o Windows Server 2008 R2

Traduzione articoli Traduzione articoli
Identificativo articolo: 927520 - Visualizza i prodotti a cui si riferisce l?articolo.
-

Per continuare a ricevere gli aggiornamenti della protezione per Windows, assicurarsi di eseguire Windows Vista con Service Pack 2 (SP2). Per ulteriori informazioni, fare riferimento a questa pagina Web Microsoft: Per alcune versioni di Windows il servizio di supporto non ? pi? disponibile

Importante I dischi dinamici sono supportati unicamente nelle seguenti versioni:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2

Non sono supportati in Windows Vista Home Basic, Windows Vista Home Premium, Windows 7 Home Basic, Windows 7 Starter e Windows 7 Home Premium.

Esiste un'eccezione. Quando si aggiorna il computer da Windows XP Media Center Edition a Windows Vista Home Premium, alcuni dischi dinamici vengono gestiti e supportati.
Espandi tutto | Chiudi tutto

Sintomi

Quando si tenta di installare Windows Vista, Windows 7 o Windows Server 2008 R2, Ŕ possibile riscontrare uno o pi¨ dei seguenti sintomi:
  • Il disco rigido nel quale si desidera installare Windows Vista, Windows 7 o Windows Server 2008 R2 non Ŕ elencato.
  • Non Ŕ possibile selezionare una partizione del disco rigido su cui installare Windows Vista, Windows 7 or Windows Server 2008 R2.
  • Non Ŕ possibile formattare una o pi¨ partizioni del disco rigido.
  • Non Ŕ possibile impostare la dimensione corretta per una partizione del disco rigido.
  • Viene visualizzato il seguente messaggio di errore:
    Windows: impossibile trovare un volume di sistema che soddisfa i criteri per l'installazione.

Cause

Questo problema pu˛ verificarsi per una delle seguenti ragioni:
  • Windows non Ŕ compatibile con un controller di archiviazione di massa o con un driver di archiviazione di massa.
  • Un controller di archiviazione di massa o un driver di archiviazione di massa non Ŕ aggiornato.
  • Il disco rigido nel quale si desidera installare Windows Vista, Windows 7 o Windows Server 2008 R2 Ŕ un disco dinamico.
  • Un cavo dati all'interno del computer Ŕ scollegato o si Ŕ verificato un altro problema hardware.
  • Il disco rigido o il file system di Windows Ŕ danneggiato.
  • Si Ŕ tentato di selezionare una partizione FAT32 o altro tipo di partizione non compatibile con Windows Vista, Windows 7 o Windows Server 2008 R2.

Risoluzione

Per risolvere questo problema, utilizzare uno o pi¨ metodi descritti di seguito.

Metodo 1: Verificare che la partizione sia compatibile con Windows

Non Ŕ possibile installare Windows su partizioni FAT32. ╚ altresý necessario configurare correttamente i dischi dinamici prima dell'utilizzo con Windows. Per verificare che la partizione sia compatibile con Windows Vista, Windows 7 o Windows Server 2008 R2, attenersi alla procedura seguente:
  1. Per un disco dinamico con un volume semplice, utilizzare l'utilitÓ Diskpart.exe per configurare il disco come attivo. Per ulteriori informazioni su come utilizzare l'utilitÓ Diskpart.exe, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
    300415 Descrizione dell'utilitÓ a riga di comando Diskpart
  2. Per una partizione FAT32, riformattare la partizione o convertirla nel file system NTFS utilizzando il comando Convert.exe.

    Nota Quando si formatta una partizione, tutti i dati in essa contenuti vengono rimossi, inclusi tutti i file presenti nella partizione. Per ulteriori informazioni su come utilizzare il comando Convert.exe, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
    314097 Come utilizzare Convert.exe per convertire una partizione nel file system NTFS

Metodo 2: Aggiornare i driver del controller del disco rigido

Se si desidera installare Windows Vista, Windows 7 o Windows Server 2008 R2 come aggiornamento, aggiornare i driver per il controller del disco rigido alle versioni pi¨ recenti.

Nota L'installazione di Windows fornisce una funzionalitÓ per migrare i driver correnti al nuovo sistema operativo. Pertanto, l'installazione di Windows potrebbe utilizzare i driver attualmente installati nel computer. Se nel computer non sono installati i driver pi¨ recenti, il programma di installazione potrebbe utilizzare quelli non aggiornati, con conseguenti problemi di compatibilitÓ.

Metodo 3: Fornire i driver corretti per il controller del disco rigido

Se si sta tentando di effettuare una nuova installazione di Windows, Ŕ necessario fornire i driver corretti per il controller del disco rigido. Quando viene richiesto di selezionare il disco sul quale installare Windows, Ŕ necessario anche selezionare l'opzione Carica driver. Il programma di installazione di Windows guiderÓ l'utente per il resto del processo.

Metodo 4: esaminare il file Setupact.log per verificare che la partizione sia attiva

Se viene visualizzato il messaggio di errore riportato di seguito, verificare che la partizione sia attiva esaminando il file Setupact.log:
Windows: impossibile trovare un volume di sistema che soddisfa i criteri per l'installazione.
Note
  • Se si installa Windows Vista, Windows 7 o Windows Server 2008 R2 come aggiornamento, il file Setupact.log file si trova nella cartella UnitÓ:\$WINDOWS.~BT\Sources\Panther. UnitÓ rappresenta l'unitÓ che contiene l'installazione esistente di Windows..
  • Se si esegue una nuova installazione di Windows Vista, Windows 7 o Windows Server 2008 R2, il file Setupact.log file si trova nella cartella UnitÓ:\$WINDOWS\Sources\Panther. UnitÓ rappresenta l'unitÓ DVD che contiene i file di installazione di Windows.
Per verificare che la partizione sia attiva, attenersi alla seguente procedura:
  1. Inserire il DVD nell'unitÓ DVD.
  2. Nella schermata di selezione del disco, premere SHIFT+F10. VerrÓ visualizzata la finestra del prompt dei comandi.
  3. Modificare la directory per individuare il file Setupact.log, quindi aprirlo.
  4. Individuare la sezione "DumpDiskInformation" che contiene informazioni sul mapping delle partizioni.
  5. Nella sezione "DumpDiskInformation", individuare la voce di registro analoga alla seguente.
    Disk [0] partition [1] is an active partition
  6. Se questa voce di registro Ŕ visualizzata dopo una voce analoga alla seguente, il disco rigido potrebbe non essere configurato per l'utilizzo di un sistema operativo basato su Windows.
    Unknown (Sconosciuto)
    In questo caso, utilizzare l'utilitÓ Diskpart.exe per configurare una partizione diversa come attiva.

    Nota Questo passaggio impedisce l'avvio di un sistema operativo di terze parti.
  7. Chiudere la finestra del prompt dei comandi.

Metodo 5: Verificare la presenza di aggiornamenti del firmware e del BIOS del sistema

Per aggiornamenti del firmware e del BIOS del sistema e contattare il produttore hardware del computer, visitare il seguente sito Web:
http://support.microsoft.com/gp/vendors

Metodo 6: verificare che il BIOS di sistema rilevi correttamente il disco rigido

Per informazioni su come verificare che il BIOS di sistema rilevi correttamente il disco rigido, contattare il produttore dell'hardware del computer.

Metodo 7: utilizzare l'utilitÓ Chkdsk.exe per verificare l'eventuale presenza di problemi

Eseguire l'utilitÓ Chkdsk.exe per verificare se il disco presenta dei problemi. Sostituire il disco rigido se Ŕ danneggiato.

Metodo 8: Utilizzare l'utilitÓ Diskpart.exe per pulire il disco, quindi eseguire nuovamente l'installazione di Windows

Se si sono tentati tutti i metodi elencati in questa sezione e il problema persiste, utilizzare l'utilitÓ Diskpart.exe per pulire il disco, quindi eseguire nuovamente l'installazione di Windows.

Nota Utilizzare questo metodo unicamente se si intende procedere a una nuova installazione di Windows. Quando si pulisce il disco, questo viene formattato. Tutte le partizioni e tutti i dati presenti sul disco vengono eliminati definitivamente. Si consiglia di eseguire il backup dei file sul disco rigido prima di pulirlo.

Per utilizzare l'utilitÓ Diskpart.exe per pulire il disco rigido, attenersi alla seguente procedura:
  1. Inserire il DVD nell'unitÓ DVD.
  2. Nella schermata di selezione del disco, premere SHIFT+F10. VerrÓ visualizzata la finestra del prompt dei comandi.
  3. Digitare diskpart e premere INVIO per avviare lo strumento.
  4. Digitare list disk, quindi premere INVIO. VerrÓ visualizzato un elenco di dischi rigidi disponibili.
  5. Digitaresel disk numero, quindi premere INVIO. numero del disco rigido che si desidera pulire.. A questo punto il disco rigido Ŕ selezionato.
  6. Digitare det disk, quindi premere INVIO. VerrÓ visualizzato un elenco delle partizioni presenti sul disco rigido. Utilizzare queste informazioni per verificare che sia selezionato il disco corretto.
  7. Assicurarsi che il disco non contenga dati necessari, digitare clean all, quindi premere INVIO per pulire il disco. Tutte le partizioni e tutti i dati presenti sul disco vengono rimossi definitivamente.
  8. Digitare exit e premere INVIO per chiudere lo strumento.
  9. Chiudere la finestra del prompt dei comandi.
  10. Fare clic sul pulsante Aggiorna per aggiornare la schermata di selezione del disco. In questo passaggio viene elencato il disco.
  11. Eseguire il programma di installazione di Windows per effettuare un'installazione nuova.

ProprietÓ

Identificativo articolo: 927520 - Ultima modifica: domenica 25 settembre 2011 - Revisione: 3.0
Le informazioni in questo articolo si applicano a:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
  • Windows 7 Enterprise
  • Windows 7 Enterprise N
  • Windows 7 Professional
  • Windows 7 Professional N
  • Windows 7 Ultimate
  • Windows 7 Ultimate N
Chiavi:á
kbexpertisebeginner kbtshoot kbprb KB927520
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com