Windows를 설치하려고 할 때 하드 디스크 파티션을 선택하거나 포맷할 수 없습니다.

이 문서에서는 Windows를 설치하려고 할 때 하드 디스크 파티션을 선택하거나 포맷하지 못하는 문제에 대한 해결 방법을 제공합니다.

적용 대상: Windows 7 Service Pack 1, Windows Server 2012 R2
원본 KB 번호: 927520

참고

서비스 팩이 설치되지 않은 Windows Vista에 대한 지원은 2010년 4월 13일에 종료되었습니다. Windows용 보안 업데이트를 계속 받으려면 SP2(서비스 팩 2)를 사용하여 Windows Vista를 실행하고 있는지 확인합니다. 자세한 내용은 일부 버전의 Windows에 대한 지원이 종료됨을 참조하세요.

중요

동적 디스크는 다음에서만 지원됩니다.

  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate.
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2

Windows Vista Home Basic, Windows Vista Home Premium, Windows 7 Home Basic, Windows 7 Starter 및 Windows 7 Home Premium에는 지원되지 않습니다.

한 가지 예외가 있습니다. 컴퓨터를 Windows XP Media Center Edition에서 Windows Vista Home Premium으로 업그레이드하면 일부 동적 디스크가 처리되고 지원됩니다.

증상

Windows Vista, Windows 7 또는 Windows Server 2008 R2를 설치하려고 하면 다음 증상 중 하나 이상이 발생할 수 있습니다.

  • Windows Vista, Windows 7 또는 Windows Server 2008 R2is를 설치하려는 하드 디스크가 목록에 없습니다.

  • Windows Vista, Windows 7 또는 Windows Server 2008 R2를 설치할 하드 디스크 파티션을 선택할 수 없습니다.

  • 하드 디스크 파티션 또는 파티션의 형식을 지정할 수 없습니다.

  • 하드 디스크 파티션에 대한 올바른 크기를 설정할 수 없습니다.

  • 다음과 유사한 오류 메시지가 나타납니다.

    Windows에서 설치 기준을 충족하는 시스템 볼륨을 찾을 수 없습니다.

원인

이 문제는 다음 이유 중 하나로 인해 발생할 수 있습니다.

  • Windows는 대용량 스토리지 컨트롤러 또는 대용량 스토리지 드라이버와 호환되지 않습니다.
  • 대용량 스토리지 컨트롤러 또는 대용량 스토리지 드라이버가 오래되었습니다.
  • Windows Vista, Windows 7 또는 Windows Server 2008 R2를 설치하려는 하드 디스크는 동적 디스크입니다.
  • 컴퓨터의 데이터 케이블이 느슨하거나 다른 하드웨어 문제가 발생했습니다.
  • 하드 디스크 또는 Windows 파일 시스템이 손상되었습니다.
  • FAT32 파티션 또는 Windows Vista, Windows 7 또는 Windows Server 2008 R2와 호환되지 않는 다른 유형의 파티션을 선택하려고 했습니다.

이 문제를 resolve 하려면 다음 방법 중 하나 이상을 사용합니다.

해결 방법 1: 파티션이 Windows와 호환되는지 확인

FAT32 파티션에는 Windows를 설치할 수 없습니다. 또한 Windows에서 사용할 동적 디스크를 올바르게 구성해야 합니다. 파티션이 Windows Vista, Windows 7 또는 Windows Server 2008 R2와 호환되는지 확인하려면 다음 단계를 수행합니다.

  1. 간단한 볼륨이 있는 동적 디스크의 경우 Diskpart.exe 유틸리티를 사용하여 디스크를 활성 디스크로 구성합니다. Diskpart.exe 유틸리티를 사용하는 방법에 대한 자세한 내용은 DiskPart Command-Line 옵션을 참조하세요.

  2. FAT32 파티션의 경우 파티션을 다시 포맷하거나 Convert.exe 명령을 사용하여 파티션을 NTFS 파일 시스템 파티션으로 변환합니다.

    참고

    파티션의 서식을 지정하면 파티션에서 모든 데이터가 제거됩니다. 이 데이터에는 파티션의 모든 파일이 포함됩니다.

해결 방법 2: 하드 디스크 컨트롤러용 드라이버 업데이트

Windows Vista Windows 7 또는 Windows Server 2008 R2를 업그레이드로 설치하려면 하드 디스크 컨트롤러용 드라이버를 최신 드라이버로 업데이트합니다.

참고

Windows 설치 프로그램은 현재 드라이버를 새 운영 체제로 마이그레이션하는 기능을 제공합니다. 따라서 Windows 설치 프로그램은 컴퓨터에 현재 설치된 드라이버를 사용할 수 있습니다. 컴퓨터에 최신 드라이버가 설치되어 있지 않은 경우 설치 프로그램에서 오래된 드라이버를 사용할 수 있습니다. 이 경우 호환성 문제가 발생할 수 있습니다.

해결 방법 3: 하드 디스크 컨트롤러에 올바른 드라이버 제공

Windows의 클린 설치를 수행하려는 경우 하드 디스크 컨트롤러에 올바른 드라이버를 제공해야 합니다. Windows를 설치할 디스크를 선택하라는 메시지가 표시되면 드라이버 로드 옵션도 클릭해야 합니다. Windows 설치 프로그램은 나머지 프로세스를 안내합니다.

해결 방법 4: Setupact.log 파일을 검사하여 파티션이 활성 상태인지 확인합니다.

다음 오류 메시지가 표시되면 Setupact.log 파일을 검사하여 파티션이 활성 상태인지 확인합니다.

Windows에서 설치 기준을 충족하는 시스템 볼륨을 찾을 수 없습니다.

참고

  • Windows Vista, Windows 7 또는 Windows Server 2008 R2를 업그레이드로 설치하는 경우 Setupact.log 파일은 Drive:$WINDOWS.~BT\Sources\Panther 폴더에 있습니다. 드라이브 는 기존 Windows 설치가 포함된 드라이브를 나타냅니다.
  • Windows Vista, Windows 7 또는 Windows Server 2008 R2의 클린 설치를 수행하는 경우 Setupact.log 파일은 Drive:$WINDOWS\Sources\Panther 폴더에 있습니다. 드라이브 는 Windows 설치 파일이 포함된 DVD 드라이브를 나타냅니다.

파티션이 활성 상태인지 확인하려면 다음 단계를 수행합니다.

  1. DVD 드라이브에 DVD를 삽입합니다.

  2. 디스크 선택 화면에서 Shift+F10을 누릅니다. CMD( 명령 프롬프트 ) 창이 열립니다.

  3. 디렉터리를 변경하여 Setupact.log 파일을 찾은 다음, Setupact.log 파일을 엽니다.

  4. DumpDiskInformation 섹션을 찾습니다. 이 섹션에는 파티션 매핑에 대한 정보가 포함되어 있습니다.

  5. DumpDiskInformation 섹션에서 다음과 유사한 로그 항목을 찾습니다.

    디스크 [0] 파티션 [1]이(가) 활성 파티션입니다.

  6. 이 로그 항목이 다음과 유사한 항목 다음에 나타나는 경우 하드 디스크가 Windows 기반 운영 체제를 사용하도록 구성되지 않을 수 있습니다.

    알 수 없음

    이 경우 Diskpart.exe 유틸리티를 사용하여 다른 파티션을 활성으로 구성합니다.

    참고

    이 단계에서는 타사 운영 체제가 시작되지 않도록 방지합니다.

  7. 명령 프롬프트 창을 닫습니다.

해결 방법 5: 펌웨어 업데이트 및 시스템 BIOS 업데이트 확인

펌웨어 업데이트 및 시스템 BIOS 업데이트는 컴퓨터의 하드웨어 제조업체에 문의하세요.

해결 방법 6: 시스템 BIOS가 하드 디스크를 올바르게 검색했는지 확인

시스템 BIOS가 하드 디스크를 올바르게 검색하는지 확인하는 방법에 대한 자세한 내용은 컴퓨터 하드웨어 제조업체에 문의하세요.

해결 방법 7: Chkdsk.exe 사용하여 문제 검사

Chkdsk.exe 유틸리티를 실행하여 디스크 문제를 검사. 손상된 경우 하드 디스크를 교체합니다.

해결 방법 8: Diskpart.exe 사용하여 디스크 클린 Windows 설치 프로그램 다시 실행

이 섹션에 나열된 모든 메서드를 시도했지만 문제가 지속되면 Diskpart.exe 유틸리티를 사용하여 디스크를 클린 Windows 설치 프로그램을 다시 실행합니다.

참고

Windows의 클린 설치를 수행하려는 경우에만 이 메서드를 사용합니다. 하드 디스크를 클린 경우 포맷됩니다. 하드 디스크의 모든 파티션과 모든 데이터는 영구적으로 제거됩니다. 디스크를 클린 전에 하드 디스크의 파일을 백업하는 것이 좋습니다.

Diskpart.exe 유틸리티를 사용하여 하드 디스크를 클린 다음 단계를 수행합니다.

  1. DVD 드라이브에 DVD를 삽입합니다.
  2. 디스크 선택 화면에서 Shift+F10을 누릅니다. 명령 프롬프트 창이 열립니다.
  3. diskpart를 입력한 다음 Enter 키를 눌러 diskpart 도구를 엽니다.
  4. list disk을(를) 입력한 다음 Enter 키를 누릅니다. 사용 가능한 하드 디스크 목록이 표시됩니다.
  5. sel disk number을(를) 입력한 다음 Enter 키를 누릅니다. number는 클린 하드 디스크의 수입니다. 이제 하드 디스크가 선택되었습니다.
  6. det disk을(를) 입력한 다음 Enter 키를 누릅니다. 하드 디스크의 파티션 목록이 표시됩니다. 이 정보를 사용하여 올바른 디스크가 선택되었는지 확인합니다.
  7. 디스크에 필요한 데이터가 포함되어 있지 않은지 확인하고 를 입력clean all한 다음 Enter 키를 눌러 디스크를 클린. 모든 파티션 및 디스크의 모든 데이터가 영구적으로 제거됩니다.
  8. 를 입력 exit한 다음 Enter 키를 눌러 diskpart 도구를 닫습니다.
  9. 명령 프롬프트 창을 닫습니다.
  10. 새로 고침 단추를 클릭하여 디스크 선택 화면을 업데이트합니다. 이 단계에서는 디스크를 나열합니다.
  11. Windows 설치 프로그램을 실행하여 Windows의 클린 설치를 수행합니다.