Non Ŕ possibile installare un driver di dispositivo utilizzando il relativo programma di installazione in Windows Vista

Traduzione articoli Traduzione articoli
Identificativo articolo: 927524 - Visualizza i prodotti a cui si riferisce l?articolo.
-

Per continuare a ricevere gli aggiornamenti della protezione per Windows, assicurarsi di eseguire Windows Vista con Service Pack 2 (SP2). Per ulteriori informazioni, fare riferimento a questa pagina Web Microsoft: Per alcune versioni di Windows il servizio di supporto non Ŕ pi¨ disponibile

Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Non Ŕ possibile completare l'installazione di un driver di dispositivo utilizzando il relativo programma di installazione in Windows Vista.

Questo problema pu˛ verificarsi in presenza delle seguenti condizioni:
  • Il driver utilizza un programma di installazione basato su file eseguibile.
  • Il programma di installazione non Ŕ progettato per Windows Vista.

Cause

I problemi con i programmi di installazione basati su file eseguibili possono verificarsi in presenza di una o pi¨ delle seguenti condizioni:
  • Il programma di installazione Ŕ incompatibile con Windows Vista.
  • Il driver Ŕ incompatibile con Windows Vista.
  • Si verifica un problema correlato ai diritti utente richiesti per installare il driver.

Risoluzione

Per risolvere il problema, eseguire il programma di installazione del driver in modalitÓ compatibilitÓ. In alternativa, utilizzare un account che dispone delle credenziali amministrative per eseguire il programma di installazione del driver. ╚ inoltre possibile individuare il file con estensione inf relativo al driver, quindi installare manualmente il driver.

Importante Prima di utilizzare uno di questi metodi, si consiglia di contattare il produttore del dispositivo o del driver per ulteriori informazioni sull'installazione del driver in Windows Vista.

Per eseguire il programma di installazione del driver in modalitÓ compatibilitÓ

Configurare il programma di installazione del driver affinchÚ venga eseguito in modalitÓ compatibilitÓ di Microsoft Windows XP Service Pack 2. A questo scopo, attenersi alla procedura seguente:
  1. Individuare il file eseguibile relativo al programma di installazione del driver.
  2. Fare clic con il pulsante destro del mouse sul file e scegliere ProprietÓ.
  3. Nella finestra di dialogo ProprietÓ NomePacchetto scegliere la scheda CompatibilitÓ.
  4. Selezionare la casella di controllo Esegui il programma in modalitÓ compatibilitÓ per fare clic su Windows XP (Service Pack 2) nell'elenco Esegui il programma in modalitÓ compatibilitÓ per, quindi scegliere OK.
  5. Fare doppio clic sul file eseguibile per avviare il programma di installazione.

Per eseguire il programma di installazione del driver utilizzando le credenziali amministrative

Configurare il programma di installazione del driver affinchÚ venga eseguito nel contesto dell'account Administrator. A questo scopo, attenersi alla procedura seguente:
  1. Individuare il file eseguibile relativo al programma di installazione del driver.
  2. Fare clic con il pulsante destro del mouse sul file, quindi scegliere Esegui come amministratore.

    Riduci l'immagineEspandi l'immagine
    Autorizzazione Controllo
				di accesso utente
    Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Continua.
  3. Seguire le istruzioni visualizzate per installare il driver.

Per individuare il file con estensione inf e installare manualmente il driver

Utilizzare Gestione dispositivi per installare il driver. Per eseguire questa operazione, attenersi alla procedura descritta di seguito.

Passaggio 1: Individuare il file con estensione inf

Individuare il file inf incluso nel programma di installazione del driver. In genere il file con estensione inf si trova in una delle seguenti cartelle sul supporto di installazione del driver:
  • Nella stessa cartella del programma di installazione.
  • In una sottocartella della cartella contenente il programma di installazione. Il nome della sottocartella Ŕ generalmente analogo a Windows XP, Drivers o WinXP.
Se i file del driver sono inclusi in un unico file eseguibile, Ŕ possibile estrarli o accedervi. Per effettuare questa operazione, utilizzare uno dei metodi riportati di seguito in base alla situazione.
  • Utilizzare un programma di compressione file per estrarre i file.

    Se i file del driver sono inclusi in un unico file eseguibile, Ŕ possibile utilizzare uno strumento di compressione file, ad esempio WinZip o WinRAR, per estrarre il contenuto del pacchetto driver in una cartella. Tra i file estratti dovrÓ essere presente il file con estensione inf.
  • Per estrarre i file, utilizzare la funzionalitÓ Cartelle compresse di Windows.

    Se il programma WinZip o WinRAR non Ŕ disponibile, Ŕ possibile estrarre i file utilizzando la funzionalitÓ Cartelle compresse di Windows. Per effettuare questa operazione, modificare l'estensione di file da exe in zip. Utilizzare quindi Esplora risorse per copiare i file dalla cartella compressa.
  • Estrarre il contenuto dal file CAB.

    Se nel pacchetto driver non Ŕ incluso un file con estensione inf, ma sono disponibili uno o pi¨ file CAB, Ŕ possibile estrarre il contenuto dei file CAB.

    Nota Questo metodo solitamente non ha esito positivo. In genere questi tipi di pacchetti driver vengono creati tramite il programma InstallShield. Questo programma utilizza uno speciale formato di file CAB che non Ŕ progettato per consentire l'accesso da parte di strumenti come WinZip o WinRAR.
  • Individuare i file nella cartella Temp.

    Se ancora non Ŕ possibile accedere ai file di installazione, provare a individuare i file temporanei estratti. Generalmente i file vengono estratti in una cartella Temp locale quando si installa un programma. Esaminando il contenuto della cartella Temp, Ŕ possibile visualizzare il contenuto del pacchetto driver. A questo scopo, attenersi alla procedura seguente:
    1. Rimuovere il contenuto della cartella Temp. La rimozione del contenuto della cartella Temp consente di individuare pi¨ facilmente i file temporanei creati durante l'esecuzione del programma di installazione del driver. Per rimuovere il contenuto della cartella Temp, attenersi alla seguente procedura:
      1. Fare clic sul pulsante Start
        Riduci l'immagineEspandi l'immagine
        Pulsante Start
        , quindi scegliere Computer.
      2. Fare clic con il pulsante destro del mouse sul disco rigido in cui Ŕ installato Windows Vista, quindi scegliere ProprietÓ.
      3. Nella finestra di dialogo ProprietÓ disco localeLetteraUnitÓ fare clic sulla scheda Generale, quindi scegliere Pulizia disco.
      4. Nella finestra di dialogo Opzioni Pulizia disco fare clic su File di tutti gli utenti sul computer in uso.

        Riduci l'immagineEspandi l'immagine
        Autorizzazione Controllo di accesso
						  utente
        Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Continua.
      5. In File da eliminare deselezionare tutte le caselle di controllo, selezionare la casella di controllo File temporanei, quindi scegliere OK.
      6. Quando viene chiesto di confermare l'eliminazione definitiva dei file, fare clic su Elimina file.
    2. Utilizzare Esplora risorse per aprire la cartella Temp. A questo scopo, fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
      Pulsante
					 Start
      , digitare %temp% nella casella Inizia ricerca, quindi premere INVIO.
    3. Avviare il programma di installazione del driver.

      Nota Alcuni programmi di installazione eliminano automaticamente i file temporanei al momento della chiusura. Lasciare quindi il programma di installazione del driver in esecuzione in background.
    4. Esaminare il contenuto della cartella Temp per individuare i file del driver.

Passaggio 2: Installare manualmente il driver

Dopo avere individuato il file con estensione inf per il driver che si desidera installare, procedere all'installazione manuale del nuovo driver. A questo scopo, attenersi alla procedura seguente:
  1. Fare clic sul pulsante Start
    Riduci l'immagineEspandi l'immagine
    Pulsante Start
    , fare clic con il pulsante destro del mouse su Computer, quindi scegliere ProprietÓ.
  2. Nel riquadro AttivitÓ fare clic su Gestione dispositivi.

    Riduci l'immagineEspandi l'immagine
    Autorizzazione Controllo di accesso
				utente
    Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Continua.
  3. In Gestione dispositivi individuare il dispositivo per cui si desidera installare il driver.

    Nota Per visualizzare i dispositivi nascosti, scegliere Mostra dispositivi nascosti dal menu Visualizza.
  4. Fare clic con il pulsante destro del mouse sul dispositivo, quindi scegliere Aggiornamento software driver.
  5. Fare clic su Cerca il software del driver nel computer, quindi su Scegli manualmente da un elenco di driver di dispositivo nel computer e infine scegliere Disco driver.
  6. Nella finestra di dialogo Installazione da disco floppy scegliere Sfoglia, individuare il file con estensione inf per il driver di dispositivo che si desidera installare, quindi scegliere Apri.
  7. Attenersi alla procedura descritta nella finestra di dialogo Aggiornamento software driver NomeDispositivo per aggiornare il driver.
I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilitÓ di tali prodotti.

ProprietÓ

Identificativo articolo: 927524 - Ultima modifica: domenica 25 settembre 2011 - Revisione: 3.0
Le informazioni in questo articolo si applicano a:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
Chiavi:á
kbdriver kbexpertisebeginner kbhardware kbtshoot kbprb KB927524
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com