기술 자료: 927524 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

Windows Vista에서 장치 드라이버 설치 프로그램을 사용하여 장치 드라이버를 설치하려고 하면 설치가 안 됩니다.

다음과 같은 경우에 이 문제가 발생할 수 있습니다.
  • 드라이버에서 실행 파일 기반 설치 프로그램을 사용합니다.
  • 설치 프로그램이 Windows Vista용으로 설계되지 않았습니다.

원인

다음 조건 중 하나 이상에 해당하면 실행 파일 기반 설치 프로그램과 관련된 문제가 발생할 수 있습니다.
  • 설치 프로그램이 Windows Vista와 호환되지 않습니다.
  • 드라이버가 Windows Vista와 호환되지 않습니다.
  • 드라이버를 설치하는 데 필요한 사용자 권한과 관련된 문제가 발생합니다.

해결 방법

이 문제를 해결하려면 드라이버 설치 프로그램을 호환 모드에서 실행하거나 드라이버 설치 프로그램을 실행할 관리 자격 증명이 있는 계정을 사용해야 합니다. 또한 드라이버의 .inf 파일을 찾은 다음 드라이버를 수동으로 설치할 수도 있습니다.

중요 이러한 방법 중 하나를 사용하기 전에 장치 제조업체나 드라이버 제조업체에 문의하여 Windows Vista에서 드라이버를 설치하는 방법에 대한 자세한 내용을 알아보는 것이 좋습니다.

드라이버 설치 프로그램을 호환 모드에서 실행하는 방법

Microsoft Windows XP 서비스 팩 2 호환 모드에서 실행되도록 드라이버 설치 프로그램을 구성합니다. 이렇게 하려면 다음과 같이 하십시오.
  1. 드라이버 설치 프로그램의 실행 파일을 찾습니다.
  2. 파일을 마우스 오른쪽 단추로 누른 다음 속성을 누릅니다.
  3. PackageName 속성 대화 상자에서 호환성 탭을 누릅니다.
  4. 이 프로그램을 실행할 호환 모드 확인란을 선택하고 이 프로그램을 실행할 호환 모드 목록에서 Windows XP(서비스 팩 2)를 누른 다음 확인을 누릅니다.
  5. 실행 파일을 두 번 눌러 설치 프로그램을 시작합니다.

관리 자격 증명을 사용하여 드라이버 설치 프로그램을 실행하는 방법

관리자 계정의 컨텍스트에서 실행되도록 드라이버 설치 프로그램을 구성합니다. 이렇게 하려면 다음과 같이 하십시오.
  1. 드라이버 설치 프로그램의 실행 파일을 찾습니다.
  2. 파일을 마우스 오른쪽 단추로 누른 다음 관리자 권한으로 실행을 누릅니다.

    그림 축소그림 확대
    사용자 액세스 제어 권한
    관리자 암호나 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 계속을 누릅니다.
  3. 드라이버를 설치하는 단계를 수행합니다.

.inf 파일을 찾고 드라이버를 수동으로 설치하는 방법

장치 관리자를 사용하여 드라이버를 설치합니다. 이렇게 하려면 다음과 같이 하십시오.

1단계: .inf 파일 찾기

드라이버 설치 프로그램에 포함된 .inf 파일을 찾습니다. 일반적으로 .inf 파일은 드라이버 설치 미디어의 다음 폴더 중 하나에 있습니다.
  • 설치 프로그램과 동일한 폴더
  • 설치 프로그램이 포함된 폴더에 있는 하위 폴더. 일반적으로 하위 폴더의 이름은 Windows XP, Drivers, WinXP 등입니다.
드라이버 파일이 단일 실행 파일로 패키지된 경우 드라이버 파일을 추출하거나 드라이버 파일에 액세스할 수 있습니다. 이렇게 하려면 다음 방법 중 상황에 맞는 방법을 사용하십시오.
  • 파일 압축 프로그램을 사용하여 파일 추출

    드라이버 파일이 단일 실행 파일로 패키지된 경우 WinZip이나 WinRAR과 같은 파일 압축 도구를 사용하여 드라이버 패키지의 내용을 폴더에 추출할 수 있습니다. 추출되는 파일에 .inf 파일이 포함되어 있습니다.
  • Windows 압축 폴더 기능을 사용하여 파일을 추출합니다.

    WinZip 프로그램이나 WinRAR 프로그램이 없으면 Windows 압축 폴더 기능을 사용하여 파일을 추출할 수 있습니다. 이렇게 하려면 파일 확장명을 .exe에서 .zip로 변경한 다음 Windows 탐색기를 사용하여 압축된 폴더에서 파일을 복사하십시오.
  • .cab 파일에서 내용을 추출합니다.

    드라이버 패키지에 .inf 파일이 없지만 .cab 파일이 하나 이상 있으면 .cab 파일의 내용을 추출할 수 있습니다.

    참고 이 방법은 대개 실패합니다. 일반적으로 이러한 종류의 드라이버 패키지는 InstallShield 프로그램을 사용하여 만들어집니다. InstallShield 프로그램에서는 WinZip이나 WinRAR과 같은 도구에서 액세스하도록 설계되지 않은 특별한 .cab 형식을 사용합니다.
  • Temp 폴더에서 파일을 찾습니다.

    여전히 설치 파일에 액세스할 수 없으면 추출된 임시 파일을 찾아 봅니다. 프로그램을 설치할 때 대개 로컬 Temp 폴더에 파일이 추출됩니다. Temp 폴더의 내용을 확인하여 드라이버 패키지의 내용을 볼 수 있습니다. 이렇게 하려면 다음과 같이 하십시오.
    1. Temp 폴더의 내용을 제거합니다. Temp 폴더의 내용을 제거하면 드라이버 설치 프로그램을 실행할 때 만들어진 임시 파일을 좀 더 쉽게 찾을 수 있습니다. Temp 폴더의 내용을 제거하려면 다음과 같이 하십시오.
      1. 시작
        그림 축소그림 확대
        시작 단추
        을 누른 다음 컴퓨터를 누릅니다.
      2. Windows Vista가 설치된 하드 디스크를 마우스 오른쪽 단추로 누른 다음 속성을 누릅니다.
      3. 로컬 디스크 (DriveLetter) 속성 대화 상자에서 일반 탭을 누른 다음 디스크 정리를 누릅니다.
      4. 디스크 정리 옵션 대화 상자에서 이 컴퓨터의 모든 사용자 파일을 누릅니다.

        그림 축소그림 확대
        사용자 액세스 제어 권한
        관리자 암호나 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 계속을 누릅니다.
      5. 삭제할 파일에서 모든 확인란의 선택을 취소하고 임시 파일 확인란을 선택한 다음 확인을 누릅니다.
      6. 파일을 영구적으로 삭제할 것인지 물으면 파일 삭제를 누릅니다.
    2. Windows 탐색기를 사용하여 Temp 폴더를 엽니다. 이렇게 하려면 시작
      그림 축소그림 확대
      시작 단추
      을 누르고 검색 시작 상자에 %temp%를 입력한 다음 Enter 키를 누릅니다.
    3. 드라이버 설치 프로그램을 시작합니다.

      참고 일부 설치 프로그램은 설치 프로그램이 종료될 때 임시 파일을 자동으로 삭제하므로 드라이버 설치 프로그램이 백그라운드로 실행되도록 두십시오.
    4. Temp 폴더의 내용을 확인하여 드라이버 파일을 찾습니다.

2단계: 수동으로 드라이버 설치

설치할 드라이버의 .inf 파일을 찾은 후 새 드라이버를 수동으로 설치합니다. 이렇게 하려면 다음과 같이 하십시오.
  1. 시작
    그림 축소그림 확대
    시작 단추
    을 누르고 컴퓨터를 마우스 오른쪽 단추로 누른 다음 속성을 누릅니다.
  2. 작업 창에서 장치 관리자를 누릅니다.

    그림 축소그림 확대
    사용자 액세스 제어 권한
    관리자 암호나 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 계속을 누릅니다.
  3. 장치 관리자에서 드라이버를 설치할 장치를 찾습니다.

    참고 숨겨진 장치를 표시하려면 보기 메뉴에서 숨김 장치 표시를 누릅니다.
  4. 장치를 마우스 오른쪽 단추로 누른 다음 드라이버 소프트웨어 업데이트를 누릅니다.
  5. 컴퓨터에서 드라이버 소프트웨어 찾아보기를 누르고 컴퓨터의 장치 드라이버 목록에서 직접 선택을 누른 다음 디스크 있음을 누릅니다.
  6. 디스크에서 설치 대화 상자에서 찾아보기를 누르고 설치할 장치 드라이버의 .inf 파일을 찾은 다음 열기를 누릅니다.
  7. 드라이버 소프트웨어 업데이트 - DeviceName 대화 상자의 단계를 수행하여 드라이버를 업데이트합니다.
이 문서에 나와 있는 다른 공급업체 제품은 Microsoft와 무관한 회사에서 제조한 것입니다. Microsoft는 이러한 제품의 성능이나 신뢰성에 관하여 명시적이든 묵시적이든 어떠한 보증도 하지 않습니다.



Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.

속성

기술 자료: 927524 - 마지막 검토: 2011년 8월 29일 월요일 - 수정: 2.3
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
키워드:?
kbdriver kbexpertisebeginner kbhardware kbtshoot kbprb KB927524

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com