Logga in med Microsoft
Logga in eller skapa ett konto.
Hej,
Välj ett annat konto.
Du har flera konton
Välj det konto som du vill logga in med.

Symptom

När du har installerat en enhet eller uppdaterat en drivrutin för en enhet på en dator med Windows Vista eller Windows 7, startar inte operativsystemet.

Orsak

Detta kan inträffa om någon av följande förutsättningar föreligger:

  • Den nya enheten eller drivrutinen orsakar konflikter med andra drivrutiner på datorn.

  • Det uppstår ett maskinvaruproblem.

  • Den installerade drivrutinen är skadad.

Lösning

Lös problemet genom att ta reda på den exakta orsaken med följande åtgärder för felsökning, och vidta sedan lämpliga åtgärder.

Starta Windows Vista eller Windows 7

  1. Om du har installerat en ny enhet tar du bort den och försöker sedan starta om datorn. Om -operativsystemet inte startar går du till steg 2. Om -operativsystemet startar går du till avsnittet "Åtgärda orsaken till startproblemet" i den här artikeln.

  2. Starta datorn och tryck på F8. Välj Senast fungerande konfiguration på skärmen Avancerade startalternativ och tryck på RETUR. Om -operativsystemet inte startar går du till steg 3. Om -operativsystemet startar går du till avsnittet "Åtgärda orsaken till startproblemet" i den här artikeln.

  3. Starta datorn och tryck på F8. Klicka på Felsäkert läge på skärmen Avancerade startalternativ och tryck på RETUR. Om -operativsystemetstartar i felsäkert läge går du till avsnittet "Åtgärda orsaken till startproblemet" i den här artikeln. Om du inte kan starta -operativsystemet i felsäkert läge går du till avsnittet "Använda återställningsmiljön i Windows för att reparera startproblem i Windows Vista eller Windows 7" i den här artikeln.

Använda återställningsmiljön i Windows för att reparera startproblem i Windows Vista eller Windows 7

Viktigt! Den här artikeln innehåller information om hur du redigerar registret. Det kan uppstå allvarliga problem om du gör detta felaktigt. Följ därför instruktionerna noga, och säkerhetskopiera registret innan du gör några ändringar i det. Då kan du återställa registret om det uppstår problem. Om du vill veta mer om hur du säkerhetskopierar och återställer registret, klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:

322756 Säkerhetskopiera och återställa registret i Windows

För att kunna använda återställningsmiljön i Windows måste du ha installationsskivan för Windows Vista eller Windows 7 Så här startar du återställningsmiljön i Windows:

  1. Sätt in installationsskivan för i diskenheten och starta datorn.

  2. Tryck på en tangent när du uppmanas till detta.

  3. Välj språk, tid och valuta samt tangentbord eller inmatningsmetod och klicka på Nästa.

  4. Klicka på Reparera datorn.

  5. I dialogrutan Systemåterställningsalternativ klickar du på operativsystemet du vill reparera och sedan på Nästa.

Använda verktygen i återställningsmiljön i Windows för att reparera Windows Vista eller Windows 7 Gör så här:

  1. Om datorn inte startar i säkert läge klickar du på Startreparation i dialogrutan Systemåterställningsalternativ för att åtgärda vissa problem som kan förhindra att -operativsystemet startar på rätt sätt. Om verktyget Startreparation inte kan diagnostisera eller reparera problemet går du till steg 2. Om Windows Vista eller Windows 7 startar går du till avsnittet "Åtgärda orsaken till startproblemet".

    Om du vill veta mer om hur du använder Startreparation klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:

    925810 Ett stoppfel inträffar eller också slutar datorn att svara när du försöker starta Windows Vista eller Windows 7

  2. Klicka på Systemåterställning i dialogrutan Systemåterställningsalternativ, så att -operativsystemet återställs till återställningspunkten som skapades när programmet eller drivrutinen installerades. Om du inte kan starta datorn med Systemåterställning går du till steg 3.

  3. Använd Kommandotolken i återställningsmiljön i Windows för att inaktivera drivrutinen som förhindrar att -operativsystemet startar. Gör så här:

    1. Klicka på Kommandotolken i dialogrutan Systemåterställningsalternativ.

    2. Skriv följande kommandon. Tryck på RETUR efter varje kommando.

      cd \Windows\INF
      notepad setupapi.app.log

    3. Anteckna datumet i början av varje nytt avsnitt för en enhets- eller drivrutinsinstallation, och använd datumen för att ta reda på när den senaste drivrutinen installerades.

    4. När du har tagit reda på vilken drivrutin som installerades senast, tar du reda på vilken drivrutin som behövs för att starta datorn. Gör det genom att läsa informationen i avsnittet i filen Setupapi.app.log som beskriver drivrutinen. Om drivrutinen hör till diskstyrenheten eller kretsuppsättningen, eller om drivrutinen tillhandahålls av operativsystemet, söker du efter namnet på drivrutinen och problemsymptomet på följande Microsoft-webbplats:

      http://www.microsoft.com/sv/se/default.aspx Ta reda på om drivrutinen kan inaktiveras innan du fortsätter. Om den senaste drivrutinen som installerades inte behövs för start av datorn går du till steg e.

    5. Skriv regedit vid kommandotolken och klicka på OK.

    6. Klicka på HKEY_LOCAL_MACHINE och klicka sedan på Läs in registreringsdatafilArkiv-menyn.

    7. Leta upp och klicka på filen C:\Windows\System32\Config\System, och klicka sedan på Öppna.

    8. I dialogrutan Läs in registreringsdatafil skriver du Offline och klickar på OK.

    9. Expandera System och klicka på Select.

    10. Leta upp Current i den högra rutan och anteckna värdet i kolumnen Data.

    11. Expandera ControlSet00x och sedan Services. x är värdet från kolumnen Data du antecknade i steg j.

    12. Leta upp undernyckeln som motsvarar den senaste drivrutinen som installerades. Om du inte hittar en sådan undernyckel gör du följande: klicka på Services, SökRedigera-menyn, skriv namnet på drivrutinen i rutan Sök efter och klicka på Sök nästa.

    13. Klicka på undernyckeln med samma namn som drivrutinen.

    14. Högerklicka på Start i den högra rutan och klicka sedan på Ändra.

    15. I rutan Data skriver du 4 och klickar på OK. Detta förhindrar att drivrutinen startar.

    16. Leta upp och klicka på följande registerundernyckel:

      HKEY_LOCAL_MACHINE\Offline

    17. Klicka på Ta bort registreringsdatafilArkiv-menyn och sedan på Ja i dialogrutan Bekräfta borttagning av registreringsdatafil.

    18. Avsluta Registereditorn.

    19. Starta om datorn.

    20. Om -operativsystemet inte startar, startar du återställningsmiljön i Windows och upprepar åtgärd a till och med s. Du måste kanske upprepa åtgärderna tills alla drivrutiner som har installerats sedan den senaste starten har inaktiverats.

  4. När du kan starta -operativsystemet, kontaktar du tillverkaren av enheten eller drivrutinen för information om kompatibilitetsproblem eller tillgängliga uppdateringar.

Åtgärda orsaken till startproblemet

  1. Öppna Enhetshanteraren så här: klicka på Start Start , skriv Enhetshanteraren i rutan Påbörja sökning och klicka på Enhetshanteraren i listan Program.

  2. Om du har uppdaterat drivrutinen för en enhet gör du följande: högerklicka på enheten i Enhetshanteraren, klicka på Egenskaper och klicka på Återställ tidigare drivrutin på fliken Drivrutin.

  3. Om du har installerat en ny enhet högerklickar du på den i Enhetshanteraren och klickar sedan på Avinstallera.

  4. Om du har installerat ett program som innehåller en ny drivrutin gör du följande:

    1. Klicka på Start Start , skriv appwiz.cpl i rutan Påbörja sökning och klicka på appwiz.cpl i listan Program.

    2. Klicka på det installerade programmet och sedan på Avinstallera/ändra.
      Klicka på Fortsätt om du tillfrågas om du vill fortsätta.

    3. Besvara frågan "Vill du fortsätta?" med Ja.

  5. Starta om Windows Vista eller Windows 7.

Behöver du mer hjälp?

Vill du ha fler alternativ?

Utforska prenumerationsförmåner, bläddra bland utbildningskurser, lär dig hur du skyddar din enhet med mera.

Communities hjälper dig att ställa och svara på frågor, ge feedback och få råd från experter med rika kunskaper.

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?
Genom att trycka på skicka, kommer din feedback att användas för att förbättra Microsofts produkter och tjänster. IT-administratören kan samla in denna data. Sekretesspolicy.

Tack för din feedback!

×