Beim Durchsuchen einer Windows SharePoint Services 3.0-Website werden in den Suchergebnissen keine Adobe PDF-Dokumente zurückgegeben

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 927675 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
927675 No Adobe PDF documents are returned in the search results when you search a Windows SharePoint Services 3.0 Web site
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Alles erweitern | Alles schließen

Problembeschreibung

Stellen Sie sich folgendes Szenario vor: Sie durchsuchen eine Microsoft Windows SharePoint Services 3.0-Website nach Inhalten, die sich in Adobe Portable Document Format (PDF)-Dokumenten befinden. Es werden jedoch keine PDF-Dokumente in den Suchergebnissen zurückgegeben. Dieses Verhalten tritt auf, obwohl sich die gesuchten Inhalte in PDF-Dokumenten auf der Windows SharePoint Services 3.0-Website befinden.

Ursache

Das geschilderte Problem tritt auf, wenn der Windows SharePoint Services-Suchdienst in Windows SharePoint Services 3.0 nicht zum Crawlen von PDF-Dokumenten konfiguriert wurde.

Lösung

Wichtig: Dieser Abschnitt bzw. die Methoden- oder Aufgabenbeschreibung enthält Hinweise zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Als Schutzmaßnahme sollten Sie vor der Bearbeitung eine Sicherungskopie der Registrierung erstellen. So ist gewährleistet, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen und Wiederherstellen einer Sicherungskopie der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756 Unter Windows XP und Windows Server 2003 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen


Um das Problem zu beheben, stellen Sie sicher, dass der Windows SharePoint Services-Suchdienst zum Crawlen von PDF-Dokumenten auf allen Servern konfiguriert ist, auf denen Adobe PDF IFilter installiert ist. Gehen Sie folgendermaßen vor, um Adobe PDF IFilter zu installieren und um den Windows SharePoint Services-Suchdienst zu konfigurieren:
  1. Laden Sie Adobe PDF IFilter von der folgenden Adobe-Website herunter, und installieren Sie ihn:
    http://www.adobe.com/support/downloads/detail.jsp?ftpID=2611
    Die Kontaktinformationen bezüglich der in diesem Artikel erwähnten Fremdanbieter sollen Ihnen helfen, den benötigten technischen Support zu finden. Diese Kontaktinformationen können ohne vorherige Ankündigung geändert werden. Sie werden von Microsoft ohne jede Gewähr weitergegeben.
  2. Fügen Sie den folgenden Registrierungseintrag hinzu, und legen Sie dann den Wert des Registrierungseintrag auf pdf fest:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Applications\<GUID>\Gather\Search\Extensions\ExtensionList\38
    Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie auf Start und auf Ausführen, geben Sie regedit ein, und klicken Sie auf OK.
    2. Klicken Sie auf den folgenden Registrierungsunterschlüssel:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Applications\GUID\Gather\Search\Extensions\ExtensionList
    3. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie anschließend auf Zeichenfolge.
    4. Geben Sie 38 ein, und drücken Sie die [EINGABETASTE].
    5. Klicken Sie mit der rechten Maustaste auf den erstellten Registrierungseintrag, und klicken Sie dann auf Ändern.
    6. Geben Sie pdf im Feld Wert ein, und klicken Sie dann auf OK.
  3. Überprüfen Sie, ob die folgenden beiden Registrierungsunterschlüssel vorhanden sind und die entsprechenden Werte enthalten.

    Hinweis: Diese Registrierungsunterschlüssel und die enthaltenen Werte werden bei der Installation von Adobe PDF IFilter auf dem Server erstellt.
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf
      Dieser Registrierungsunterschlüssel muss den folgenden Registrierungseintrag enthalten:
      • Name: Default
        Typ: REG_MULTI_SZ
        Wert: {4C904448-74A9-11D0-AF6E-00C04FD8DC02}
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\Filters\.pdf
      Dieser Registrierungsunterschlüssel muss die folgenden Registrierungseinträge enthalten:
      • Name: Default
        Typ: REG_SZ
        Wert: (Wert nicht gesetzt)
      • Name: Extension
        Typ: REG_SZ
        Wert: pdf
      • Name: FileTypeBucket
        Typ: REG_DWORD
        Wert: 0x00000001 (1)
      • Name: MimeTypes
        Typ: REG_SZ
        Wert: application/pdf
  4. Laden Sie die PDF-Dokumente auf die Windows SharePoint Services 3.0-Website hoch.
  5. Beenden Sie den Windows SharePoint Services-Suchdienst und starten Sie den Dienst erneut. Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie auf Start und auf Ausführen, geben Sie cmd ein, und klicken Sie auf OK.
    2. Beenden Sie den Windows SharePoint Services-Suchdienst. Geben Sie hierzu an der Eingabeaufforderung net stop spsearch ein, und drücken Sie die [EINGABETASTE].
    3. Starten Sie den Windows SharePoint Services-Suchdienst. Geben Sie hierzu an der Eingabeaufforderung net start spsearch ein, und drücken Sie die [EINGABETASTE].
    4. Geben Sie exit ein, um die Eingabeaufforderung zu beenden.
Hinweis: Wenn auf der Windows SharePoint Services 3.0-Website bereits PDF-Dokumente vorhanden waren, bevor Sie Adobe PDF IFilter auf dem Server installiert haben, müssen Sie möglicherweise einen zusätzlichen Schritt ausführen. Ändern Sie nach der Installation und Konfiguration von Adobe PDF IFilter auf dem Server eine Eigenschaft der vorhandenen PDF-Dokumente auf dem Server. Ändern Sie beispielsweise eine Metadateneigenschaft wie den Titel, oder laden Sie die PDF-Dokumente erneut auf die Windows SharePoint Services-Website hoch. In diesem Fall crawlt der Windows SharePoint Services-Suchdienst die vorhandenen PDF-Dokumente erneut.

Weitere Informationen

Die in diesem Artikel genannten Fremdanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Eigenschaften

Artikel-ID: 927675 - Geändert am: Dienstag, 3. Juni 2008 - Version: 1.3
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows SharePoint Services 3.0
Keywords: 
kbexpertiseinter kbtshoot kbprb KB927675
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com