No Adobe PDF documents are returned in the search results when you search a Windows SharePoint Services 3.0 Web site

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Article ID: 927675 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario. You search a Microsoft Windows SharePoint Services 3.0 Web site for content that is located in Adobe Portable Document Format (PDF) documents. However, no PDF documents are returned in the search results. You experience this symptom even though the content that you search for is located in PDF documents in the Windows SharePoint Services 3.0 Web site.

CAUSE

This issue occurs if the Windows SharePoint Services Search service in Windows SharePoint Services 3.0 is not configured to crawl PDF documents.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To resolve this issue, make sure that the Windows SharePoint Services Search service is configured to crawl PDF documents on each server on which the Adobe PDF IFilter is installed. To install the Adobe PDF IFilter and to configure the Windows SharePoint Services Search service, follow these steps:
  1. Download and then install the Adobe PDF IFilter from the following Adobe Web site:
    http://www.adobe.com/support/downloads/detail.jsp?ftpID=2611
    Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
  2. Add the following registry entry, and then set the registry entry value to pdf:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Applications\<GUID>\Gather\Search\Extensions\ExtensionList\38
    To do this, follow these steps:
    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Applications\GUID\Gather\Search\Extensions\ExtensionList
    3. On the Edit menu, point to New, and then click String Value.
    4. Type 38, and then press ENTER.
    5. Right-click the registry entry that you created, and then click Modify.
    6. In the Value data box, type pdf, and then click OK.
  3. Verify that the following two registry subkeys are present and that they contain the appropriate values.

    Note These registry subkeys and the values that they contain are created when you installed the Adobe PDF IFilter on the server.
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf
      This registry subkey must contain the following registry entry:
      • Name: Default
        Type: REG_MULTI_SZ
        Data: {8315BA54-B69F-4275-AE11-31CB6359EB09}
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\Filters\.pdf
      This registry subkey must contain the following registry entries:
      • Name: Default
        Type: REG_SZ
        Data: (value not set)
      • Name: Extension
        Type: REG_SZ
        Data: pdf
      • Name: FileTypeBucket
        Type: REG_DWORD
        Data: 0x00000001 (1)
      • Name: MimeTypes
        Type: REG_SZ
        Data: application/pdf
  4. Upload the PDF documents to the Windows SharePoint Services 3.0 Web site.
  5. Stop and then start the Windows SharePoint Services Search service. To do this, follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. Stop the Windows SharePoint Services Search service. To do this, type net stop spsearch at the command prompt, and then press ENTER.
    3. Start the Windows SharePoint Services Search service. To do this, type net start spsearch at the command prompt, and then press ENTER.
    4. Type exit to exit the command prompt.
Note If the Windows SharePoint Services 3.0 Web site already had PDF documents before you installed the Adobe PDF IFilter on the server, you may have to perform an additional step. After you install and configure the Adobe PDF IFilter on the server, modify a property of the existing PDF documents on the server. For example, modify a metadata property such as the title, or upload the PDF documents to the Windows SharePoint Services Web site again. When you do this, the Windows SharePoint Services Search service crawls the existing PDF documents again.

MORE INFORMATION

You can find the GUID in the registry by searching for the Adobe filter DLL. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Search for “acrordif.dll.”
  3. You should find one of the following subkeys:
    HKEY_CLASSES_ROOT\CLSID\{8315BA54-B69F-4275-AE11-31CB6359EB09}\InProcServer32

    HKEY_CLASSES_ROOT\CLSID\{E8978DA6-047F-4E3D-9C78-CDBE46041603}\InProcServer32
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 927675 - Last Review: May 14, 2007 - Revision: 1.4
APPLIES TO
  • Microsoft Windows SharePoint Services 3.0
Keywords: 
kbexpertiseinter kbtshoot kbprb KB927675

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