Aucun document Adobe PDF ne s'affiche dans les résultats de la recherche lorsque vous effectuez une recherche sur un site Web Windows SharePoint Services 3.0

Traductions disponibles Traductions disponibles
Numéro d'article: 927675 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Envisagez le scénario suivant. Vous recherchez du contenu stocké dans des documents PDF (Adobe Portable Document Format) sur un site Web Microsoft Windows SharePoint Services 3.0. Cependant, aucun document PDF ne s'affiche dans les résultats de la recherche. Vous rencontrez ce problème bien que le contenu que vous recherchez soit stocké dans les documents PDF disponibles sur le site Web Windows SharePoint Services 3.0.

Cause

Ce problème survient lorsque le service de recherche de Windows SharePoint Services 3.0 n'est pas configuré pour analyser les documents PDF.

Résolution

Important Cette section, méthode ou tâche, contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour plus de protection, effectuez une sauvegarde du Registre avant de le modifier. Vous serez alors en mesure de le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde et la restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows


Pour résoudre ce problème, vérifiez que le service de recherche de Windows SharePoint Services est configuré pour analyser les documents PDF sur chaque serveur sur lequel Adobe PDF IFilter est installé. Pour installer Adobe PDF IFilter et configurer le service de recherche Windows SharePoint Services, procédez comme suit :
  1. Téléchargez, puis installez Adobe PDF IFilter à partir du site Web Adobe à l'adresse suivante (en anglais) :
    http://www.adobe.com/support/downloads/detail.jsp?ftpID=2611
    Microsoft fournit des informations relatives aux contacts tiers afin de vous aider à trouver un support technique. Ces informations peuvent être modifiées sans préavis. Microsoft ne garantit en aucun cas l'exactitude des informations concernant les sociétés tierces.
  2. Ajoutez l'entrée de Registre suivante, puis définissez-la sur la valeur pdf :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Applications\<GUID>\Gather\Search\Extensions\ExtensionList\38
    Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, puis sur Exécuter, tapez regedit, puis cliquez sur OK.
    2. Recherchez la sous-clé de Registre suivante, puis cliquez dessus :
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Applications\GUID\Gather\Search\Extensions\ExtensionList
    3. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur chaîne.
    4. Tapez 38, puis appuyez sur ENTRÉE.
    5. Cliquez avec le bouton droit sur l'entrée de Registre que vous venez de créer Modifier.
    6. Dans la zone Données de la valeur, tapez pdf, puis cliquez sur OK.
  3. Vérifiez que les deux sous-clés de Registre suivantes sont présentes et qu'elles contiennent les valeurs appropriées.

    Remarque Ces sous-clés de Registre et les valeurs qu'elles contiennent ont été créées lors de l'installation d'Adobe PDF IFilter sur le serveur.
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf
      Cette sous-clé de Registre doit contenir la clé de Registre suivante :
      • Nom : Par défaut
        Type : REG_MULTI_SZ
        Données : {4C904448-74A9-11D0-AF6E-00C04FD8DC02}
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\Filters\.pdf
      Cette sous-clé de Registre doit contenir les clés de Registre suivantes :
      • Nom : Par défaut
        Type : REG_SZ
        Données : (valeur non définie)
      • Nom : Extension
        Type : REG_SZ
        Données : pdf
      • Nom : FileTypeBucket
        Type : REG_DWORD
        Données : 0x00000001 (1)
      • Nom : MimeTypes
        Type : REG_SZ
        Données : application/pdf
  4. Téléchargez les documents PDF sur le site Web Windows SharePoint Services 3.0.
  5. Arrêtez, puis démarrez le service de recherche Windows SharePoint Services. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, puis sur Exécuter, tapez cmd, puis cliquez sur OK.
    2. Arrêtez le service de recherche Windows SharePoint Services. Pour cela, à l'invite de commandes, tapez net stop spsearch, puis appuyez sur ENTRÉE.
    3. Démarrez le service de recherche Windows SharePoint Services. Pour cela, à l'invite de commandes, tapez net start spsearch, puis appuyez sur ENTRÉE.
    4. Tapez exit pour quitter l'invite de commandes.
Remarque Si des documents PDF étaient déjà disponibles sur le site Web Windows SharePoint Services 3.0 avant l'installation d'Adobe PDF IFilter sur le serveur, vous devrez peut-être également effectuer une étape supplémentaire. Après avoir installé et configuré Adobe PDF IFilter sur le serveur, modifiez une propriété des documents PDF existants sur celui-ci. Modifiez par exemple une propriété de métadonnées (le titre) ou téléchargez à nouveau les documents PDF sur le site Web Windows SharePoint Services. Lors de cette opération, le service de recherche de Windows SharePoint Services analyse à nouveau les documents PDF existants.

Plus d'informations

Les produits tiers mentionnés dans le présent article proviennent de sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.

Propriétés

Numéro d'article: 927675 - Dernière mise à jour: mercredi 30 avril 2008 - Version: 1.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows SharePoint Services 3.0
Mots-clés : 
kbexpertiseinter kbtshoot kbprb KB927675
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com