Нет документов Adobe PDF возвращаются в результатах поиска при поиске Windows SharePoint Services 3.0 сайт

Переводы статьи Переводы статьи
Код статьи: 927675 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Проблема

Рассмотрим описанную ниже ситуацию.. Поиск веб-узел Microsoft Windows SharePoint Services 3.0 Web для содержимого, расположенного в документах Adobe формат PDF (Portable Document). Тем не менее в результатах поиска не возвращаются документов PDF. Эта проблема возникает несмотря на то, что содержимое, для поиска находится в PDF-документы в Windows SharePoint Services 3.0 узла.

Причина

Эта проблема возникает, если службы Windows SharePoint Services Search в Windows SharePoint Services 3.0 не настроена для обхода PDF-документы.

Решение

Существенный:Этот раздел, метод или задачу включены действия по инструкции по изменению реестра. Однако, серьезные проблемы могут возникнуть в случае некорректного изменения реестра.. Поэтому при выполнении этих действий рекомендуется строго соблюдать инструкции.. Чтобы обеспечить дополнительную защиту, создайте резервную копию реестра.. В этом случае при возникновении неполадок реестр можно будет восстановить.. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт::
322756Создание резервных копий и восстановление реестра Windows


Чтобы устранить эту проблему, убедитесь, что службы Windows SharePoint Services Search настроена на сканирование документов PDF на каждом сервере, на котором установлен Adobe PDF IFilter. Для установки Adobe PDF IFilter и настройки службы Windows SharePoint Services Search, выполните следующие действия.
  1. Загрузите и установите фильтр IFilter Adobe PDF из Adobe веб-узла:
    http://www.Adobe.com/support/Downloads/Detail.JSP?ftpID=2611
    Контактные данные независимых производителей предоставлены в этой статье с целью помочь пользователям получить необходимую техническую поддержку.. Эти данные могут быть изменены без предварительного уведомления.. Корпорация Майкрософт не дает гарантий относительно верности приведенных контактных данных сторонних производителей..
  2. Добавьте следующую запись реестра и установите значение записи реестраPDF:
    Сервер Extensions\12.0\Search\Applications\ Tools\Web HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared <guid>\Gather\Search\Extensions\ExtensionList\38</guid>
    Выполните следующие действия::
    1. затем –START ::затем –ВыполнитьTYPE :regeditи выберите командуOk..
    2. Найдите и откройте следующий подраздел реестра::
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web сервера Extensions\12.0\Search\Applications\GUID\Gather\Search\Extensions\ExtensionList
    3. в менюВ файлеВыберите пункт менюСОЗДАТЬ.и выберите командуСтроковый параметр:.
    4. TYPE :38и нажмите клавишу ВВОД..
    5. Щелкните правой кнопкой мыши запись реестра, который был создан и нажмите кнопкуModify.
    6. В диалоговом окнеЗначениеполе типаPDFи выберите командуOk..
  3. Убедитесь, что имеются две следующие подразделы и содержат соответствующие значения.

    Примечание.Эти разделы реестра и значения, которые они содержат создаются, когда на сервере установлен Adobe PDF IFilter.
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web сервера Extensions\12.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf
      Этот раздел реестра может содержать следующую запись реестра:
      • Имя: по умолчанию
        Тип: REG_MULTI_SZ
        Данные: {8315BA54-B69F-4275-AE11-31CB6359EB09}
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web сервера Extensions\12.0\Search\Setup\Filters\.pdf
      Этот раздел реестра может содержать следующие записи реестра:
      • Имя: по умолчанию
        Тип: REG_SZ
        Данные: (значение не задано)
      • Имя: расширения
        Тип: REG_SZ
        Данные: в формате pdf
      • Имя: FileTypeBucket
        Тип: REG_DWORD
        Данные: 0x00000001 (1)
      • Имя: MimeTypes
        Тип: REG_SZ
        Данные: приложение или pdf
  4. Загрузите документы PDF Windows SharePoint Services 3.0 узла.
  5. Остановите и запустите службу поиска службы Windows SharePoint. Выполните следующие действия::
    1. затем –START ::затем –ВыполнитьTYPE :Cmdи выберите командуOk..
    2. Остановка службы Windows SharePoint Services Search. <a0>$$$$</a0><a1>$$$$</a1>:<a2>$$$$</a2>net stop spsearchи нажмите клавишу ВВОД..
    3. Запуск службы Windows SharePoint Services Search. <a0>$$$$</a0><a1>$$$$</a1>:<a2>$$$$</a2>net start spsearchи нажмите клавишу ВВОД..
    4. TYPE :ExitЧтобы выйти из командной строки.
Примечание.Если Windows SharePoint Services 3.0 узла уже применена документов PDF, перед установкой сервера Adobe PDF IFilter, необходимо выполнить дополнительные действия. После установки и настройки на сервере Adobe PDF IFilter, измените свойства существующих документов PDF на сервере. Например изменять свойства метаданных, такие как название или снова отправить PDF-документы к узлу служб Windows SharePoint. При этом служба Windows SharePoint Services Search снова обходящий существующих документов PDF.

Дополнительная информация

Идентификатор GUID можно найти в реестре, поиск фильтр Adobe библиотеки DLL. Выполните следующие действия::
  1. затем –START ::затем –ВыполнитьTYPE :regeditи выберите командуOk..
  2. Поиск “ acrordif.dll ”.
  3. Необходимо найти один из следующих подразделов:
    \InProcServer32 HKEY_CLASSES_ROOT\CLSID\ {8315BA54-B69F-4275-AE11-31CB6359EB09}

    \InProcServer32 HKEY_CLASSES_ROOT\CLSID\ {E8978DA6 047F-4E3D 9 C 78-CDBE46041603}
Продукты независимых производителей, обсуждаемые в этой статье, производятся компаниями, независимыми от корпорации Майкрософт.. Корпорация Майкрософт не предоставляет никаких гарантий, явных или подразумеваемых, относящихся к производительности или надежности этих продуктов..

Свойства

Код статьи: 927675 - Последний отзыв: 27 ноября 2010 г. - Revision: 2.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows SharePoint Services 3.0
Ключевые слова: 
kbexpertiseinter kbtshoot kbprb kbmt KB927675 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:927675

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com