No results are returned when you search for e-mail items after you enable Instant Search in Outlook

Article translations Article translations
Article ID: 927676 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

After you enable the Instant Search feature in Microsoft Office Outlook, Windows Desktop Search returns no results when you search for e-mail items.

CAUSE

This issue occurs if the Exchange System Manager tool is installed on a computer that is also running Outlook.

To support Exchange System Manager, the installation program for the Exchange System Management Tools copies MAPI DLL files to the %WINDIR%\system32 folder. This is the same location in which the SearchProtocolHost.exe search provider file is located. In this situation, when MAPI tries to load provider DLL files, MAPI uses the Microsoft Exchange-related DLL files. The Exchange-related DLL files do not have all the features that are required to index e-mail messages. Therefore, Windows Desktop Search no longer searches e-mail messages.

RESOLUTION

To resolve this issue, use the Fixmapi.exe tool to change the provider DLL search order.

Note If you reinstall the Exchange System Management Tools after Outlook has been installed, you must rerun the Fixmapi.exe tool. To run the Fixmapi.exe tool, follow these steps:
  1. Click Start, click Run, type %windir%\system32\fixmapi.exe, and then click OK.
  2. Restart the computer.
  3. Rebuild the computer's index catalog. To do this, follow these steps:
    1. In Control Panel, double-click Indexing Options.
    2. In the Indexing Options dialog box, click Advanced.
    3. Click the Index Settings tab, and then click Rebuild.
    4. Click OK when you are prompted to rebuild the indexed locations on the computer.
    5. Click Close to close the Indexing Options dialog box.

WORKAROUND

To work around this issue, remove the Exchange System Management Tools. Then, rebuild the computer's index catalog.

Properties

Article ID: 927676 - Last Review: April 15, 2012 - Revision: 3.0
APPLIES TO
  • Microsoft Office Outlook 2007
  • Microsoft Outlook 2010
Keywords: 
kbexpertisebeginner kbtshoot kbprb KB927676

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com