Aucuns résultats ne sont retournés lorsque vous recherchez des éléments de courrier électronique après avoir activé la recherche instantanée dans Outlook

Numéro d'article: 927676 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Après avoir activé la fonctionnalité recherche instantanée dans Microsoft Office Outlook, Windows Desktop Search ne renvoie aucun résultat lorsque vous recherchez des éléments de courrier électronique.

Cause

Ce problème se produit si l'outil Gestionnaire système Exchange est installé sur un ordinateur qui exécute également Outlook.

Pour prendre en charge Gestionnaire système Exchange, le programme d'installation pour les outils de gestion du système Exchange copie les fichiers DLL MAPI vers le dossier % Windir%\System32. C'est le même emplacement que celui dans lequel se trouve le fichier SearchProtocolHost.exe du fournisseur de recherche. Dans ce cas, lorsque MAPI essaie de charger des fichiers DLL du fournisseur, MAPI utilise les fichiers DLL liés à Exchange de Microsoft. Les fichiers DLL liés à Exchange n'ont pas toutes les fonctionnalités qui sont nécessaires pour indexer les messages électroniques. Par conséquent, Windows Desktop Search n'est plus recherches de messages électroniques.

Résolution

Pour résoudre ce problème, utilisez l'outil Fixmapi.exe pour modifier l'ordre de recherche des DLL du fournisseur.

Remarque : Si vous réinstallez les outils de gestion du système Exchange après avoir installé Outlook, vous devez réexécuter l'outil Fixmapi.exe. Pour exécuter l'outil Fixmapi.exe, procédez comme suit :
  1. Cliquez sur Démarrer, cliquez sur Exécuter, type %windir%\system32\fixmapi.exe, puis cliquez sur OK.
  2. Redémarrez l'ordinateur.
  3. Reconstruire le catalogue d'index de l'ordinateur. Pour ce faire, procédez comme suit :
    1. Dans le panneau de configuration, double-cliquez sur Options d'indexation.
    2. Dans le Options d'indexation boîte de dialogue, cliquez sur Avancée.
    3. Cliquez sur le Paramètres de l'index onglet, puis cliquez sur Reconstruction.
    4. Cliquez sur OK Lorsque vous êtes invité à reconstruire les emplacements indexés sur l'ordinateur.
    5. Cliquez sur Fermer Pour fermer le Options d'indexation boîte de dialogue.

Contournement

Pour contourner ce problème, supprimez les outils de gestion du système Exchange. Reconstituez ensuite le catalogue d'index de l'ordinateur.

Propriétés

Numéro d'article: 927676 - Dernière mise à jour: dimanche 15 avril 2012 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Outlook 2007
  • Microsoft Outlook 2010
Mots-clés : 
kbexpertisebeginner kbtshoot kbprb kbmt KB927676 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 927676
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires