Error message in the Sched.log file in SMS 2003 with Service Pack 2: "WARNING: Found duplicate Send Request ID already exists"

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Article ID: 927723 - View products that this article applies to.
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SYMPTOMS

You experience the following symptoms in a Microsoft Systems Management Server (SMS) 2003 site hierarchy:
  • SMS 2003 does not distribute a package to some SMS 2003 child sites.
  • The following error information is logged in the SMS\Logs\Sched.log file:
    Processing routing request <request>.RTR SMS_SCHEDULER?<date> <time>? (0x121C) 
    The routing request came from site <site> SMS_SCHEDULER?<date> <time>? (0x121C) 
    WARNING: Found duplicate Send Request ID already exists in sites current list - ID: ID: 2_<child site> SMS_SCHEDULER?<date> <time>? (0x121C) 
    Abandoning processing of the routing request <request>.RTR.  It will be retried on the next routing request processing cycle. SMS_SCHEDULER?<date> <time>? (0x121C)
    Note The following text is significant in this logged information:
    "WARNING: Found duplicate Send Request ID already exists in sites current list - ID: 2_<child site>"

CAUSE

This problem may occur if a duplicate send request ID is generated in SMS 2003. You may experience this problem if the following conditions are true:
  • You have a three-tier site hierarchy.
  • The send request is sent to a remote site that has a slow link.
Send request IDs can have a maximum number of 46,656 unique values before they restart. A send request that is sent to a remote site that has a slow link may take seven days to be processed or to be deleted.

Note The SMS Scheduler deletes active send requests that are over seven days old.

In a three-tier site hierarchy, send request IDs may reach the maximum number of unique values and restart as frequently as one time per week. Typically, duplicate send request IDs are located in the Sms\Inboxes\Schedule.box\Outboxes\lan folder. However, duplicate send requests IDs may also be located in the Sms\Inboxes\Schedule.box\Requests folder.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Basesvr.dll2.50.4160.21251,769,47201-Mar-200613:00x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you install this hotfix, SMS 2003 automatically generates a new send request ID when it detects duplicate send request IDs. This allows for the immediate processing of all the send requests in a routing request. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

If you experience this symptom on a site that is running SMS 2003 with SP1, see the follow Microsoft Knowledge Base article:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;886685

Properties

Article ID: 927723 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbautohotfix kbbug kbfix kbhotfixserver kbqfe KB927723

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