Help and Support
 

powered byLive Search

Windows Vista を Windows XP とのデュアルブート構成でインストールした後、Windows XP を起動できない

文書番号:927817
最終更新日:2007年5月21日
リビジョン:2.0

現象

Windows Vista を、Microsoft Windows XP とのデュアルブート構成でインストールした後、Windows XP を選択してコンピュータを起動しようとすると、以下のようなエラー メッセージが表示されます。
次のファイルが存在しないかまたは壊れているため、Windows を起動できませんでした:
C:\Windows\system32\ntoskrnl.exe.

上記のファイルをインストールし直してください。

先頭へ戻る

原因

この問題は、Windows XP がインストールされているパーティションの前の未割り当てディスク領域に Windows Vista がインストールされた場合に発生します。

この場合、Windows Vista セットアップ プログラムにより、未割り当てのディスク領域に新しいパーティションが作成されます。Windows XP がインストールされているパーティションの前に新しいパーティションが作成されるため、Boot.ini で Windows XP のインストール用に指定されているパーティションが無効になります。

次のような状況を想定します。
? Windows XP のパーティションの前に未割り当てのハード ディスク領域のあるハード ディスク (ディスク 0) があります。
? Windows XP の Boot.ini ファイルでは、Windows XP スタートアップ ファイルの場所として disk(0)partition(1) を指定しています。
? Windows Vista プログラムによって、上記の未割り当てのハード ディスク領域にパーティションが作成されます。
この場合、Windows XP スタートアップ ファイルは disk(0)partition(2) に置かれますが、Windows XP の Boot.ini ファイルでは、Windows XP スタートアップ ファイルの場所として disk(0)partition(1) が指定されたままです。そのため、Windows XP が正常に起動されません。

先頭へ戻る

解決方法

この問題を解決するには、Windows XP の Boot.ini ファイルを編集して、適切なパーティションを指定します。これを行うには、以下の手順を実行します。
1. Windows Vista を起動します。
2. [スタート] ボタン[スタート] ボタンを右クリックし、[エクスプローラ] をクリックします。
3. [整理] メニューの [フォルダと検索のオプション] をクリックします。
4. [フォルダ オプション] ダイアログ ボックスの [表示] タブをクリックします。
5. [詳細設定] ボックスで、[すべてのファイルとフォルダを表示する] をクリックし、[登録されている拡張子は表示しない] チェック ボックスおよび [保護されたオペレーティング システム ファイルを表示しない (推奨)] チェック ボックスをオフにし、[はい] をクリックして、オペレーティング システム ファイルを表示することを確認します。次に、[OK] をクリックします。
6. Windows XP システム ドライブを見つけてクリックします。Windows Vista のエクスプローラでは通常、ドライブ D です。
7. 右側のウィンドウで、[boot.ini] を右クリックし、[プロパティ] をクリックします。
8. [boot.ini のプロパティ] ダイアログ ボックスで、[セキュリティ] タブをクリックし、[詳細設定] をクリックします。
9. [所有者] タブをクリックし、[編集] をクリックします。

ユーザー アカウント制御の許可管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [続行] をクリックします。
10. [所有者の変更] ボックスの一覧で、エイリアスをクリックするか、デフォルトの Administrators オプションを選択した状態で、[OK] を 4 回クリックします。
11. [boot.ini] を右クリックし、[編集] をクリックします。
12. ARC (Advanced RISC Computing) パスを、Windows XP スタートアップ パーティションとして適切なパスに変更します。たとえば、Windows Vista セットアップ プログラムによって Windows XP がインストールされているパーティションの前の未割り当てディスク領域にパーティションが作成された場合、パーティションの値を 1 増やす必要があります。そのため、Boot.ini ファイルに記載されている Windows XP オペレーティング システムの ARC パス内に partition(1) が含まれている場合は、partition(2) を使用するように、この ARC パスを変更します。この場合の ARC パスの例を以下に示します。
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
13. Boot.ini ファイルへの変更を保存し、メモ帳を終了します。

先頭へ戻る

詳細

ARC パスの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
102873 (http://support.microsoft.com/kb/102873/) [NT]BOOT.INI と ARC パスの名前付け規約と使用法
155222 (http://support.microsoft.com/kb/155222/) ARC パスを確認する方法
関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
289022 (http://support.microsoft.com/kb/289022/) Windows XP で Boot.ini ファイルを編集する方法
関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
314058 (http://support.microsoft.com/kb/314058/) Windows XP 回復コンソールについて
307654 (http://support.microsoft.com/kb/307654/) Windows XP での回復コンソールのインストールおよび使用方法

先頭へ戻る


この資料は以下の製品について記述したものです。
?Windows Vista Ultimate
?Windows Vista Enterprise
?Windows Vista Business
?Windows Vista Home Premium
?Windows Vista Home Basic
?Windows Vista Starter
?Windows Vista Enterprise 64-bit edition
?Windows Vista Home Basic 64-bit edition
?Windows Vista Home Premium 64-bit edition
?Windows Vista Ultimate 64-bit edition

先頭へ戻る

キーワード:?
kbtshoot kbpending kbbug kbenv kbexpertisebeginner kbprb KB927817

先頭へ戻る

"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.