IndisponibilitÓ dei comandi "Aggiungi" e "Rimuovi" della scheda Driver in un server di stampa remoto basato su Windows Vista

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Descrizione del problema

Quando si apre la finestra di dialogo ProprietÓ server in un server di stampa basato su Windows Vista tramite una connessione remota, Ŕ possibile notare che i comandi Aggiungi e Rimuovi della scheda Driver non sono disponibili.

Questo articolo consente di risolvere il problema.

Causa

Il problema si verifica qualora siano vere le seguenti condizioni:
  • Il server di stampa basato su Windows Vista fa parte di un gruppo di lavoro.
  • Si accede a un computer client basato su Windows Vista utilizzando credenziali che includono diritti amministrativi per il server di stampa basato Windows Vista facente parte del gruppo di lavoro.
  • Dal computer client connettersi in modalitÓ remota al server di stampa basato su Windows Vista.
Questo problema si verifica perchÚ le credenziali di amministratore necessarie per amministrare in modalitÓ remota i driver della stampante sul server di stampa basato su Windows Vista vengono rimossi da Controllo account utente. Questo Ŕ il comportamento di protezione predefinito in Windows Vista.

Soluzione alternativa

Per ovviare a questo comportamento, Ŕ possibile accedere localmente al server di stampa per aggiungere o rimuovere i driver. In alternativa Ŕ possibile modificare il Registro di sistema del server di stampa basato su Windows Vista in modo che tra il computer client e il server di stampa vengano scambiate credenziali complete.

Per consentire al supporto tecnico di modificare il Registro di sistema, andare alla sezione "Correzione automatica". Se si preferisce modificare manualmente il Registro di sistema, andare alla sezione "Correzione manuale".

Correzione automatica

Per risolvere il problema automaticamente, fare clic sul collegamento Correggi problema, quindi su Esegui nella finestra di dialogo Download file e attenersi alla procedura guidata.

Correggi problema
Microsoft Fix it 50005


Nota Questa procedura guidata potrebbe essere disponibile esclusivamente in inglese. Tuttavia, la soluzione automatica funziona anche per le versioni di Windows in altre lingue.

Nota Se il computer utilizzato non Ŕ quello interessato dal problema, Ŕ possibile salvare la correzione automatica su un'unitÓ di memoria flash o su un CD. Quindi, Ŕ possibile eseguire questa correzione sul computer che presenta il problema.

A questo punto, andare alla sezione "Verifica della risoluzione del problema".

Correzione manuale

Importante In questa sezione, metodo o attivitÓ viene illustrato come modificare il Registro di sistema. L'errata modifica del Registro di sistema pu˛ causare seri problemi. Attenersi quindi scrupolosamente alla procedura indicata. Per maggiore protezione, eseguire una copia di backup del Registro di sistema prima di modificarlo. In questo modo sarÓ possibile effettuarne il ripristino in caso di problemi. Per ulteriori informazioni su come eseguire il backup del Registro di sistema e su come ripristinarlo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows
  1. Fare clic sul pulsante Start
    Riduci l'immagineEspandi l'immagine
    Pulsante Start
    , digitare regedit nella casella Inizia ricerca, quindi fare clic su regedit nell'elenco Programmi.

    Riduci l'immagineEspandi l'immagine
    Autorizzazione Controllo dell'account utente
    Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Continua.
  2. Espandere la seguente sottochiave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies
  3. Fare clic su System, fare clic con il pulsante destro del mouse su LocalAccountTokenFilterPolicy, quindi scegliere Modifica.
  4. Nella casella Dati valore digitare 1, quindi scegliere OK.
  5. Chiudere l'editor del Registro di sistema.
A questo punto andare alla sezione "Verifica della risoluzione del problema".

Verifica della risoluzione del problema

Verificare se il problema Ŕ stato risolto. Se il problema Ŕ stato risolto, Ŕ possibile interrompere la lettura dell'articolo. Se il problema persiste, contattare il supporto tecnico.

Ulteriori informazioni

La voce LocalAccountTokenFilterPolicy del Registro di sistema pu˛ avere il valore 0 o 1. Tali valori modificano il comportamento nel modo seguente:
  • 0 = creazione di un token con filtro. Si tratta del valore predefinito. Le credenziali di amministratore vengono rimosse. Tali credenziali sono necessarie per l'amministrazione remota dei driver della stampante.
  • 1 = creazione di un token con privilegi elevati. Questo valore consente l'amministrazione remota dei driver della stampante su un server che fa parte di un gruppo di lavoro.

ProprietÓ

Identificativo articolo: 927832 - Ultima modifica: mercoledý 21 ottobre 2009 - Revisione: 3.0
Le informazioni in questo articolo si applicano a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Chiavi:á
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