無法在遠端 Windows Vista 列印伺服器使用 [驅動程式] 索引標籤上的 [新增] 和 [移除] 命令

文章翻譯 文章翻譯
文章編號: 927832 - 檢視此文章適用的產品。
全部展開 | 全部摺疊

在此頁中

問題描述

當您透過遠端連線開啟 Windows Vista 列印伺服器上的 [伺服器內容] 對話方塊時,發現 [驅動程式] 索引標籤上的 [新增][移除] 命令無法使用。

本文將協助您解決此問題。

原因

當下列情況成立時,就會發生這個問題:
  • Windows Vista 列印伺服器位於工作群組中。
  • 您登入用戶端 Windows Vista 電腦時,所使用的認證具有工作群組中 Windows Vista 列印伺服器的系統管理權限。
  • 您從用戶端電腦遠端連線到 Windows Vista 列印伺服器。
之所以發生這個問題,是因為「使用者帳戶控制」(UAC) 移除了遠端管理 Windows Vista 列印伺服器上列印驅動程式所需要的系統管理員認證。這是 Windows Vista 中預設的安全性行為。

其他可行方案

如果要解決這個問題,您可以從本機登入列印伺服器以新增或移除驅動程式。或者,您可以變更 Windows Vista 列印伺服器上的登錄,以便在用戶端電腦和列印伺服器之間傳送完整認證。

如果要我們為您變更登錄,請前往<為我修正此問題>一節。如果您要自行變更登錄,請前往<讓我自行修正此問題>一節。

為我修正此問題

若要自動解決此問題,請按一下 [修正此問題] 連結,然後按一下 [檔案下載] 對話方塊中的 [執行],並依照此精靈中的步驟執行。

修正此問題
Microsoft Fix it 50005


注意 此精靈只提供英文版本。不過,自動修正程式也適用於 Windows 的其他語言版本。

注意 如果您不在發生問題的電腦上,則可將自動修正程式儲存至快閃磁碟機或 CD,然後在發生問題的電腦上執行此修正程式。

立即前往<這樣是否已修正問題?>一節。

讓我自行修正此問題

重要 這個章節、方法或工作包含的步驟會告訴您要如何修改登錄。然而,如果登錄修改錯誤,可能會發生嚴重的問題。因此,請確定小心執行下列步驟。為加強保護,修改登錄之前,請務必將它備份起來。如果發生問題,您就可以還原登錄。如需有關如何備份和還原登錄的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
322756 如何在 Windows XP 和 Windows Server 2003 中備份、編輯及還原登錄
  1. 按一下 [開始]
    摺疊此圖像展開此圖像
    [開始] 按鈕
    ,在 [開始搜尋] 方塊中輸入 regedit,然後按一下 [程式集] 清單中的 regedit

    摺疊此圖像展開此圖像
    使用者帳戶控制權限
    如果出現要求您輸入系統管理員密碼或確認的提示,請輸入密碼或按一下 [繼續]
  2. 展開下列子機碼:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies
  3. 按一下 [System],用滑鼠右鍵按一下 [LocalAccountTokenFilterPolicy],然後按一下 [修改]
  4. [數值資料] 方塊中,輸入 1,然後按一下 [確定]
  5. 結束「登錄編輯程式」。
立即前往<這樣是否已修正問題?>一節。

這樣是否已修正問題?

檢查問題是否已修正。如果問題已修正,您便已完成本文。如果問題尚未修正,您可以連絡技術支援服務

其他相關資訊

登錄中 LocalAccountTokenFilterPolicy 項目的值可以是 0 或 1。這些值會變更項目的行為,如下所示:
  • 0 = 建置篩選過的權杖。這是預設值。系統管理員認證將遭到移除。列印驅動程式的遠端管理需要使用這些認證。
  • 1 = 建置提高權限的權杖。這個值允許遠端管理工作群組內伺服器上的列印驅動程式。

屬性

文章編號: 927832 - 上次校閱: 2009年10月13日 - 版次: 3.0
這篇文章中的資訊適用於:
  • Windows Vista 商用進階 64 位元版
  • Windows Vista 家用入門 64 位元版
  • Windows Vista 家用進階 64 位元版
  • Windows Vista 旗艦 64 位元版
  • Windows Vista 商用入門版
  • Windows Vista 商用入門 64 位元版
  • Windows Vista 商用進階版
  • Windows Vista 家用入門版
  • Windows Vista 家用進階版
  • Windows Vista 旗艦版
關鍵字:?
kbmsifixme kbfixme kbtshoot kbexpertiseinter kbprb KB927832
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com