Artigo: 927840 - Última revisão: quinta-feira, 15 de Março de 2007 - Revisão: 1.8

Entrada do teclado pode ser apresentada muito lentamente depois de actualizar um computador para o Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registo. Certifique-se de que cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registo do Microsoft Windows
Expandir tudo | Reduzir tudo

Sintomas

Depois de actualizar um computador para o Windows Vista, as entradas de teclado poderão ser apresentadas muito lentamente. Por exemplo, pode escrever caracteres antes de todos os caracteres são apresentados no ecrã do computador. Além disso, utilização da CPU poderá picos quando utiliza o teclado. Este comportamento poderá momentaneamente fixar o sistema.

Este problema ocorre quando utiliza um teclado PS/2 ou um teclado sem fios que utiliza uma placa PS/2.

Nota Este problema não ocorre se utilizar um USB teclado.

Causa

Este problema ocorre se uma definição de teclado não for migrada correctamente durante a actualização. Uma subchave de registo controla o tempo de atraso que ocorre após cada entrada de chave. Se esta definição de registo é perdida durante a actualização, o tempo de atraso é definido como o valor predefinido de 12 milissegundos (ms). Por conseguinte, o sistema aguarda ms 12 depois de cada tecla é premida.

Resolução

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.

Para resolver este problema, siga estes passos:
  1. Abra o Editor de registo. Para o fazer, clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
    the Start button
    , escreva regedit na caixa Iniciar procura e, em seguida, clique em regedit.exe em programas lista.

    Reduzir esta imagemExpandir esta imagem
    User Account Control
				permission
    Se lhe for pedido para uma palavra-passe de administrador ou confirmação, escreva a palavra-passe ou clique em Permitir (Allow ).
  2. Localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters
  3. Faça duplo clique PollStatusIterations e, em seguida, escreva 1 para o valor.
  4. Saia do Editor de registo.
  5. Reinicie o computador.

A informação contida neste artigo aplica-se a:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Starter
Palavras-chave: 
kbmt kbtshoot kbexpertisebeginner kbprb KB927840 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 927840  (http://support.microsoft.com/kb/927840/en-us/ )