ID do artigo: 927840 - Última revisão: quinta-feira, 15 de março de 2007 - Revisão: 1.8

Entrada de teclado pode ser exibida lentamente após atualizar um computador para o Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de fazer backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registro do Microsoft Windows
Expandir tudo | Recolher tudo

Sintomas

Depois de atualizar um computador para o Windows Vista, entrada de teclado pode ser exibida muito lentamente. Por exemplo, você pode digitar número de caracteres antes que quaisquer caracteres são exibidos na tela do computador. Além disso, uso da CPU pode picos ao usar o teclado. Esse comportamento pode congelar momentaneamente o sistema.

Esse problema ocorre quando você usar um teclado PS/2 ou um teclado sem fio que usa um adaptador PS/2.

Observação Esse problema não ocorre se você usar um USB teclado.

Causa

Esse problema ocorre se uma configuração do teclado não é migrada corretamente durante a atualização. Uma subchave do registro controla o tempo de espera que ocorre após cada entrada de chave. Se essa configuração do registro for perdida durante a atualização, o tempo de espera é definido como o valor padrão de 12 milissegundos (ms). Portanto, o sistema aguarda 12 ms após cada tecla é pressionada.

Resolução

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Para resolver esse problema, execute essas etapas:
  1. Abra o Editor do Registro. Para fazer isso, clique
    Recolher esta imagemExpandir esta imagem
    the Start button
    Iniciar , digite regedit na caixa Iniciar procura e, em seguida, clique em regedit.exe em programas lista.

    Recolher esta imagemExpandir esta imagem
    User Account Control
				permission
    Se você for solicitado uma senha de administrador ou confirmação, digite a senha ou clique em Permitir .
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters
  3. Clique duas vezes PollStatusIterations e, em seguida, digite 1 para o valor.
  4. Feche o Editor do Registro.
  5. Reinicie o computador.

A informação contida neste artigo aplica-se a:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Starter
Palavras-chave: 
kbmt kbtshoot kbexpertisebeginner kbprb KB927840 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 927840  (http://support.microsoft.com/kb/927840/en-us/ )