Makale numarası: 927840 - Son Gözden Geçirme: 20 Mart 2007 Salı - Gözden geçirme: 1.3

Bilgisayarı Windows Vista'ya yükselttikten sonra klavye girişi çok yavaş görüntülenebilir

Sistem İpucuBu makale, kullandığınızdan farklı bir işletim sistemine yöneliktir. Sizinle ilgili olmayabilecek makale içeriği devre dışı bırakıldı.
Önemli Bu makale, kayıt defterini değiştirmeyle ilgili bilgiler içermektedir. Kayıt defterini değiştirmeden önce yedeklemeyi unutmayın. Sorun oluşması durumunda kayıt defterini nasıl geri yükleyeceğinizi bildiğinizden emin olun. Kayıt defterini yedekleme, geri yükleme ve değiştirme hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
256986  (http://support.microsoft.com/kb/256986/ ) Microsoft Windows Kayıt Defteri'nin Açıklaması
Hepsini aç | Hepsini kapa

Belirtiler

Bir bilgisayarı Windows Vista'ya yükselttikten sonra klavye girişi çok yavaş görüntülenebilir Örneğin, bilgisayar ekranında bir karakter görüntüleninceye kadar birçok karakter yazabilirsiniz. Ek olarak, klavyenizi kullandığınızda CPU kullanımı en üst düzeye çıkabilir. Bu davranış bilgisayarı anlık olarak dondurabilir.

Bu sorun bir PS/2 klavye veya PS/2 bağdaştırıcısı kullanan bir kablosuz klavye kullandığınızda oluşur.

Not USB klavye kullandığınızda bu sorun oluşmaz.

Neden

Bu sorun, bir klavye ayarı yükseltme sırasında doğru geçirilmemişse oluşur. Bir kayıt defteri alt anahtarı, her tuş girişinden sonra beklenilen süreyi denetler. Yükseltme sırasında bu kayıt defteri anahtarı kaybolursa, bekleme süresi varsayılan değer olan 12 milisaniyeye (ms) ayarlanır. Bu nedenle, sistem her tuş basılmasından sonra 12 ms bekler.

€”zm

Uyarı Kayıt Defteri Düzenleyicisi'ni veya başka bir yöntemi kullanarak kayıt defterini hatalı olarak değiştirirseniz önemli sorunlar oluşabilir. Bu sorunlar, işletim sistemini yeniden yüklemenizi gerektirebilir. Microsoft bu sorunların çözülebileceğini garanti etmemektedir. Kayıt defterini değiştirmek kendi sorumluluğunuzdadır.

Bu sorunu gidermek için aşağıdaki adımları izleyin:
  1. Kayıt Defteri Düzenleyicisi'ni açın. Bunu yapmak için, Başlat
    Bu resmi kapatBu resmi aç
    Başlat düğmesi
    düğmesini tıklatın, Aramaya Başla kutusuna regedit yazın ve sonra Programlar listesinde regedit.exe'yi tıklatın.

    Bu resmi kapatBu resmi aç
     Kullanıcı Erişim Denetimi izni
    Yönetici parolası girmeniz veya onaylamanız istenirse, parolayı yazın veya İzin Ver'i tıklatın.
  2. Aşağıdaki kayıt defteri alt anahtarını bulup tıklatın:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters
  3. PollStatusIterations'ı çift tıklatın ve değer olarak 1 yazın.
  4. Kayıt Defteri Düzenleyicisi'nden çıkın.
  5. Bilgisayarı yeniden başlatın.

Durum

Microsoft bu sorunun "Aşağıdakilere Uygulanır" bölümünde listelenen Microsoft ürünlerinde bulunduğunu onaylamıştır.

Bu makaledeki bilginin uygulandigi durum:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Starter
Anahtar Kelimeler: 
kbtshoot kbexpertisebeginner kbprb KB927840