Article ID: 928006 - Last Review: October 11, 2007 - Revision: 1.7

You receive a "STOP: 0x0000007f" error message or the computer automatically restarts in Windows Server 2003

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SYMPTOMS

On a computer that is running Microsoft Windows Server 2003, you may experience any of the following symptoms:
  • The computer automatically restarts.
  • After you log on, you receive the following error message:
    Microsoft Windows
    The system has recovered from a serious error.
    A log of this error has been created.
    Please tell Microsoft about this problem.
    We have created an error report that you can send to help us improve Microsoft Windows. We will treat this report as confidential and anonymous.
    To see what data this error report contains, click here.
    When you click click here, you see error signature information that resembles the following:
    BCCode : 0x0000007F BCP1 : 00000008 BCP2 : 00000000 BCP3 : 00000000 BCP4 : 00000000 OSVer : 5_2_3718 SP : 0_0 Product : 272_3
  • You receive the following Stop error message:
    A problem has been detected and Windows has been shut down to prevent damage to the computer...
    Technical information:

    *** STOP: 0x0000007F (0x00000008, 0x00000000, 0x00000000, 0x00000000)
    Unexpected_Kernel_Mode_Trap
    Note The symptoms of a Stop error vary according to the computer's system failure options. For more information about how to configure system failure options, click the following article number to view the article in the Microsoft Knowledge Base:
    307973  (http://support.microsoft.com/kb/307973/ ) How to configure system failure and recovery options in Windows
    The parameters that are included in the parentheses of the Stop error also vary according to the computer's configuration.
  • When you view the System log in Event Viewer, you may see an event ID 1003 entry that resembles the following:
    Date: date
    Source: System
    Error Time: time
    Category: (102)
    Type: Error
    Event ID: 1003
    User: N/A
    Computer: ComputerName
    Description: Error code 0000007F, parameter1 00000008, parameter2 00000000, parameter3 00000000, parameter4 00000000. For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: 53 79 73 74 65 6d 20 45 System E 0008: 72 72 6f 72 20 20 45 72 rror Er 0010: 72 6f 72 20 63 6f 64 65 ror code 0018: 20 30 30 30 30 30 30 35 00000MN 0020: 30 20 20 50 61 72 61 6d 0 Param 0028: 65 74 65 72 73 20 66 66 eters ff 0030: 66 66 66 66 64 31 2c
These symptoms appear at seemingly random intervals.

CAUSE

This problem occurs because some glyph-encoding functions in the remote desktop protocol display driver (RDPDD) use too much stack space.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 32-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rdpdd.dll5.2.3790.2862100,48816-Jan-200717:07x86SP1SP1QFE
Rdpdd.dll5.2.3790.4006100,48816-Jan-200717:48x86SP2SP2QFE
Windows Server 2003, 64-bit x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rdpdd.dll5.2.3790.2862166,53616-Jan-200703:28x64SP1SP1QFE
Rdpdd.dll5.2.3790.4006166,53616-Jan-200703:30x64SP2SP2QFE
Windows Server 2003, 64-bit Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rdpdd.dll5.2.3790.2862327,30416-Jan-200703:28IA-64SP1SP1QFE
Rdpdd.dll5.2.3790.4006327,30416-Jan-200703:31IA-64SP2SP2QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Keywords: 
kbautohotfix kberrmsg kbwinserv2003postsp2fix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB928006
 

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