Un controlador de onda personalizado se descarga cuando un equipo cliente remoto se conecta a un equipo basado en Windows Server 2003 que está ejecutando un programa TAPI

Seleccione idioma Seleccione idioma
Id. de artículo: 928046 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que copia el registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

En esta página

Síntomas

En un equipo basado en Microsoft Windows Server 2003 que ejecuta un programa de API de telefonía (TAPI), puede experimentar los síntomas siguientes:
  • El controlador de onda personalizado se descarga desde el equipo y el controlador de audio de protocolo de escritorio remoto (RDP) está cargado en el equipo.
  • Las secuencias de audio de todas las llamadas se desconectan. Esto incluye todas las llamadas que están en curso y las llamadas que se conectan.
  • El controlador de onda no puede comunicarse con proveedor de servicios TAPI (TSP, Telephony Service Provider).

Causa

Estos síntomas aparecen si cumplen las condiciones siguientes:
  • Tiene un equipo basado en Windows Server 2003 que está ejecutando un programa TAPI y este programa se comunica con un modificador de telefonía rama privada (PBX) de exchange.
  • El modificador de PBX tiene un TSP personalizado y un controlador de onda personalizados que están instalados en el equipo.
  • Un usuario con derechos de usuario administrativos se conecta a la sesión de consola del equipo mediante la herramienta de conexión a Escritorio remoto (mstsc.exe) junto con el modificador /Console .
  • De forma predeterminada, la opción Traer a este equipo está seleccionada en la lista de sonido de equipo remoto para la sesión de escritorio remota.

Solución

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Windows Server 2003. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100Cómo obtener la versión más reciente del Service Pack para Windows Server 2003

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

El equipo debe estar ejecutando Windows Server 2003 Service Pack 1 (SP1) para instalar esta revisión.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix. Además, debe agregar la entrada de registro DontUnloadConsoleAudio.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos de archivo más reciente) mostrados en la tabla siguiente. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Server 2003, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
TERMSRV.dll5.2.3790.2832696,32014 De noviembre de 200601: 07IA-64
Windows Server 2003, versión de 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
TERMSRV.dll5.2.3790.2832363,52014 De noviembre de 200601: 05x 64
Windows Server 2003, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
TERMSRV.dll5.2.3790.2832245,24814 De noviembre de 200614: 15x 86

Información del registro

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Después de instalar la revisión, debe crear la entrada de registro DontUnloadConsoleAudio. Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic con el botón secundario en la siguiente subclave del registro:
    HKEY_Local_Machine\System\CurrentControlSet\Control\Terminal Server
  3. Seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  4. Escriba DontUnloadConsoleAudio y, a continuación, presione ENTRAR.
  5. Haga clic con el botón secundario del mouse en DontUnloadConsoleAudio y, a continuación, haga clic en Modificar .
  6. En el cuadro de diálogo Editar valor DWORD , haga clic en decimal , escriba 1 en el cuadro de datos de valor y, a continuación, haga clic en Aceptar .
  7. Editor de registro de salida.

Solución

Para evitar este problema, configure el equipo cliente para reproducir archivos de sonido sólo en el equipo remoto. Para ello, siga estos pasos:
  1. Haga clic en Inicio , elija programas o Todos los programas , Accesorios , comunicaciones y, a continuación, haga clic en Conexión a Escritorio remoto .
  2. Haga clic en la ficha Recursos locales , haga clic en mantener en el equipo remoto en la lista sonido de equipo remoto y, a continuación, haga clic en Conectar .

    Nota Al hacer clic en Conectar , esta configuración se convertirá en la configuración predeterminada para todas las conexiones de escritorio remoto y se guarda en el archivo default.rdp.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en Windows Server 2003 Service Pack 2.

Más información

Para obtener más información acerca de la descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 928046 - Última revisión: miércoles, 28 de marzo de 2007 - Versión: 2.5
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Palabras clave: 
kbmt kbautohotfix kbwinserv2003sp2fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB928046 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 928046

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com