Um driver de wave personalizado é descarregado quando um computador cliente remoto se conecta a um computador baseado no Windows Server 2003 que está executando um programa TAPI

Traduções deste artigo Traduções deste artigo
ID do artigo: 928046 - Exibir os produtos aos quais esse artigo se aplica.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de que você faça backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986Descrição do registro do Microsoft Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Em um computador com Microsoft Windows Server 2003 que está executando um programa de API de telefonia (TAPI), poderá detectar os seguintes sintomas:
  • O driver de wave personalizado é descarregado do computador e o driver de áudio do remote desktop protocol (RDP) é carregado para o computador.
  • Os fluxos de áudio de todas as chamadas são desconectados. Isso inclui todas as chamadas que estão em andamento e as chamadas que estão sendo conectadas.
  • O driver de som wave não é possível comunicar com o provedor de serviços TAPI (TSP).

Causa

Esses sintomas ocorrem se as seguintes condições forem verdadeiras:
  • Você tem um computador com Windows Server 2003 que está executando um programa TAPI e este programa se comunica com uma opção de troca (PBX) de ramificação particular de telefonia.
  • A opção de PBX tem um TSP personalizado e um driver de wave personalizados que são instalados no computador.
  • Um usuário que tenha direitos administrativos se conecta à sessão do console do computador usando a ferramenta de conexão de área de trabalho remota (mstsc.exe) junto com a opção /console .
  • Por padrão, a opção Trazer para este computador está selecionada na lista de som do computador remoto para a sessão da área de trabalho remota.

Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100Como obter o service pack mais recente para o Windows Server 2003

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

O computador deve estar executando o Windows Server 2003 Service Pack 1 (SP1) para instalar essa correção.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix. Além disso, você deve adicionar a entrada de registro DontUnloadConsoleAudio.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês dessa correção apresenta atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.2.3790.2832696,32014 De novembro de 200601: 07IA-64
Windows Server 2003, versão com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.2.3790.2832363,52014 De novembro de 200601: 05x 64
Windows Server 2003, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.2.3790.2832245,24814 De novembro de 200614: 15x 86

Informações do registro

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Depois de instalar o hotfix, você deve criar a entrada de registro DontUnloadConsoleAudio. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e com o botão direito do mouse na seguinte subchave do Registro:
    HKEY_Local_Machine\System\CurrentControlSet\Control\Terminal Server
  3. Aponte para novo e, em seguida, clique em Valor DWORD .
  4. Digite DontUnloadConsoleAudio e, em seguida, pressione ENTER.
  5. Clique com o botão direito do mouse DontUnloadConsoleAudio e, em seguida, clique em Modificar .
  6. Na caixa de diálogo Editar valor DWORD , clique em decimal , digite 1 na caixa dados do valor e, em seguida, clique em OK .
  7. Feche o Editor do Registro.

Como Contornar

Para solucionar esse problema, configure o computador cliente para reproduzir arquivos de som somente no computador remoto. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , aponte para programas ou Todos os programas , aponte para Acessórios , aponte para comunicações e, em seguida, clique em Conexão de área de trabalho remota .
  2. Clique na guia Recursos locais , clique em deixar no computador remoto na lista de som do computador remoto e, em seguida, clique em conectar .

    Observação Ao clicar em conectar , essa configuração tornam-se a configuração padrão de todas as conexões de área de trabalho remota e é salvo no arquivo default.RDP.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Windows Server 2003 Service Pack 2.

Mais Informações

Para obter mais informações sobre a descrição da terminologia padrão que é usada para descrever as atualizações de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 928046 - Última revisão: quarta-feira, 28 de março de 2007 - Revisão: 2.5
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Palavras-chave: 
kbmt kbautohotfix kbwinserv2003sp2fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB928046 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 928046

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com