A custom wave driver is unloaded when a remote client computer connects to a Windows Server 2003-based computer that is running a TAPI program

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Article ID: 928046 - View products that this article applies to.
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry
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SYMPTOMS

On a Microsoft Windows Server 2003-based computer that is running a Telephony API (TAPI) program, you may experience the following symptoms:
  • The custom wave driver is unloaded from the computer, and the remote desktop protocol (RDP) audio driver is loaded to the computer.
  • The audio streams of all calls are disconnected. This includes all calls that are in progress and the calls that are being connected.
  • The wave driver cannot communicate with the TAPI service provider (TSP).

CAUSE

These symptoms occur if the following conditions are true:
  • You have a Windows Server 2003-based computer that is running a TAPI program, and this program communicates with a telephony private branch exchange (PBX) switch.
  • The PBX switch has a custom TSP and a custom wave driver that are installed on the computer.
  • A user who has administrative user rights connects to the console session of the computer by using the Remote Desktop Connection tool (Mstsc.exe) together with the /console switch.
  • By default, the Bring to this computer option is selected in the Remote computer sound list for the remote desktop session.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

The computer must be running Windows Server 2003 Service Pack 1 (SP1) to install this fix.

Restart requirement

You must restart the computer after you apply this hotfix. Additionally, you must add the DontUnloadConsoleAudio registry entry.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this fix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, Itanium-based versions
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File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.2832696,32014-Nov-200601:07IA-64
Windows Server 2003, x64-based version
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File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.2832363,52014-Nov-200601:05x64
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.2832245,24814-Nov-200614:15x86

Registry information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install the hotfix, you must create the DontUnloadConsoleAudio registry entry. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and right-click the following registry subkey:
    HKEY_Local_Machine\System\CurrentControlSet\Control\Terminal Server
  3. Point to New, and then click DWORD Value.
  4. Type DontUnloadConsoleAudio, and then press ENTER.
  5. Right-click DontUnloadConsoleAudio, and then click Modify.
  6. In the Edit DWORD Value dialog box, click Decimal, type 1 in the Value data box, and then click OK.
  7. Exit Registry Editor.

WORKAROUND

To work around this problem, configure the client computer to play sound files only on the remote computer. To do this, follow these steps:
  1. Click Start, point to Programs or All Programs, point to Accessories, point to Communications, and then click Remote Desktop Connection.
  2. Click the Local Resources tab, click Leave at remote computer in the Remote computer sound list, and then click Connect.

    Note When you click Connect, this setting becomes the default setting for all Remote Desktop connections and is saved in the Default.rdp file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

MORE INFORMATION

For more information about the description of the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 928046 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Keywords: 
kbautohotfix kbwinserv2003sp2fix kbbug kbfix kbqfe KB928046

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