Help and Support

After you apply a Windows XP service pack, the remote desktop session fails

Article ID:928055
Last Review:February 8, 2007
Revision:1.0

SYMPTOMS

After you use Remote Desktop Client Control (Mstscax.dll) to make a remote desktop connection from a Microsoft Windows XP-based computer, the remote desktop session fails. This problem occurs after you apply Windows XP Service Pack 1 (SP1) or Windows XP Service Pack 2 (SP2) on a client computer.

For example, when you try to connect to a Microsoft Windows Storage Server 2003 R2-based computer that has Remote Desktop for Administration installed, you receive the following error message:
Remote Admin Connection
Remote Admin Web Connection ActiveX Control could not be installed.   A connection cannot be made without a working installed version of the control. Please contact the server administrator.
The remote desktop connection then fails.

Back to the top

CAUSE

This problem occurs when the Mstscax.dll file is not reregistered when the Windows XP service pack is applied.

Back to the top

RESOLUTION

To solve this problem, run the Regsvr32.exe program to reregister the Mstscax.dll file. To do this, click Start, click Run, type regsvr32 %systemroot%\system32\mstscax.dll, and then click OK.

Back to the top


APPLIES TO
Microsoft Windows XP Service Pack 2
Microsoft Windows XP Service Pack 1

Back to the top

Keywords: 
kbtshoot kbbug kbexpertiseadvanced kbexpertiseinter KB928055

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.