Article ID: 928169 - Last Review: March 27, 2009 - Revision: 2.0

You experience various symptoms when you use SharePoint Portal Server 2003 on a computer that has an antivirus scan engine installed

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SYMPTOMS

When you use Microsoft Office SharePoint Portal Server 2003 on a computer that has an antivirus scan engine installed, you may experience the following symptoms:
  • When you browse through the Default.aspx page, you receive one of the following error codes:
    • HRESULT:0x80041050
    • HRESULT:0x80041051
    • HRESULT:0x80041052
    • HRESULT:0x80041054
  • When you try to open a file from a SharePoint document library, you receive the following error message:
    http://ServerName/Sites/Site/FileName contains the following virus: The Antivirus Scanner scan engine is offline. Please try to contact the scan engine later or contact your administrator.
Additionally, you may find messages that are related to the antivirus scan engine in the Windows SharePoint Services log file. The messages resemble the following:
0 08/16 00:09:25 6196 #96000a: infected by "The Symantec AntiVirus Scan Engine is offline. Please try to contact the scan engine later or contact your administrator. " - DOMAIN\USER - /sites/somesite/some document.doc

0 08/16 00:09:25 6196 #96000a: infected by "The Symantec AntiVirus Scan Engine is offline. Please try to contact the scan engine later or contact your administrator. " - DOMAIN\USER - /sites/somesite/default.aspx
Note The Windows SharePoint Services log file is located in the following folder:
%WINDIR%\TEMP

CAUSE

This problem occurs because the antivirus scan engine sets the VirusStatus code in the document table to a non-zero and non-null value. When a virus is detected or when the service that connects SharePoint Portal Server to the antivirus scan engine becomes unavailable, the antivirus scanner sets the VirusStatus code.

RESOLUTION

To resolve this problem, follow these steps:
  1. Use Query Analyzer to connect to the SharePoint content database.
  2. Run the following query to list all the files that are affected:
    SELECT     *
    FROM         Docs
    WHERE     (VirusStatus > 0) AND (VirusStatus IS NOT NULL)
    
  3. Manually run an antivirus scan from the antivirus scan engine to reset the VirusStatus code.
  4. Wait about 30 seconds, and then repeat steps 2 and 3 until you notice that no rows are returned in step 2.
Note Some antivirus scan engines reset the VirusStatus code when a new virus signature is downloaded. In this case, you must download a new virus signature to reset the VirusStatus code.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

APPLIES TO
  • Microsoft Office SharePoint Portal Server 2003
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