Article ID: 928218 - View products that this article applies to.
הרחב הכל | כווץ הכל

On This Page

תקציר

מאמר זה מספק שיטות שבהן באפשרותך לפעול להסרת התקנה או להסרה של חבילות Microsoft Office 2007.

האם ברצונך להסיר התקנה של גירסה אחרת של Microsoft Office?

כדי להציג מידע על אופן הסרת התקנה או הסרה של גירסה אחרת של Microsoft Office, לחץ על הקישור המתאים לגירסת Office שברשותך:

כיצד להסיר התקנה או להסיר חבילות של Microsoft Office 2010
כיצד להסיר התקנה או להסיר חבילות של Microsoft Office 2003
כיצד להסיר התקנה או להסיר את Microsoft Office עבור Mac 2011
כיצד להסיר התקנה או להסיר את Microsoft Office עבור Mac 2008

פתרון הבעיה

מומלץ לעקוב אחר השיטות המוצעות במאמר זה לפי סדר הצעתן. עם זאת, אם כבר ניסית בעבר אחת מהשיטות להסרת Office ללא הצלחה, תוכל לדלג במהירות לשיטה אחרת מרשימה זו:
  • שיטה 1: הסר את ההתקנה של חבילות Microsoft Office 2007 מלוח הבקרה
  • שיטה 2: הסר את ההתקנה של חבילות Microsoft Office 2007 באמצעות Microsoft Fix it
  • שיטה 3: הסר את ההתקנה של חבילות Microsoft Office 2007 באמצעות פותר בעיות התקנה והסרת התקנה של תוכניות
  • שיטה 4: הסרה ידנית של חבילות Microsoft Office 2007

שיטה 1: הסרת התקנה של חבילות Microsoft Office 2007 מלוח הבקרה

כווץ את התמונההרחב את התמונה
assets folding start collapsed
כדי להסיר את Microsoft Office 2007 מלוח הבקרה, בצע את הפעולות הבאות:
  1. לחץ על הפעל.
  2. לחץ על כל התוכניות, ולאחר מכן פתח את התיקייה עזרים (דלג על שלב זה ב- Windows XP).
  3. לחץ על הפעלה, ולאחר מכן לחץ התיבה פתח.
  4. הקלד appwiz.cpl, ואז לחץ על אישור.
  5. אתר את ערך Microsoft Office ברשימת התוכניות המותקנות כעת.
  6. בחר אותו ולאחר מכן לחץ על הסר התקנה (או הסר ב- Windows XP).
אם אתה נתקל בבעיות בהסרת ההתקנה של מערכת 2007 Microsoft Office בלוח הבקרה, עבור לשיטה הבאה.
כווץ את התמונההרחב את התמונה
assets folding end collapsed

שיטה 2: הסר את ההתקנה של חבילות Microsoft Office 2007 באמצעות פתרון תיקון (Fix it) של Microsoft

כווץ את התמונההרחב את התמונה
assets folding start collapsed
אזהרה: פתרון התיקון אינו מסיר תוכניות בודדות של Office שהותקנו במחשב שלך בנפרד. לדוגמה, אם התקנת את Microsoft Office Professional 2007 ואת Microsoft Office Visio 2007, פתרון התיקון יסיר רק את Microsoft Office Professional 2007. ההתקנה של Visio 2007 לא תוסר. לחץ כאן כדי להציג 'כיצד להסיר התקנה או להסיר חבילות של Microsoft Office 2007'.

חשוב - קרא הערות אלה לפני השימוש בפתרון התיקון:
  • אם ברשותך מערכת הפעלה Windows עם 64 סיביות, הורד ושמור את פתרון התיקון על שולחן העבודה, לאחר מכן לחץ עליו לחיצה כפולה להפעלתו על המחשב. אם תנסה להריץ את הפתרון ישירות מהמאמר תיתקל בבעיות בהפעלה נכון של הפתרון.
  • עליך להפעיל מחדש את המחשב אם השתמשת בפתרון התיקון.
  • ייתכן שאשף זה מוצג באנגלית בלבד. עם זאת, התיקון האוטומטי פועל גם עבור גרסאות של Windows בשפות אחרות.
  • אם אינך נמצא מול המחשב שבו אירעה הבעיה, שמור את הפתרון בכונן הבזק או בתקליטור או DVD ולאחר מכן הפעל אותו במחשב שבו אירעה הבעיה.
פתרון התיקון עבור חבילות Microsoft Office 2007 יסיר את כל המהדורות של Office 2007. זה כולל את כל המהדורות הניסיון של Office 2007.

כדי לסיר אוטומטית את ההתקנה של חבילת 2007 Microsoft Office, לחץ על הלחצן או על הקישור תקן בעיה זו. לחץ על הפעלה בתיבת הדו-שיח הורדת קובץ ופעל בהתאם לשלבים באשף התיקון.
כווץ את התמונההרחב את התמונה
assets fixit1
תקן בעיה זו
Microsoft Fix it 50154
כווץ את התמונההרחב את התמונה
assets fixit2


אם עדיין לא ניתן להסיר את חבילת Microsoft Office, עבור לשיטה הבאה.
כווץ את התמונההרחב את התמונה
assets folding end collapsed

שיטה 3: הסרת התקנה של חבילות Microsoft Office 2007 באמצעות פותר הבעיות 'התקנה והסרה של תוכניות'

כווץ את התמונההרחב את התמונה
assets folding start collapsed
ניתן לנסות ולהסיר את חבילת Microsoft Office על-ידי הפעלת פותר הבעיות 'התקנה והסרה של תוכניות'. כדי להפעיל את פותר הבעיות, בקר במאמר הבא במאגר הידע Microsoft knowledge base:



אם עדיין לא ניתן להסיר את חבילת Microsoft Office, עבור לשיטה הבאה.
כווץ את התמונההרחב את התמונה
assets folding end collapsed

שיטה 4: הסרת חבילות של Microsoft Office 2007 באופן ידני

כווץ את התמונההרחב את התמונה
assets folding start collapsed
הערה עליך להתחבר ל- Windows עם חשבון משתמש של מנהל מחשב כדי לבצע שיטה זו. אם זהו המחשב האישי שלך, סביר להניח שאתה כבר מחובר לחשבון מנהל מערכת. אם זהו מחשב המהווה חלק מרשת, ייתכן שיהיה עליך לבקש עזרה ממנהל המערכת. כדי לוודא שנכנסת ל-Windows עם חשבון משתמש שהוא מנהל מחשב, בקר במאמר הבא במאגר Microsoft knowledge base:



חשוב - מידע שעליך לדעת לפני הסרת Office 2007:
  • כדי להשתמש בתפריט תצוגה או כלים ב-Windows 7 או Vista, עליך ללחוץ תחילה על מקש ALT כדי להציג את שורת התפריטים.
  • יהיה עליך להציג קבצים ותיקיות מוסתרים. לשם כך, בצע את הפעולות הבאות:
    1. פתח את Windows Explorer.
    2. בתפריט כלים, לחץ על אפשרויות תיקייה. ב-Windows 7 או Vista, הקש על מקש ALT כדי להציג את שורת התפריטים.
    3. לחץ על הכרטיסיה תצוגה.
    4. בחלונית הגדרות מתקדמות, תחת קבצים ותיקיות מוסתרים, לחץ על הצג קבצים ותיקיות מוסתרים.
    5. נקה את תיבת הסימון הסתר סיומות עבור סוגי קבצים מוכרים.
    6. לחץ על אישור ולאחר מכן סגור את החלונות.

שלב 1: הסר חבילות Windows Installer שנותרו של מערכת Microsoft Office 2007.
  1. לחץ על הפעל.
  2. לחץ על כל התוכניות, ולאחר מכן פתח את התיקייה עזרים (דלג על שלב זה ב- Windows XP).
  3. לחץ על הפעלה, ולאחר מכן לחץ התיבה פתח.
  4. הקלד installer, ולאחר מכן לחץ על אישור.
    פעולה זו פותחת את התיקייה %windir%\Installer.

  5. בתפריט תצוגה, לחץ על בחירת פרטים.
  6. לחץ כדי לבחור בתיבת הסימון נושא, הקלד 340 בתיבה רוחב העמודה הנבחרת (בפיקסלים) ואחר כך לחץ על אישור.
    הערה ייתכן שיעברו מספר דקות עד שהנושאים יופיעו ליד כל קובץ MSI.

  7. בתפריט תצוגה, הצבע על מיין לפי ב-Windows 7 או Vista, או הצבע על סדר סמלים לפי ב-Windows XP, ולאחר מכן לחץ על נושא.
  8. אם מופיעה תיבת דו-שיח בקרת חשבונות משתמשים, לחץ על אפשר כדי להמשיך.
  9. עבור כל קובץ .MSI שהנושא שלו הוא "Microsoft Office <product name> 2007," לחץ באמצעות לחצן העכבר הימני על קובץ ה-MSI, ולאחר מכן לחץ על הסר התקנה.
    שים לב <product name> הוא מציין המיקום עבור השם של מוצר Microsoft Office 2007.
שלב 2: הפסק את שירות Office Source Engine.
  1. לחץ על הפעל.
  2. לחץ על כל התוכניות, ולאחר מכן פתח את התיקייה עזרים (דלג על שלב זה ב- Windows XP).
  3. לחץ על הפעלה, ולאחר מכן לחץ התיבה פתח.
  4. הקלד services.msc, ואז לחץ על אישור.
  5. בחלון שירותים, קבע האם שירות Office Source Engine פועל (יוצג החיווי "Started" בעמודה מצב). אם שירות זה פועל, לחץ באמצעות לחצן העכבר הימני על Office Source Engine ולאחר מכן לחץ על הפסק.
  6. סגור את חלון שירותים.
שלב 3: הסר את כל התיקיות שנותרו מהתקנת Microsoft Office 2007.
  1. לחץ על הפעל.
  2. לחץ על כל התוכניות, ולאחר מכן פתח את התיקייה עזרים (דלג על שלב זה ב- Windows XP).
  3. לחץ על הפעלה, ולאחר מכן לחץ התיבה פתח.
  4. הקלד %CommonProgramFiles%\Microsoft Shared, ואז לחץ על אישור.
    שים לב במחשב המופעל באמצעות גירסת 64 סיביות של Windows 7 או Vista, הקלד %CommonProgramFiles(x86)%\Microsoft Shared ולאחר מכן לחץ על אישור.

  5. אם התיקיות הבאות קיימות, מחק אותן:
    • Office12
    • Source Engine
  6. לחץ על הפעל.
  7. לחץ על כל התוכניות, ולאחר מכן פתח את התיקייה עזרים (דלג על שלב זה ב- Windows XP).
  8. לחץ על הפעלה, ולאחר מכן לחץ התיבה פתח.
  9. הקלד %ProgramFiles%\Microsoft Office, ואז לחץ על אישור.
    שים לב במחשב המופעל באמצעות גירסת 64 סיביות של Windows 7 או Vista, הקלד %ProgramFiles(x86)%\Microsoft Office ולאחר מכן לחץ על אישור.

  10. מחקר את התיקיה Office12.
  11. בתיקיית השורש בכל כונן דיסק קשיח, אתר את התיקייה MSOCache ולאחר מכן פתח אותה. אם לא ניתן לראות את התיקייה, בצע את הפעולות הבאות:
    1. פתח את סייר Windows ולאחר מכן, בתפריט כלים, לחץ על אפשרויות תיקייה.
    2. לחץ על הכרטיסייה תצוגה.
    3. בחלונית הגדרות מתקדמות, תחת קבצים ותיקיות מוסתרים, לחץ על הצג קבצים ותיקיות מוסתרים.
    4. נקה את תיבת הסימון הסתר קבצים מוגנים של מערכת ההפעלה ולאחר מכן לחץ על אישור.
  12. פתח את התיקייה All Users בתיקייה MSOCache, ואז מחק כל תיקייה המכילה את הטקסט 0FF1CE}- בשם התיקייה.
    שים לב טקסט זה מכיל אפס ואחד במקום האותיות "O" ו- "I".
    דוגמה {90140000-001B-0409-0000-0000000FF1CE}-C
שלב 4: הסר את כל הקבצים שנותרו מהתקנת Microsoft Office 2007.
  1. לחץ על הפעל.
  2. לחץ על כל התוכניות, ולאחר מכן פתח את התיקייה עזרים (דלג על שלב זה ב- Windows XP).
  3. לחץ על הפעלה, ולאחר מכן לחץ התיבה פתח.
  4. הקלד %appdata%\microsoft\templates, ולאחר מכן לחץ על אישור.
  5. מחק את הקבצים הבאים:
    • Normal.dot
    • Normalemail.dotm
  6. לחץ על הפעל.
  7. לחץ על כל התוכניות, ולאחר מכן פתח את התיקייה עזרים (דלג על שלב זה ב- Windows XP).
  8. לחץ על הפעלה, ולאחר מכן לחץ התיבה פתח.
  9. הקלד %appdata%\microsoft\document building blocks, ולאחר מכן לחץ על אישור.
  10. פתח את תיקיית המשנה שבתיקייה Document Building Blocks.
    שים לב שם תיקיית המשנה יהיה מספר בן 4 ספרות המייצג את השפה של חבילת Microsoft Office.

  11. מחק את הקובץ building blocks.dotx.
  12. סגור את כל התוכניות לפני שתבצע את שאר השלבים.
  13. לחץ על הפעל.
  14. לחץ על כל התוכניות, ולאחר מכן פתח את התיקייה עזרים (דלג על שלב זה ב- Windows XP).
  15. לחץ על הפעלה, ולאחר מכן לחץ התיבה פתח.
  16. הקלד %temp% ולאחר מכן לחץ על אישור.
  17. בתפריט עריכה, לחץ על בחר הכל.
  18. בתפריט קובץ, לחץ על מחק.
  19. לחץ על הפעל.
  20. לחץ על כל התוכניות, ולאחר מכן פתח את התיקייה עזרים (דלג על שלב זה ב- Windows XP).
  21. לחץ על הפעלה, ולאחר מכן לחץ התיבה פתח.
  22. הקלד %AllUsersprofile%\Application Data\Microsoft\Office\Data, ולאחר מכן לחץ על אישור.
  23. מחק את הקובץ opa12.dat (וקובץ זה בלבד!).
שלב 5: הסר את מפתחות המשנה של הרישום השייכים ל- Microsoft Office System 2007.
אזהרה שינוי שגוי של הרישום באמצעות עורך הרישום או בשיטה אחרת עלול לגרום לבעיות חמורות. בעיות אלה עלולות לחייב התקנה מחדש של מערכת ההפעלה. Microsoft אינה ערבה לכך שבעיות אלה ניתנות לפתרון. שינוי הרישום הוא באחריותך הבלעדית.

חשוב מאמר זה מכיל מידע על אופן השינוי של הרישום. הקפד לגבות את הרישום לפני שינויו. ודא שאתה יודע כיצד לשחזר את הרישום במקרה שתתעורר בעיה. לקבלת מידע נוסף על אופן הגיבוי, השחזור והשינוי של הרישום, לחץ על מספר המאמר שלהלן כדי להציגו מתוך מאגר הידע Microsoft Knowledge Base:
322756 כיצד לגבות ולשחזר את הרישום ב- Windows

אתר ולאחר מכן מחק את מפתחות המשנה של הרישום עבור Office 2007 אם הם קיימים. לשם כך, בצע את הפעולות הבאות:
  1. לחץ על הפעל.
  2. לחץ על כל התוכניות, ולאחר מכן פתח את התיקייה עזרים (דלג על שלב זה ב- Windows XP).
  3. לחץ על הפעלה, ולאחר מכן לחץ התיבה פתח.
  4. הקלד regedit ולאחר מכן לחץ על אישור.
  5. לחץ על מפתח המשנה הבא:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  6. בתפריט קובץ, לחץ על ייצוא, הקלד DeletedKey01 ולאחר מכן לחץ על שמור.
  7. בתפריט עריכה, לחץ על מחק ולאחר מכן לחץ על כן לאישור.
  8. חזור על שלבים אלה (1 עד 7) עבור כל מפתח משנה של הרישום ברשימה הבאה. שנה את שם המפתח המיוצא עבור כל מפתח משנה.
    לדוגמה, הקלד DeletedKey02 עבור המפתח השני, הקלד DeletedKey03 עבור המפתח השלישי וכן הלאה.
הערה במפתחות הרישום הבאים, תו הכוכבית (*) מייצג תו אחד או יותר בשם של מפתח הרישום.

גירסאות 32 סיביות של Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Upgrade Codes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Assemblies\*Office12*
גירסאות 64 סיביות של Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Asemblies\*Office12*
המשך עם מפתחות המשנה הבאים של הרישום:
  1. אתר את מפתח המשנה הבא:

    32 סיביות: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
    64 סיביות: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

  2. בתפריט קובץ, לחץ על ייצוא, הקלד UninstallKey01 ולאחר מכן לחץ על שמור.
  3. תחת מפתח המשנה Uninstall שאיתרת בשלב 1, לחץ על כל מפתח משנה, ולאחר מכן קבע אם מוקצה לו הערך הבא:
    • שם: UninstallString:
    • Data: file_name path\Office Setup Controller\Setup.exe path

      הערה בדוגמה זו, file_name הוא מציין מיקום של שם תוכנית ההתקנה, ו- path הוא מציין מיקום של נתיב הקובץ.
  4. אם מפתח המשנה מכיל את השם והנתונים המתוארים בשלב 3, לחץ על מחק בתפריט עריכה. אחרת, עבור לשלב 5.
  5. חזור על שלבים 3 ו- 4 עד שתאתר ולאחר מכן תמחק כל מפתח משנה המתאים לשם ולנתונים המתוארים בשלב 3.
  6. סגור את עורך הרישום.
שלב 6: הפעל מחדש את המחשב.
הפעל מחדש את המחשב. אם ההסרה בוצעה בהצלחה, סיימת את התהליך וכעת תוכל להתקין מחדש את Microsoft Office, אם תרצה בכך. אם ההסרה לא בוצעה בהצלחה, עבור אל סעיף "הפניות" במאמר זה.
כווץ את התמונההרחב את התמונה
assets folding end collapsed


מאפיינים

Article ID: 928218 - Last Review: יום ראשון 09 מרץ 2014 - Revision: 22.0
המידע במאמר זה חל על:
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Basic 2007
מילות מפתח 
kbexpertiseinter kberrmsg kbregistry kbsetup kbinstallation kbtshoot kbprb kbfixme kbmsifixme kbcip KB928218

ספק משוב

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com