SATA optical drives are not available after you start a Windows Vista-based computer

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Article ID: 928253 - View products that this article applies to.
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SYMPTOMS

Serial Advanced Technology Attachment (SATA) optical drives, such as a CD or a DVD drive, may not be available after you start a Windows Vista-based computer.

CAUSE

This problem may occur if the computer uses an Advanced Host Controller Interface (AHCI) chipset. The problem does not occur if the AHCI chipset uses Parallel Advanced Technology Attachment (PATA) emulation mode.

WORKAROUND

To work around this problem, enable PATA emulation in the system BIOS. Contact the manufacturer of your hardware for more information about how to do this.

For information about your hardware manufacturer, visit the following Web site:
http://support.microsoft.com/gp/vendors/en-us

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Aliide.sys1.2.0.014,95217-Nov-200608:35x86
Amdide.sys6.0.6000.2048515,46417-Nov-200608:35x86
Atapi.sys6.0.6000.2048519,04817-Nov-200608:35x86
Ataport.sys6.0.6000.20485107,11217-Nov-200608:37x86
Cmdide.sys2.0.7.016,48817-Nov-200608:35x86
Intelide.sys6.0.6000.2048514,95217-Nov-200608:35x86
Msahci.sys6.0.6000.2048523,14417-Nov-200608:36x86
Pciide.sys6.0.6000.2048513,41617-Nov-200608:35x86
Pciidex.sys6.0.6000.2048542,60017-Nov-200608:36x86
Viaide.sys5.1.3790.15017,51217-Nov-200608:35x86
Aliide.sys1.2.0.014,95217-Nov-200609:12x86
Amdide.sys6.0.6000.1639115,46417-Nov-200609:12x86
Atapi.sys6.0.6000.1639119,04817-Nov-200609:12x86
Ataport.sys6.0.6000.16391107,11217-Nov-200609:15x86
Cmdide.sys2.0.7.016,48817-Nov-200609:12x86
Intelide.sys6.0.6000.1639114,95217-Nov-200609:12x86
Msahci.sys6.0.6000.1639123,14417-Nov-200609:12x86
Pciide.sys6.0.6000.1639113,41617-Nov-200609:11x86
Pciidex.sys6.0.6000.1639142,60017-Nov-200609:13x86
Viaide.sys5.1.3790.15017,51217-Nov-200609:12x86
Windows Vista, 64-bit versions
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File nameFile versionFile sizeDateTimePlatform
Hccoin.dll6.0.6000.2048510,75217-Nov-200609:11x64
Usbd.sys6.0.6000.204857,55217-Nov-200606:56x64
Usbehci.sys6.0.6000.2048548,12817-Nov-200606:56x64
Usbhub.sys6.0.6000.20485265,21617-Nov-200606:57x64
Usbohci.sys6.0.6000.2048524,06417-Nov-200606:56x64
Usbport.sys6.0.6000.20485256,51217-Nov-200606:57x64
Usbuhci.sys6.0.6000.2048528,67217-Nov-200606:56x64
Aliide.sys1.2.0.015,97617-Nov-200609:46x64
Amdide.sys6.0.6000.1639115,97617-Nov-200609:46x64
Atapi.sys6.0.6000.1639120,07217-Nov-200609:47x64
Ataport.sys6.0.6000.16391121,44817-Nov-200609:49x64
Cmdide.sys2.0.7.018,02417-Nov-200609:47x64
Intelide.sys6.0.6000.1639116,48817-Nov-200609:47x64
Msahci.sys6.0.6000.1639124,68017-Nov-200609:47x64
Pciide.sys6.0.6000.1639113,41617-Nov-200609:46x64
Pciidex.sys6.0.6000.1639148,74417-Nov-200609:48x64
Viaide.sys5.1.3790.15018,02417-Nov-200609:47x64
Aliide.sys1.2.0.015,97617-Nov-200609:32x64
Amdide.sys6.0.6000.2048515,97617-Nov-200609:32x64
Atapi.sys6.0.6000.2048520,07217-Nov-200609:32x64
Ataport.sys6.0.6000.20485121,44817-Nov-200609:34x64
Cmdide.sys2.0.7.018,02417-Nov-200609:32x64
Intelide.sys6.0.6000.2048516,48817-Nov-200609:32x64
Msahci.sys6.0.6000.2048524,68017-Nov-200609:33x64
Pciide.sys6.0.6000.2048513,41617-Nov-200609:32x64
Pciidex.sys6.0.6000.2048548,74417-Nov-200609:33x64
Viaide.sys5.1.3790.15018,02417-Nov-200609:32x64
Usbccgp.sys6.0.6000.1639195,23217-Nov-200606:53x64
Usbhub.sys6.0.6000.16391265,21617-Nov-200606:53x64
Usbccgp.sys6.0.6000.2048595,23217-Nov-200606:57x64
Usbhub.sys6.0.6000.20485265,21617-Nov-200606:57x64
Hccoin.dll6.0.6000.1639110,75217-Nov-200609:20x64
Usbd.sys6.0.6000.163917,55217-Nov-200606:53x64
Usbehci.sys6.0.6000.1639148,12817-Nov-200606:53x64
Usbhub.sys6.0.6000.16391265,21617-Nov-200606:53x64
Usbohci.sys6.0.6000.1639124,06417-Nov-200606:53x64
Usbport.sys6.0.6000.16391256,51217-Nov-200606:53x64
Usbuhci.sys6.0.6000.1639128,67217-Nov-200606:53x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site:
http://www.microsoft.com/windowsxp/64bit/default.mspx
For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx

Properties

Article ID: 928253 - Last Review: May 16, 2008 - Revision: 3.2
APPLIES TO
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbvistasp1fix kbfix kbbug kbhotfixserver kbqfe kbprb kbexpertiseinter KB928253

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