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Article ID: 928447 - Last Review: October 25, 2007 - Revision: 1.1

You may notice inaccurate queue information in Exchange Server 2003 and in Exchange 2000 Server

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SYMPTOMS

On a computer that is running Microsoft Exchange Server 2003 or Microsoft Exchange 2000 Server, you may notice inaccurate queue information when you use Queue Viewer in Exchange System Manager. For example, you may notice thousands of messages in the queue or in the links to upstream routing groups. However, you can find only 50 to 100 messages when you enumerate the messages in the links to upstream routing groups.

Note You may also notice this behavior in a third-party monitoring tool. Also, you may receive false warning messages when the messages have actually been delivered.

CAUSE

This problem occurs if there are messages in the retry queue. Messages in the retry queue have already been delivered. Exchange may put messages in the retry queue if messages are being handled by multiple connections. Also, messages may be in the retry queue if Exchange is configured to wait until there are no more active connections to merge messages in the retry queue with messages in the original queue. Typically, this problem occurs on servers that have a constant flow of messages on a specific link.

WORKAROUND

To work around this problem, perform one of the following tasks:
  • Increase the number of messages for each connection.
  • Decrease the number of connections for each domain.
The task that you perform depends on the links between your routing groups.

This workaround requires testing to find the appropriate number of messages or number of connections. And, you can only perform this workaround when there is a high volume of mail. This workaround may not reduce the number of messages in the retry queue. If you use this workaround incorrectly, it may cause more issues.

Alternatively, you can increase the speed of the link to work around this problem. A faster link will significantly reduce the number of messages in the retry queue.

Note If this problem occurs in a third-party monitoring tool, contact the third-party vendor to see whether they can provide a method to filter the results.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Messages in the retry queue are counted in the Remote Retry Queue Length counter. The Remote Retry Queue Length counter is located under the SMTP Server object in the Performance Monitor tool.

Microsoft Exchange Server 2007 is not affected by this problem because of the differences in the transport component.

REFERENCES

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
823489  (http://support.microsoft.com/kb/823489/ ) How to use Queue Viewer to troubleshoot mail flow issues in Exchange Server 2003

APPLIES TO
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Keywords: 
kbesm kbtshoot kbprb kbexpertiseinter KB928447

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