REVISIÓN: Internet Explorer 6 no muestra la página Web anterior cuando se busque una aplicación Web ASP.NET y haga clic en el botón Atrás

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Id. de artículo: 928491 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que copia el registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
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Síntomas

Cuando explora una aplicación Web de ASP.NET de Microsoft en Microsoft Internet Explorer 6, haga clic en el botón Atrás . Sin embargo, Internet Explorer no muestra la página Web anterior. En su lugar, Internet Explorer incorrectamente continúa mostrando la página actual. El problema se produce cuando se cumplen las condiciones siguientes:
  • Está ejecutando Microsoft Windows XP Service Pack 2 (SP2).
  • El método de compresión de GZIP está habilitado en el servidor Web que aloja la aplicación Web ASP.NET.
  • La aplicación Web ASP.NET realiza una solicitud de devolución.

Causa

Este problema se produce porque Internet Explorer anexa una cookie interna a la entrada de caché de la aplicación Web ASP.NET si se produce una solicitud de devolución. Además, la cookie interna se utiliza para buscar la página anterior. Si el método de compresión de GZIP está habilitado, se agrega una nueva entrada de caché sin la cookie interna. Por lo tanto, no se encuentra la página anterior en la memoria caché al hacer clic el botón Atrás .

Solución

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Debe tener Microsoft Windows XP Service Pack 2 (SP2) para aplicar este hotfix instalado.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión no sustituye a ningún otro hotfix que se aplican en el equipo.

Información del registro

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Después de aplicar la revisión, debe modificar la configuración del registro para habilitar la revisión. Puede modificar la configuración de registro para un usuario específico o para todos los usuarios.

Configuración del registro para un usuario específico

Utilice uno de los métodos siguientes para habilitar la revisión para un usuario específico.
Método 1
Siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente clave del Registro:
    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 y, a continuación, presione ENTRAR.
  5. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor alfanumérico .
  6. Tipo * , y, a continuación, presione ENTRAR.
  7. En el menú Edición , haga clic en Modificar .
  8. Escriba 1 y, a continuación, haga clic en Aceptar .
  9. En el menú archivo , haga clic en Salir .
Método 2
Siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente clave del Registro:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 y, a continuación, presione ENTRAR.
  5. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Tipo * , y, a continuación, presione ENTRAR.
  7. En el menú Edición , haga clic en Modificar .
  8. Escriba 1 y, a continuación, haga clic en Aceptar .
  9. En el menú archivo , haga clic en Salir .

Configuración del registro para todos los usuarios

Utilice uno de los métodos siguientes para habilitar la revisión para todos los usuarios.
Método 1
Siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente clave del Registro:
    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 y, a continuación, presione ENTRAR.
  5. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor alfanumérico .
  6. Tipo * , y, a continuación, presione ENTRAR.
  7. En el menú Edición , haga clic en Modificar .
  8. Escriba 1 y, a continuación, haga clic en Aceptar .
  9. En el menú archivo , haga clic en Salir .
Método 2
Siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar
  2. Busque y haga clic en la siguiente clave del Registro:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_URLMON_POST_DECOMPRESSION_CACHE_COOKIE_KB928491 y, a continuación, presione ENTRAR.
  5. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Tipo * , y, a continuación, presione ENTRAR.
  7. En el menú Edición , haga clic en Modificar .
  8. Escriba 1 y, a continuación, haga clic en Aceptar .
  9. En el menú archivo , haga clic en Salir .

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Urlmon.dll6.0.2900.3038600,06420 De noviembre de 200613: 49x 86

Solución

Para evitar este problema, instale Microsoft Internet Explorer 7.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 928491 - Última revisión: jueves, 15 de noviembre de 2007 - Versión: 2.2
La información de este artículo se refiere a:
  • Microsoft Internet Explorer 6.0
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbpubtypekc KB928491 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 928491

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