Po instalaci opravy hotfix 896017 dochází v aplikaci Internet Explorer 6 k neočekávanému zavření okna Stažení souboru (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 928540 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem obnovení registru v případě, že nastane problém. Další informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

V aplikaci Microsoft Internet Explorer 6 v dialogovém okně Stažení souboru může neočekávaně ukončit při klepněte na tlačítko Uložit, Otevřít nebo Storno.

Tento problém není vyřešen, i po instalaci opravy hotfix 896017. Další informace o opravě hotfix 896017 klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
896017Okno, které spustí dialogové okno Stažení souboru, se při pokusu o stažení souboru pomocí aplikace Internet Explorer v systému Windows XP Service Pack 2 neočekávaně zavře (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Příčina

Tento problém nastane v případě splnění následujících podmínek:
  • Počítač se systémem Windows XP Service Pack 2 (SP2).
  • Stáhnout obsah obsahuje rámce.
  • Stáhnout obsah používá "content-disposition: Příloha" záhlaví HTTP.
  • Typ MIME stáhnout obsah je "text/plain".

Řešení

Informace o aktualizaci zabezpečení

Tento problém lze vyřešit instalací nejnovější kumulativní aktualizace zabezpečení pro aplikaci Internet Explorer. Chcete-li nainstalovat nejnovější aktualizace, navštivte následující web společnosti Microsoft:
http://windowsupdate.microsoft.com
Další technické informace o nejnovější kumulativní aktualizaci zabezpečení pro aplikaci Internet Explorer naleznete na následujícím webu společnosti Microsoft:
http://www.microsoft.com/technet/security/current.aspx
Poznámka:Tato oprava byla poprvé zahrnuta v aktualizaci zabezpečení 933566 (MS07-033). Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
933566MS07-033: Kumulativní aktualizace zabezpečení pro aplikaci Internet Explorer

Informace o opravě hotfix

Požadavky

Chcete-li použít tuto opravu hotfix, musí mít aplikaci Internet Explorer 6 a aktualizací Service Pack 2.

Požadavek na restartování

Po instalaci této opravy hotfix bude třeba restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce Datum a čas v ovládacím.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPSložka služby
Mshtml.dll6.0.2900.30563,062,27227. Prosince 200617: 07X86SP2SP2QFE
Shdocvw.dll6.0.2900.30561,498,11227. Prosince 200617: 07X86SP2SP2QFE
Updspapi.dll6.2.29.0371,42419. Leden 200619: 29X86NONENelze použít

Informace o registru

Upozornění Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Po instalaci opravy hotfix povolit změny, které provádí opravu hotfix takto:
  1. Ukončete aplikaci Internet Explorer 6.
  2. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz regedit a klepněte na tlačítko OK.
  3. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    Poznámka: Pokud podklíč FeatureControl neexistuje, přidejte ji takto:
    1. Main
      klepněte pravým tlačítkem myši, přejděte na příkaz Nový a klepněte na příkaz klíč.
    2. Zadejte název nového podklíče a stiskněte klávesu ENTER FeatureControl.
  4. Klepněte pravým tlačítkem myši
    FeatureControl
    , přejděte na příkaz Nový a klepněte na příkaz klíč.
  5. Zadejte název nového podklíče a stiskněte klávesu ENTER FEATURE_PREVENT_CDA_CLOSE_KB928540.
  6. Klepněte pravým tlačítkem myši
    FEATURE_PREVENT_CDA_CLOSE_KB928540
    , přejděte na příkaz Nový a potom klepněte na příkaz Hodnota DWORD.
  7. Zadejte název nové položky registru a potom stiskněte klávesu ENTER iexplore.exe.
  8. Klepněte pravým tlačítkem myši
    iexplore.exe
    a potom klepněte na příkaz změnit.
  9. V poli Údaj hodnoty zadejte 1 a potom klepněte na tlačítko OK.
  10. Ukončete program Editor registru.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Další informace o termínech používaných k popisu aktualizací softwaru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 928540 - Poslední aktualizace: 29. srpna 2007 - Revize: 3.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Internet Explorer 6.0 na těchto platformách
    • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
    • Microsoft Windows XP Professional Service Pack 2 (SP2)
    • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
    • Microsoft Windows XP Tablet PC Edition Service Pack 2 (SP2)
Klíčová slova: 
kbmt atdownload kbwinxpsp3fix kbwinxppresp3fix kbexpertiseadvanced kbfix kbbug kbhotfixserver kbqfe kbpubtypekc KB928540 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:928540

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com