Recibe mensajes de error de estado de trabajo en Data Protection Manager.

Este artículo le ayuda a corregir un problema en el que se producen mensajes de error de estado de trabajo si el componente de supervisión en tiempo real de un programa antivirus está configurado para supervisar réplicas y transferir archivos de registro para volúmenes protegidos de Data Protection Manager.

Versión original del producto: System Center Data Protection Manager
Número de KB original: 928840

Síntomas

Después de configurar Microsoft System Center Data Protection Manager para ayudar a proteger los datos en uno o varios servidores de archivos, experimenta los síntomas siguientes:

  • Los servidores de archivos contienen réplicas incoherentes.

  • Al usar la consola de administrador de Data Protection Manager, observa que las tasas de transferencia de datos pueden ralentizarse aleatoriamente.

  • Los trabajos de replicación de datos pueden producir un error en uno o varios servidores de archivos. En esta situación, se genera información de estado de trabajo similar a la siguiente en los servidores de archivos afectados:

    Mensaje de estado 1

    Tipo: comprobación de coherencia
    Estado: error
    Descripción: el servicio DPM no pudo comunicarse con el Agente de archivos DPM en el servidor localhost. (Id. 52 Detalles: El nombre de red especificado ya no está disponible (0x80070040))
    Hora de inicio: <startTime>
    Tiempo transcurrido: <elapsedTime>
    Datos transferidos: 118,51 GB (127253828784 bytes)
    Velocidad de transferencia de datos: 464 KB/s
    Detalles de origen: <Volumen> en <ServerName>
    Miembros del grupo de protección: 7
    Detalles
    Grupo de protección: <ProtectionGroup>

    Mensaje de estado 2

    Tipo: Sincronización
    Estado: error
    Descripción: la réplica en el servidor DPM para <Volume> en <ServerName> es incoherente. Los cambios no se pueden aplicar al archivo <FilePath>. (Detalles del identificador 109: el proceso no puede acceder al archivo porque lo usa otro proceso (0x80070020))
    Hora de inicio: <startTime>
    Tiempo transcurrido: <elapsedTime>
    Datos transferidos: 1,79 GB (1916715024 bytes)
    Velocidad de transferencia de datos: 100 KB/s
    Detalles de origen: <Volumen> en <ServerName>
    Miembros del grupo de protección: 7
    Detalles
    Grupo de protección: <ProtectionGroup>

    Mensaje de estado 3

    Tipo: Sincronización
    Estado: error
    Descripción: la réplica en el servidor DPM para <Volume> en <ServerName> es incoherente. Los cambios no se pueden aplicar al archivo <FilePath>. (Detalles del identificador 109: se deniega el acceso (0x80070005))
    Hora de inicio: <startTime>
    Tiempo transcurrido: <elapsedTime>
    Datos transferidos: 1,57 GB (1691028040 bytes)
    Velocidad de transferencia de datos: 207 KB/s
    Detalles de origen: <Volumen> en <ServerName>
    Miembros del grupo de protección: 2
    Detalles
    Grupo de protección: <ProtectionGroup>

    Mensaje de estado 4

    Tipo: Sincronización
    Estado: error
    Descripción: la réplica en el servidor DPM para <Volume> en <ServerName> es incoherente. Los cambios no se pueden aplicar al archivo <FilePath>. (Id. 109 Detalles: El sistema no puede encontrar la ruta de acceso especificada (0x80070003))
    Hora de inicio: <startTime>
    Tiempo transcurrido: <elapsedTime>
    Datos transferidos: 116,74 MB (122411432 bytes)
    Velocidad de transferencia de datos: 221 KB/s
    Detalles de origen: <Volumen> en <ServerName>
    Miembros del grupo de protección: 2
    Grupo de protección de detalles: <ProtectionGroup>

    Nota:

    También puede recibir otros mensajes de error de estado de trabajo.

  • Es posible que se produzca un error en la sincronización de Data Protection Manager. En esta situación, recibirá mensajes de estado similares a uno de los siguientes:

    Mensaje de estado 1

    Descripción: desde <la fecha y la hora>, se han producido errores en los trabajos de sincronización de la< ruta de acceso > en <ServerName>. Número total de trabajos con errores = 4. Error en el último trabajo por el siguiente motivo: (id. 3115) DPM no pudo completar este trabajo en el tiempo asignado para el conjunto de trabajos asociados a este grupo de protección. (id. 3151).

    Mensaje de estado 2

    Tipo: Sincronización
    Estado: error
    Descripción: la réplica del servidor DPM para la <ruta de acceso> en <ServerName> es incoherente. Los cambios no se pueden aplicar a la ruta de acceso del archivo< y al nombre >de archivo. (Detalles del identificador 109: acceso denegado (0x80070005)
    Hora de inicio: <fecha y hora>
    Tiempo transcurrido: <elapsedTime>
    Datos transferidos: 18,75 MB (19662648 bytes)
    Velocidad de transferencia de datos: 83 KB/s
    Detalles de origen: <ruta de acceso> en <ServerName>
    Grupo de protección: <ProtectionGroup>

Causa

Este problema puede producirse si el componente de supervisión en tiempo real de un programa antivirus está configurado para supervisar réplicas y transferir archivos de registro para volúmenes protegidos de Data Protection Manager. Puede experimentar este problema si el componente de supervisión en tiempo real de un programa antivirus supervisa el programa Msdpmfsagent.exe en el servidor de Data Protection Manager.

Solución

Para resolver este problema, consulte Ejecución de software antivirus en el servidor DPM.

Más información

La supervisión antivirus en tiempo real de réplicas y archivos de registro de transferencia reduce el rendimiento en Data Protection Manager. Este comportamiento se produce porque el proceso de supervisión en tiempo real hace que el programa antivirus examine los registros de transferencia cada vez que Data Protection Manager se sincroniza con el servidor de archivos. Además, el proceso de supervisión en tiempo real hace que el programa antivirus examine todos los archivos afectados cada vez que Data Protection Manager aplica cambios a las réplicas.

Se recomienda configurar el programa antivirus para eliminar archivos infectados de servidores de archivos y del servidor de Data Protection Manager en lugar de usar la característica de cuarentena para archivar archivos infectados. Esto ayuda a evitar daños en los datos de réplicas y instantáneas.

Si un programa antivirus está configurado para limpiar y poner en cuarentena automáticamente un archivo infectado, el programa antivirus modifica el archivo. Sin embargo, Data Protection Manager no puede detectar estos cambios en el archivo. Cuando Data Protection Manager intenta sincronizar una réplica modificada por otro programa, la réplica y las instantáneas del archivo pueden estar dañadas. Para obtener más información sobre cómo configurar un programa antivirus para eliminar archivos infectados, consulte la documentación del programa o póngase en contacto con el fabricante del programa antivirus.