Data Protection Manager でジョブの状態エラー メッセージを受け取る
この記事は、Data Protection Manager で保護されたボリュームのレプリカを監視し、ログ ファイルを転送するようにウイルス対策プログラムのリアルタイム監視コンポーネントが構成されている場合に、ジョブの状態エラー メッセージが発生する問題を解決するのに役立ちます。
元の製品バージョン: System Center Data Protection Manager
元の KB 番号: 928840
現象
1 つ以上のファイル サーバー上のデータを保護するためにMicrosoft System Center Data Protection Managerを構成すると、次のような現象が発生します。
ファイル サーバーに不整合なレプリカが含まれています。
Data Protection Manager 管理者コンソールを使用すると、データ転送速度がランダムに遅くなる可能性があります。
データ レプリケーション ジョブは、1 つ以上のファイル サーバーで失敗する可能性があります。 この状況では、影響を受けるファイル サーバーで、次のようなジョブの状態情報が生成されます。
ステータス メッセージ 1
型: 整合性チェック
状態: 失敗しました
説明: DPM サービスは、サーバー localhost 上の DPM ファイル エージェントと通信できませんでした。 (ID 52 詳細: 指定されたネットワーク名は使用できなくなりました (0x80070040))
開始時刻: <startTime>
経過時間: <elapsedTime>
転送されるデータ: 118.51 GB (127253828784 バイト)
データ転送速度: 464 KB/秒
ソースの詳細: <ServerName の<ボリューム>>
保護グループ メンバー: 7
詳細
保護グループ: <ProtectionGroup>ステータス メッセージ 2
型: 同期
状態: 失敗しました
説明: DPM サーバー上の [ボリューム> on ServerName>] の<レプリカに<一貫性がありません。 FilePath> ファイル<に変更を適用することはできません。 (ID 109 詳細: プロセスは別のプロセスで使用されているため、ファイルにアクセスできません (0x80070020))
開始時刻: <startTime>
経過時間: <elapsedTime>
転送されるデータ: 1.79 GB (1916715024 バイト)
データ転送速度: 100 KB/秒
ソースの詳細: <ServerName の<ボリューム>>
保護グループ メンバー: 7
詳細
保護グループ: <ProtectionGroup>ステータス メッセージ 3
型: 同期
状態: 失敗しました
説明: DPM サーバー上の [ボリューム> on ServerName>] の<レプリカに<一貫性がありません。 FilePath> ファイル<に変更を適用することはできません。 (ID 109 詳細: アクセスが拒否されました (0x80070005))
開始時刻: <startTime>
経過時間: <elapsedTime>
転送されるデータ: 1.57 GB (1691028040 バイト)
データ転送速度: 207 KB/秒
ソースの詳細: <ServerName の<ボリューム>>
保護グループ メンバー: 2
詳細
保護グループ: <ProtectionGroup>ステータス メッセージ 4
型: 同期
状態: 失敗しました
説明: DPM サーバー上の [ボリューム> on ServerName>] の<レプリカに<一貫性がありません。 FilePath> ファイル<に変更を適用することはできません。 (ID 109 詳細: 指定されたパスが見つかりません (0x80070003))
開始時刻: <startTime>
経過時間: <elapsedTime>
転送されるデータ: 116.74 MB (122411432 バイト)
データ転送速度: 221 KB/秒
ソースの詳細: <ServerName の<ボリューム>>
保護グループ メンバー: 2
詳細保護グループ: <ProtectionGroup>注:
また、他のジョブ状態エラー メッセージを受け取る場合もあります。
Data Protection Manager の同期が失敗する可能性があります。 このような場合は、次のいずれかの状態メッセージが表示されます。
ステータス メッセージ 1
説明: 日付と時刻>以降<、ServerName> 上のパス>の<<同期ジョブは失敗しています。 失敗したジョブの合計数 = 4。 最後のジョブは次の理由で失敗しました。 (ID 3115) DPM は、この保護グループに関連付けられているジョブのセットに割り当てられた時間内にこのジョブを完了できませんでした。 (ID 3151)。
ステータス メッセージ 2
型: 同期
状態: 失敗しました
説明: ServerName> 上のパス>の < DPM サーバー上のレプリカに<一貫性がありません。 ファイル パスとファイル<名>に変更を適用することはできません。 (ID 109 詳細: アクセスが拒否されました (0x80070005)
開始時刻: <日付と時刻>
経過時間: <elapsedTime>
転送されるデータ: 18.75 MB (19662648 バイト)
データ転送速度: 83 KB/秒
ソースの詳細: <ServerName の<パス>>
保護グループ: <ProtectionGroup>
原因
この問題は、ウイルス対策プログラムのリアルタイム監視コンポーネントが、レプリカを監視し、Data Protection Manager で保護されたボリュームのログ ファイルを転送するように構成されている場合に発生する可能性があります。 この問題は、ウイルス対策プログラムのリアルタイム監視コンポーネントが、Data Protection Manager サーバー上の Msdpmfsagent.exe プログラムを監視する場合に発生する可能性があります。
解決方法
この問題を解決するには、「 DPM サーバーでウイルス対策ソフトウェアを実行する」を参照してください。
詳細
レプリカと転送ログ ファイルのウイルス対策リアルタイム監視により、Data Protection Manager のパフォーマンスが低下します。 この動作は、リアルタイム監視プロセスによって、Data Protection Manager がファイル サーバーと同期するたびに、ウイルス対策プログラムによって転送ログがスキャンされるために発生します。 また、リアルタイム監視プロセスにより、Data Protection Manager がレプリカに変更を適用するたびに、影響を受けるすべてのファイルがウイルス対策プログラムによってスキャンされます。
検疫機能を使用して感染したファイルをアーカイブするのではなく、ファイル サーバーと Data Protection Manager サーバーから感染したファイルを削除するようにウイルス対策プログラムを構成することをお勧めします。 これは、レプリカとシャドウ コピーのデータ破損を防ぐために役立ちます。
ウイルス対策プログラムが感染したファイルを自動的にクリーンして検疫するように構成されている場合、ウイルス対策プログラムはファイルを変更します。 ただし、Data Protection Manager では、ファイルに対するこれらの変更を検出できません。 Data Protection Manager が別のプログラムによって変更されたレプリカを同期しようとすると、レプリカとファイルのシャドウ コピーが破損している可能性があります。 ウイルス対策プログラムを構成して感染したファイルを削除する方法の詳細については、プログラムのドキュメントを参照するか、ウイルス対策プログラムの製造元にお問い合わせください。
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