Mensaje de error cuando intenta instalar una impresora compartida de "Web apuntar e imprimir" en Windows Vista: "el proceso tener no acceso al archivo porque está siendo utilizado por otro proceso"

Seleccione idioma Seleccione idioma
Id. de artículo: 928905 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando intenta instalar a una impresora mediante la característica Web Point and Print en un equipo basado en Windows Vista, puede recibir el siguiente mensaje de error:
El proceso no puede tener acceso el archivo porque está siendo utilizado por otro proceso.
Este problema se produce cuando intenta instalar a una impresora de impresión de Internet (IPP) desde un servidor de impresión basado en Windows Vista y si se cumplen las condiciones siguientes:
  • Ha iniciado sesión en con una cuenta de usuario está localizada para una configuración regional de lenguaje que utiliza un conjunto de caracteres no latinos.
  • La instalación de Windows Vista se adapta para una configuración regional que utiliza un conjunto de caracteres no latinos.
Además, la instalación no finaliza.

Causa

Este problema se produce porque el programa ejecutable de "Web apuntar e imprimir" (Wpnpinst.exe) no admite instalar a una impresora IPP si la cuenta de usuario está traducida a utilizar un conjunto de caracteres no latinos.

Solución

Para evitar este problema e instalar y utilizar una impresora IPP, utilice uno de los métodos siguientes.

Método 1: Instalar y utilizar una impresora IPP en un entorno de intranet

Este método se aplica a ambos un controlador de impresora que se incluye con Windows Vista y un controlador de impresora de fabricante de equipos originales (OEM). Cuando instala una impresora IPP que se encuentra en un intranet conectada basado en Windows Vista impresión servidor, se crea una conexión de llamada (RPC) de directa procedimiento remoto. La autenticación de Windows requiere que la cuenta de usuario que se utiliza para conectar la impresora IPP debe cumplir una de las condiciones siguientes:
  • La cuenta de usuario debe ser una cuenta de dominio.
  • La cuenta de usuario que se utiliza para conectar la impresora IPP debe crearse en el equipo cliente y en el equipo servidor de impresión.
  • La cuenta de usuario en el equipo servidor de impresión debe utilizar las mismas credenciales que la cuenta en el equipo cliente.
Cuando utiliza la autenticación de Windows Vista, puede instalar a una impresora IPP utilizando credenciales de cuenta de usuario idénticos si se cumplen las condiciones siguientes:
  • La cuenta de usuario en el equipo cliente se adapta para una configuración regional que utiliza un conjunto de caracteres no latinos.
  • La cuenta de usuario en el servidor de impresión basado en Windows Vista está configurada para una configuración regional que utiliza un conjunto de caracteres no latinos.
Para ello, siga estos pasos:
  1. Inicie el Explorador de Internet de Windows.
  2. En el menú Herramientas , haga clic en Opciones de Internet .
  3. En la ficha seguridad , haga clic en intranet local y, a continuación, mueva el control deslizante al valor medio bajo .
  4. Haga clic en para desactivar la casilla de verificación Habilitar modo protegido (requiere reiniciar Internet Explorer) y, a continuación, haga clic en Aceptar .
  5. En la barra de direcciones, escriba lo siguiente y, a continuación, presione ENTRAR:
    http:// Contoso Contoso/Printers /
    Nota En este ejemplo, Contoso es un marcador para el nombre de un servidor de impresión. Después de presionar ENTRAR, se muestra una lista de todas las impresoras que se encuentran en el servidor de impresión de Contoso en la ventana del explorador.
  6. En la lista de impresoras disponibles, haga clic en el nombre de la impresora que desee y, a continuación, haga clic en Conectar en Acciones de impresora .
La impresora está conectada al equipo y Windows instala al controlador de impresora apropiado para su equipo.

Una vez finalizada la instalación, el icono para esta impresora se agrega a la carpeta impresoras del equipo. Puede utilizar, supervisar y administrar la impresora como si estuviera conectada al equipo en un puerto de impresora.
Nota Una vez finalizada la instalación, vuelva a habilitar modo protegido en Internet Explorer.

Método 2: Instalar y utilizar una impresora que no sean de IPP de OEM en un entorno de Internet

Este método sólo se aplica a un controlador de impresora que se incluye con Windows Vista. Una cuenta de usuario está localizada para una configuración regional de lenguaje que utiliza un conjunto de caracteres no latinos puede instalar a una impresora IPP que se encuentra en Internet mediante un servidor de impresión basado en Windows Vista. El servidor de impresión puede configurarse para utilizar cualquiera de los modos de autenticación de servidor siguientes:
  • Anónimo
  • Básico
  • Windows
Al instalar la impresora IPP, debe autenticar con las credenciales de una cuenta localizada no latina caracteres-conjunto-basadas en que se crea en el servidor de impresión basado en Windows Vista.

Nota La cuenta de usuario local debe tener el mismo nombre de usuario y la contraseña como la cuenta de usuario que se crea en el servidor de impresión basado en Windows Vista. Para ello, siga estos pasos:
  1. Inicie Internet Explorer.
  2. En el menú Herramientas , haga clic en Opciones de Internet .
  3. En la seguridad , haga clic en intranet local y, a continuación, mueva el control deslizante al valor medio bajo .
  4. Haga clic en para desactivar la casilla de verificación Habilitar modo protegido (requiere reiniciar Internet Explorer) y, a continuación, haga clic en Aceptar .
  5. En la barra de direcciones, escriba lo siguiente y, a continuación, presione ENTRAR:
    http:// Contoso Contoso/Printers /
    Nota En este ejemplo, Contoso es un marcador para el nombre de un servidor de impresión.
  6. En el cuadro nombre de usuario , escriba el nombre de cuenta de usuario de la cuenta localizado no latina caracteres-conjunto-basadas en que se crea en el servidor de impresión basado en Windows Vista.
  7. En el cuadro contraseña , escriba la contraseña de cuenta de usuario y, a continuación, haga clic en Aceptar . Una lista de todas las impresoras del servidor de impresión se muestra en la ventana del explorador.
  8. En la lista de impresoras disponibles, haga clic en el nombre de la impresora que desea conectarse y, a continuación, haga clic en Conectar en Acciones de impresora .
La impresora está conectada al equipo y Windows instala al controlador de impresora apropiado para su equipo.

Una vez finalizada la instalación, el icono para esta impresora se agrega a la carpeta Impresoras del equipo. Puede utilizar, supervisar y administrar la impresora como si estuviera conectada al equipo en un puerto de impresora.

Nota Una vez finalizada la instalación, vuelva a habilitar modo protegido en Internet Explorer.

Además, puede conceder acceso de cuentas de usuario local todo al puerto HTTP instaladas y la impresora. Esto es posible porque las credenciales que se utiliza para instalar a la impresora IPP se guardan en formato cifrado en el equipo. Para ello, siga estos pasos:
  1. Haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    Start button
    y, a continuación, haga clic en impresoras .
  2. Haga clic con el botón secundario en la impresora que ha instalado, haga clic en Ejecutar como administrador y, a continuación, haga clic en Propiedades .

    Contraer esta imagenAmpliar esta imagen
    User Account Control permission
    Si se le pide una contraseña de administrador o de confirmación, escriba su contraseña o haga clic en continuar .
  3. Haga clic en puertos .
  4. En la lista puerto, haga clic en el nuevo puerto de impresora HTTP, haga clic en Configurar puerto y, a continuación, escriba las credenciales de cuenta de usuario válido de la impresora.
  5. Haga clic en usar la misma configuración de seguridad para todos los usuarios y, a continuación, haga clic en Aceptar .

Método 3: Instalar y usar cualquier impresora IPP en un entorno de Internet

Este método se aplica a un controlador de impresora que se incluye con Windows Vista y un controlador de impresora de fabricante de equipos originales (OEM). Una cuenta de usuario no está localizada puede instalar a una impresora IPP que se encuentra en Internet mediante un servidor de impresión basado en Windows Vista. El servidor de impresión puede configurarse para utilizar cualquiera de los modos de autenticación de servidor siguientes:
  • Anónimo
  • Básico
  • Windows
Al instalar la impresora IPP, debe autenticar con las credenciales de una cuenta creada en el servidor de impresión basado en Windows Vista.

Nota La cuenta de usuario local debe tener el mismo nombre de usuario y la contraseña como la cuenta de usuario que se crea en el servidor de impresión basado en Windows Vista.

Para ello, siga estos pasos:
  1. Inicie Internet Explorer.
  2. En el menú Herramientas , haga clic en Opciones de Internet .
  3. En la ficha seguridad , haga clic en intranet local , mueva el control deslizante al valor medio bajo .
  4. Haga clic en para desactivar la casilla de verificación Habilitar modo protegido (requiere reiniciar Internet Explorer) y, a continuación, haga clic en Aceptar .
  5. En la barra de direcciones, escriba lo siguiente y, a continuación, presione ENTRAR:
    http:// Contoso Contoso/Printers /
    Nota En este ejemplo, Contoso es un marcador para el nombre de un servidor de impresión.
  6. En el campo nombre de usuario , escriba el nombre de cuenta de usuario de la cuenta de usuario que se crea en el servidor de impresión basado en Windows Vista.
  7. En el campo contraseña , escriba la contraseña de cuenta de usuario y, a continuación, haga clic en Aceptar . Una lista de todas las impresoras del servidor de impresión se muestra en la ventana del explorador.
  8. En la lista de impresoras disponibles, haga clic en el nombre de la impresora que desee y, a continuación, haga clic en Conectar en Acciones de impresora .
La impresora está conectada al equipo y Windows instala al controlador de impresora apropiado para su equipo.

Una vez finalizada la instalación, el icono para esta impresora se agrega a la carpeta Impresoras del equipo. Puede utilizar, supervisar y administrar la impresora como si estuviera conectada al equipo en un puerto de impresora.

Nota Una vez finalizada la instalación, vuelva a habilitar modo protegido en Windows Internet Explorer.

Además, puede conceder acceso de cuentas de usuario local todo al puerto HTTP instaladas y la impresora. Esto es posible porque las credenciales que se utiliza para instalar a la impresora IPP se guardan en formato cifrado en el equipo. Para ello, siga estos pasos:
  1. Haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    Start button
    y, a continuación, haga clic en impresoras .
  2. Haga clic con el botón secundario en la impresora que ha instalado, haga clic en Ejecutar como administrador y, a continuación, haga clic en Propiedades .

    Contraer esta imagenAmpliar esta imagen
    User Account Control permission
    Si se le pide una contraseña de administrador o de confirmación, escriba su contraseña o haga clic en continuar .
  3. Haga clic en puertos .
  4. En la lista puerto, haga clic en el nuevo puerto de impresora HTTP, haga clic en Configurar puerto y, a continuación, escriba las credenciales de cuenta de usuario válido de la impresora.
  5. Haga clic en usar la misma configuración de seguridad para todos los usuarios y, a continuación, haga clic en Aceptar .

Estado

Microsoft ha confirmado que se trata de un error de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Funcionamiento de la impresión de Internet

Con la característica de impresión de Internet de Windows Vista, puede utilizar un explorador Web para conectar las impresoras que se comparten en un servidor de impresión que ejecuta Servicios de Internet Information Server (IIS). Impresión se implementa por medio del protocolo de impresión de Internet (IPP) está encapsulado en el protocolo de transferencia de hipertexto (HTTP).

Escribiendo la dirección (URL) de una impresora compartida en la barra Dirección del explorador, puede conectar su equipo a una impresora compartida e imprimir desde esa impresora en la misma manera como si estuviera conectada al equipo en un puerto local. Puede ver una página Web en el que se enumeran todas las impresoras en un servidor. O puede ver una página Web que es específica de la impresora que desea conectarse.

Desde la página Web de una impresora específica, puede ver información acerca de la impresora. Esta información incluye elementos como el modelo de impresora, la ubicación y el número de documentos que esperan para imprimirse. Esta información también incluye propiedades de impresora, como la velocidad de impresión, y si la impresora admite impresión en color. Puede pausar, reanudar y cancelar la impresión de cualquier documento que envíe a la impresora. Además, si tiene el permiso Administrar impresoras para la impresora, también puede pausar o reanudar el funcionamiento de la impresora.

Propiedades

Id. de artículo: 928905 - Última revisión: jueves, 15 de marzo de 2007 - Versión: 1.3
La información de este artículo se refiere a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Palabras clave: 
kbmt kbsettings kbprinters kbprint kbpending kbbug kbexpertiseinter kbnetworkconnectivity kbnetwork kbtshoot KB928905 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 928905

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com