Artikel-ID: 929388 - Geändert am: Dienstag, 1. September 2009 - Version: 4.0

Ein "ein Fehler aufgetreten beim Starten des Prozess für Anwendungspool"CRMAppPool"" wird im Anwendungsprotokoll protokolliert nach dem Konfigurieren CRMAppPool für einen Domänenbenutzer Konto in Microsoft Dynamics CRM

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Problembeschreibung

Wenn Sie den Anwendungspool "CRMAppPool, Ausführen Nachdem Sie den Anwendungspool für einen Domänenbenutzer Konto in Microsoft CRM konfigurieren, wird die folgende Meldung im Anwendungsprotokoll protokolliert:

Ereignistyp: Fehler
Quelle: W3SVC
Ereigniskategorie: Keine
Ereignis-ID: 1059
Datum: Date
Zeit: Time
Benutzer: NV
Computer: ComputerName
Beschreibung: Fehler beim Starten aufgetreten des Prozess für Anwendungspool "CRMAppPool". Der Anwendungspool wurde deaktiviert.

Hinweis: In dieser Fehlermeldung darstellen der Platzhalter für Date und Time Platzhalter das aktuelle Datum und die tatsächliche Zeit. Z. B. das tatsächliche Datum kann "2007-12-12" und die Istzeit kann "17:53:26.138".

Wenn dieses Problem auftritt, kann der Anwendungspool "CRMAppPool nicht starten. Außerdem erhalten Sie folgende Fehlermeldung:
Dienst nicht verfügbar.
Dieses Problem tritt auf, selbst wenn das Benutzerkonto der Domäne ein Mitglied der lokalen Administratorgruppe ist.

Ursache

Das Problem tritt auf, weil der Berechtigungen oder die Benutzerrechte der Domänenbenutzer Konto nicht ausreichend sind.

Lösung

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
  1. Das Benutzerkonto der Domäne in der folgenden Gruppen in Active Directory einschließen:
    • Der Benutzer Active Directory-Gruppe
    • Die PrivUserGroup
    • Die SQLAccessGroup
    Gehen Sie hierzu folgendermaßen vor:
    1. Melden Sie sich an einen Server als ein Benutzer die Domänenadministratoren-Rechte oder die Rechte zum Aktualisieren dieser Gruppen verfügt.
    2. Klicken Sie mit der rechten Maustaste auf die Gruppe die Domänenbenutzer in Active Directory, und klicken Sie dann auf Eigenschaften .
    3. Klicken Sie im Gruppenname Geben Sie den Namen des Benutzers, der den CRM-Anwendungspool ausgeführt wird, und klicken Sie dann zwei Mal auf OK .
    4. Wiederholen Sie die Schritte b und c für die Gruppe PrivUserGroup und der Gruppe "SQLAccessGroup".
    Wenn Sie more than ein Microsoft Dynamics CRM Bereitstellung installiert haben, sind mehrere Gruppen in Active Directory vorhanden. Gehen Sie folgendermaßen vor um die Gruppen zu ermitteln, die Sie aktualisieren möchten.

    für Microsoft Dynamics CRM 3.0
    1. Führen Sie die folgende SQL-Anweisung für die MSCRM-Datenbank:
      select organizationid from organizationbase
    2. Beachten Sie die GUID. Beispielsweise kann die GUID C8AB1D52-9383-4164-B571-4C80D46674E3 sein.
    3. Suchen der Gruppe PrivUserGroup und der Gruppe "SQLAccessGroup" in Active Directory. Der Name der Gruppe enthält den GUID, die Sie in Schritt b notiert haben.
    für Microsoft Dynamics CRM 4.0
    1. Führen Sie die folgende SQL-Anweisung für die Datenbank MSCRM_config:
      select id, friendlyname from organization
    2. Beachten Sie die GUID. Beispielsweise kann die GUID C8AB1D52-9383-4164-B571-4C80D46674E3 Informationen Name sein.
    3. Suchen der Gruppe PrivUserGroup und der Gruppe "SQLAccessGroup" in Active Directory. Der Name der Gruppe enthält den GUID, die Sie in Schritt b notiert haben.
  2. Fügen Sie das Benutzerkonto der Domäne in die folgenden Gruppen in Microsoft Dynamics CRM-Server:
    • Die lokale Gruppe IIS_WPG
    • Gruppe der lokalen CRM_WPG
    Hinweis: Der Domäne Konto Benutzer muss die folgenden lokalen Benutzerrechte verfügen:
    • Annehmen der Clientidentität nach Authentifizierung rechts
    • Das Recht Anmelden als Dienst
    Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie in Microsoft Dynamics CRM-Server auf Start , zeigen Sie auf Verwaltung und klicken Sie dann auf Lokale Sicherheitsrichtlinie .
    2. Erweitern Sie Lokale Richtlinien , und klicken Sie dann auf Zuweisen von Benutzerrechten .
    3. Klicken Sie mit der rechten Maustaste auf Annehmen der Clientidentität nach Authentifizierung , und klicken Sie dann auf Eigenschaften .
    4. Klicken Sie auf Benutzer oder Gruppe hinzufügen .

      Hinweis: Sie müssen möglicherweise auf Pfad zum Auswählen der Domäne anstelle des lokalen Computers.
    5. Klicken Sie im Gruppenname Geben Sie den Namen des Benutzers, der den CRM-Anwendungspool ausgeführt wird, und klicken Sie dann zwei Mal auf OK .
    6. Wiederholen Sie Schritte 2 c über 2e für das Recht Anmelden als Dienst .
  3. Konfigurieren Sie das CRMAppPool Sicherheit Anwendungspoolkonto ein Service principal Name (SPN) verwendet. Anweisungen zum Konfigurieren von SPNs finden Sie in den principal Name (SPN) auf das Ressourcencenter Dokument Konfigurieren-Dienst: http://rc.crm.dynamics.com/rc/regcont/en_us/op/articles/configurespn.aspx (http://rc.crm.dynamics.com/rc/regcont/en_us/op/articles/configurespn.aspx)
    Hinweis:
    Für Microsoft Dynamics CRM 4.0 müssen Sie keinen SPN für das Domänenkonto erstellen.
  4. Konfigurieren Sie das CRMAppPool Sicherheit Anwendungspoolkonto für die Delegierung vertraut wird. Gehen Sie hierzu folgendermaßen vor:
    1. Melden Sie sich auf die Domänencontroller mithilfe eines Benutzerkontos, die Domäne Administrator Berechtigungen verfügt.
    2. Starten Sie das Snap-In "Active Directory-Benutzer und -Computer". Dazu klicken Sie auf Start , zeigen Sie auf Verwaltung und klicken Sie dann auf Active Directory-Benutzer und-Computer .
    3. Erweitern Sie die Domäne, klicken Sie mit der rechten Maustaste auf Sicherheit das Microsoft CRM-Anwendungspoolkonto ein, und klicken Sie dann auf Eigenschaften .
    4. Klicken Sie auf der Registerkarte Delegierung auf das Kontrollkästchen Benutzer bei Delegierungen aller Dienste (nur Kerberos) vertrauen .
    5. Klicken Sie auf OK .
    Hinweis: Für Microsoft Dynamics CRM 4.0 müssen Sie nicht das Domänenkonto als vertrauenswürdig für Delegierung zu erstellen.
  5. Starten Sie Internet Information Services (IIS) erneut. Dazu klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie IISRESET ein und klicken Sie dann auf OK .

Weitere Informationen

Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
909588  (http://support.microsoft.com/kb/909588/ ) Zum Konfigurieren von Kerberos-Authentifizierung für Microsoft CRM 3.0 und Microsoft SQL Server Reporting Services

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Dynamics CRM 4.0
  • Microsoft CRM 3.0
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 929388  (http://support.microsoft.com/kb/929388/en-us/ )
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