Un programa de MAPI no puede obtener un servidor de referencia cuando se apaga el servidor de catálogo global al que señala el programa de MAPI

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Síntomas

Un programa de MAPI no puede obtener un servidor de referencia cuando se apaga el servidor de catálogo global al que señala el programa de MAPI. Cuando esto ocurre, todos los llamadas de búsqueda de libreta de direcciones realizados por el programa de MAPI fallar. Además, se devuelve el código de error MAPI_E_NETWORK_ERROR hasta que reinicie el programa de MAPI.

El problema se produce cuando se cumplen las condiciones siguientes:
  • El programa de MAPI se ejecuta como un servicio en un servidor que tiene instalados componentes de Microsoft Exchange 2003 Service Pack 1 (SP1).
  • El sistema MAPI utiliza el proveedor de libreta de direcciones MAPI que se incluye en Exchange 2003.
  • Volver a conectar el catálogo global lógica se implementa estableciendo el indicador PR_PROFILE_ABP_ALLOW_RECONNECT en el perfil de la MAPI programa.

Causa

Durante el cierre de un servidor de catálogo global, cuando el servidor de Exchange 2003 intenta localizar un nuevo servidor de catálogo global, el servicio de centro de distribución de claves Kerberos (KDC) devuelve el código de error KDC_ERR_PRINCIPAL_UNKNOWN al servidor de Exchange 2003. A continuación, el servidor de Exchange 2003 pasa un error de credenciales error volver al programa MAPI. Este comportamiento hace que la conexión para dejar de utilizar credenciales de proceso y entrar en un estado de las credenciales de usuario. Sin embargo, el estado de las credenciales de usuario producirá un error cuando el programa de MAPI se ejecuta como un servicio. Este error se produce porque el programa de MAPI no puede solicitar las credenciales.

Solución

importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Realice una para agregar protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows


Debe crear la entrada de registro EMSAB_UserAuth_Credentials en el servidor de Exchange 2003 donde está instalado el hotfix este hotfix trabajar. Con la entrada del registro EMSAB_UserAuth_Credentials establecida en el valor 1, el proveedor MAPI no introducirá nunca el estado de credencial de usuario. Cuando todavía se está cerrando el servidor de catálogo global, los clientes MAPI que tengan esta entrada del registro continuará obtener el código de error MAPI_E_NETWORK_ERROR. Sin embargo, tan pronto como el servidor de catálogo global ha terminado cerrando y el servidor de Exchange 2003 ha establecido una conexión con un nuevo servidor de catálogo global, el cliente MAPI obtener el código de error MAPI_E_END_OF_SESSION esperado.

importante Cuando esta clave del registro está establecida en un servidor de Exchange 2003 con la revisión instalada, el estado de credencial de usuario no puede introducirse por los clientes MAPI que se ejecutan en el servidor. Esta revisión impedirá que los clientes MAPI que requieren la interfaz de usuario de conectarse a través de los límites de los dominios, donde se espera que los usuarios se pueden le pidan credenciales. Asegúrese de que no establezca la entrada del registro en los servidores de Exchange 2003 cuando la interfaz de usuario pedir credenciales deseado por los clientes MAPI que se ejecutan en los servidores. Esta revisión no modifica el comportamiento de Exchange 2003 como un servidor MAPI. Además, no afecta a los clientes de Outlook o cualquier otro MAPI que se ejecutan en otros equipos en que la clave del registro y de revisión no se aplicaron.

Para establecer el valor de registro EMSAB_UserAuth_Credentials, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Exchange Provider
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  4. En el panel de detalles, escriba EMSAB_UserAuth_Credentials y, a continuación, presione ENTRAR .
  5. Haga clic con el botón secundario del mouse en EMSAB_UserAuth_Credentials y, a continuación, haga clic en Modificar .
  6. En el cuadro de diálogo Editar valor DWORD , haga clic en decimal en el área de base .
  7. En el cuadro datos del valor , escriba 1 y, a continuación, haga clic en Aceptar .
  8. Editor de registro de salida.

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Debido a la interdependencia entre archivos, Microsoft Exchange Server 2003 Service Pack 2 (SP2) debe instalarse en el servidor antes de aplicar este hotfix. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
836993Cómo obtener los service Pack más recientes para Exchange Server 2003

Requisito de reinicio

No es necesario que reinicie el equipo una vez aplicado este hotfix.Sin embargo, los siguientes servicios se reiniciarán automáticamente al aplicar la revisión:
  • Servicio Almacén de información de Microsoft Exchange
  • Pilas MTA de Microsoft Exchange
  • Operador de sistema de Microsoft Exchange

Información acerca de la sustitución de la revisión

Esta revisión no reemplaza una revisión lanzada anteriormente.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
EMSABP32.dll6.5.7652.15173,56822-Feb-200702: 55x 86

Más información

Para obtener más información sobre el catálogo global de aplicación MAPI volver a conectar lógica, visite el siguiente sitio Web de Microsoft:
http://blogs.msdn.com/jasonjoh/archive/2004/12/21/329175.aspx

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Propiedades

Id. de artículo: 929439 - Última revisión: jueves, 25 de octubre de 2007 - Versión: 4.4
La información de este artículo se refiere a:
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
Palabras clave: 
kbmt kbautohotfix kbexchdev kbqfe kbexpertiseinter kbhotfixserver KB929439 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
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