Un programma di MAPI non pu˛ ottenere un server di riferimento quando viene arrestato il server di catalogo globale a cui punta il programma MAPI

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Sintomi

Non Ŕ un programma di MAPI potrebbe ottenere un server di riferimento quando viene arrestato il server di catalogo globale a cui punta il programma MAPI. In questo caso, tutti i indirizzo Rubrica ricerca chiamate, apportate dal programma MAPI esito negativo. Inoltre, viene restituito il codice di errore MAPI_E_NETWORK_ERROR, in Ŕ necessario riavviare il programma MAPI.

Questo problema si verifica se le seguenti condizioni sono vere:
  • Il programma MAPI viene eseguito come servizio su un server che Ŕ installati componenti di Exchange 2003 Service Pack 1 (SP1).
  • Il programma MAPI utilizza il provider della Rubrica di indirizzo MAPI che Ŕ incluso in Exchange 2003.
  • Riconnettere il catalogo globale logica viene distribuito, impostando il flag PR_PROFILE_ABP_ALLOW_RECONNECT nel profilo di MAPI programma.

Cause

Durante l'arresto di un server di catalogo globale, quando il server di Exchange 2003 tenta di individuare un nuovo server di catalogo globale, il servizio Centro distribuzione chiavi (KDC) di Kerberos restituisce il codice di errore KDC_ERR_PRINCIPAL_UNKNOWN al server di Exchange 2003. Quindi, il server di Exchange 2003 passa un errore di credenziali non riuscita all'applicazione MAPI. Questo comportamento causa la connessione per interrompere l'utilizzo delle credenziali dei processi e per immettere uno stato di credenziali utente. Tuttavia, lo stato di credenziali utente avrÓ esito negativo quando il programma MAPI Ŕ in esecuzione come servizio. Questo errore si verifica perchÚ il programma MAPI non Ŕ richiesta di credenziali.

Risoluzione

importante Questa sezione, metodo o l'attivitÓ sono contenute procedure viene illustrato come modificare il Registro di sistema. Tuttavia, possono causare seri problemi se si modifica il Registro di sistema in modo errato. Pertanto, assicurarsi che questa procedura con attenzione. Per maggiore protezione, Ŕ eseguire il backup del Registro di sistema prima di modificarlo. ╚ quindi possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322756Come eseguire il backup e il ripristino del Registro di sistema in Windows


╚ necessario creare la voce del Registro di sistema EMSAB_UserAuth_Credentials sul server Exchange 2003 in cui Ŕ installato l'aggiornamento rapido per questo aggiornamento rapido per l'utilizzo. Con la voce del Registro di sistema di EMSAB_UserAuth_Credentials Ŕ impostata sul valore 1, Ŕ possibile che il provider MAPI non immetterÓ mai lo stato di credenziali utente. Quando il server di catalogo globale Ŕ ancora arresto, i client MAPI che dispongono di questa voce del Registro di sistema continueranno a ottenere il codice di errore MAPI_E_NETWORK_ERROR. Tuttavia, non appena terminata arrestare il server di catalogo globale e il server di Exchange 2003 Ŕ stabilita una connessione con un nuovo server di catalogo globale, il client MAPI ottenere il codice di errore MAPI_E_END_OF_SESSION previsto.

importante Quando questa chiave del Registro di sistema Ŕ impostata su un server di Exchange 2003 dell'aggiornamento rapido installato, Ŕ Impossibile immettere lo stato di credenziali utente dai client MAPI sono in esecuzione sul server. Questo aggiornamento rapido (hotfix) impedirÓ di client MAPI che richiedono l'interfaccia utente di connettersi oltre i limiti del dominio, in cui Ŕ previsto che gli utenti possono essere richiesto per le credenziali. Assicurarsi che non si imposta la voce del Registro di sistema sui server di Exchange 2003 quando l'interfaccia utente di richiesta di credenziali Ŕ desiderato dai client MAPI in esecuzione sul server. Questo aggiornamento rapido (hotfix) non altera il comportamento di Exchange 2003 come server di MAPI. Inoltre, non influenza i client Outlook o qualsiasi altri client MAPI che eseguono altri computer in cui la chiave di aggiornamento rapido (hotfix) e Registro di sistema non sono state applicate.

Per impostare il valore del Registro di sistema EMSAB_UserAuth_Credentials, attenersi alla seguente procedura:
  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. Individuare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Exchange Provider
  3. Scegliere Nuovo dal menu Modifica , quindi Valore DWORD .
  4. Nel riquadro dei dettagli digitare EMSAB_UserAuth_Credentials e quindi premere INVIO .
  5. Fare clic con il pulsante destro del mouse su EMSAB_UserAuth_Credentials e quindi fare clic su Modifica .
  6. Nella finestra di dialogo Modifica valore DWORD , fare clic su decimale nell'area base .
  7. Nella casella dati valore digitare 1 e quindi fare clic su OK .
  8. Uscire dall'editor del Registro di sistema.

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

A causa delle dipendenze fra i file, deve essere installato Exchange Server 2003 Service Pack 2 (SP2) sul server prima di applicare questo aggiornamento rapido (hotfix). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
836993Come ottenere il service pack pi¨ recenti per Exchange Server 2003

NecessitÓ di riavvio

Non Ŕ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).Tuttavia, quando si applica l'aggiornamento rapido vengono automaticamente riavviati i seguenti servizi:
  • Servizio Archivio informazioni di Microsoft Exchange
  • Stack MTA di Microsoft Exchange
  • Supervisore sistema di Microsoft Exchange

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello data e ora nel Pannello di controllo.
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Emsabp32.dll6.5.7652.15173,56822-Feb-200702: 55x 86

Informazioni

Per ulteriori informazioni di catalogo globale di applicazione MAPI riconnettersi logica, visitare il seguente sito Web Microsoft:
http://blogs.msdn.com/jasonjoh/archive/2004/12/21/329175.aspx

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

ProprietÓ

Identificativo articolo: 929439 - Ultima modifica: giovedý 25 ottobre 2007 - Revisione: 4.4
Le informazioni in questo articolo si applicano a:
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
Chiavi:á
kbmt kbautohotfix kbexchdev kbqfe kbexpertiseinter kbhotfixserver KB929439 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 929439
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