MAPI プログラム可能性があります、MAPI プログラムがポイントするグローバル カタログ サーバーがシャットダウンと、参照サーバーを取得できません。

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文書番号: 929439 - 対象製品
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現象

MAPI プログラムがポイントするグローバル カタログ サーバーがシャットダウンと、MAPI プログラム、参照サーバーを取得できません可能性があります。 この現象が発生した場合、すべてアドレス帳参照呼び出し、MAPI プログラムによって行われる失敗します。 さらに、MAPI プログラムが再起動されるまでは、MAPI_E_NETWORK_ERROR のエラー コードが返されます。

この問題は、次の条件に該当する場合に発生します:
  • MAPI プログラムが Microsoft Exchange 2003 Service Pack 1 (SP1) のコンポーネントをインストールするサーバーではサービスとして実行されます。
  • MAPI プログラムに含まれている Exchange 2003 MAPI アドレス帳プロバイダーを使用します。
  • グローバル カタログの再接続ロジックは、MAPI のプロファイルに、PR_PROFILE_ABP_ALLOW_RECONNECT フラグを設定して展開プログラム。

原因

グローバル カタログ サーバーのシャットダウン、中に、Exchange 2003 サーバーが、新しいグローバル カタログ サーバーを検索しよう、Kerberos キー配布センター (KDC) サービスの [Exchange 2003 サーバー エラー コード KDC_ERR_PRINCIPAL_UNKNOWN を返します。 Exchange 2003 サーバーは、MAPI プログラムを再度に、資格情報の障害が発生したエラーを渡します。 この動作により、接続プロセスの資格情報の使用を停止し、ユーザーの資格情報の状態を入力します。 ただし、ユーザーの資格情報の状態は、MAPI プログラムがサービスとして動作しているに失敗します。 このエラーが原因、MAPI プログラムできません資格情報の要求で発生します。

解決方法

重要です このセクション、メソッド、またはタスク、レジストリを変更する方法を説明する手順がされています。 ただし、深刻な問題のレジストリを誤って変更する場合が発生する可能性があります。 このため、これらの手順を慎重に実行することを確認します。 追加の保護、するため、レジストリのバックアップを変更する前に。 問題が発生した場合に、レジストリを復元できます。 バックアップおよびレジストリを復元する方法の詳細についてはをクリックして次資料「サポート技術情報」(Microsoft Knowledge Base) 資料を参照。
322756バックアップおよび Windows のレジストリを復元する方法


動作するこの修正プログラムの修正プログラムがインストールされている、Exchange 2003 サーバー上、EMSAB_UserAuth_Credentials レジストリ エントリを作成する必要があります。 値 1 に設定、EMSAB_UserAuth_Credentials レジストリ エントリに、MAPI プロバイダーは、ユーザーの資格情報の状態をしない入力されます。 グローバル カタログ サーバーがシャットダウンされても、ときにこのレジストリ エントリが MAPI クライアントは、MAPI_E_NETWORK_ERROR のエラー コードを取得するし続けます。 ただし、グローバル カタログ サーバーがシャットダウンを終了して、Exchange 2003 サーバーが新しいグローバル カタログ サーバーと接続を確立、すぐ、MAPI クライアントは、予想される MAPI_E_END_OF_SESSION のエラー コード取得します。

重要です 修正プログラムをインストールすると、Exchange 2003 サーバー上このレジストリ キーを設定すると、ユーザーの資格情報の状態が、サーバーで実行されている MAPI クライアントによって入力できません。 この修正プログラムはユーザー インターフェイスからドメインの境界を越えて接続場所が予想ユーザーできますの資格情報入力を求められることを必要とする MAPI クライアントできなくなります。 確認が、サーバーで実行されている MAPI クライアントによって必要な UI の資格情報の入力時に Exchange 2003 サーバー上のレジストリ エントリを設定しません。 この修正プログラムでも、MAPI サーバーとして Exchange 2003 の動作は変更されません。 また、影響しません Outlook クライアントまたは、その他の MAPI クライアントで、修正プログラムおよびレジストリ キーが適用されていない他のコンピューターで実行されています。

EMSAB_UserAuth_Credentials レジストリ値を設定、次の手順に従います。
  1. 開始 ] をクリックして 実行 ] をクリックして、 regedit と入力して [OK] をクリックします。
  2. 次のレジストリ サブキーを見つけます。
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Exchange Provider
  3. [ 編集 ] メニューの [ 新規作成 ] をポイントし、[ DWORD 値 ] をクリックします。
  4. 詳細ペインで、 EMSAB_UserAuth_Credentials を入力して、 入力してください を押します。
  5. EMSAB_UserAuth_Credentials ] を右クリックし、 変更 を実行します。
  6. [DWORD 値の編集 ] ダイアログ 10 進 ベース 領域にします。
  7. 値のデータ ] 1 と入力して [OK] をクリックします。
  8. レジストリ エディターを終了します。

修正プログラムについて

サポートされている修正プログラムが Microsoft から提供されています。 ただし、ことを目的としたこの修正プログラムものですこの資料に記載されている問題のみを修正します。 この修正プログラムのみシステムに適用この特定の問題が発生しています。 この修正プログラム テストを受ける可能性があります。 そのため場合この問題で深刻な影響を受けていないお勧めしますこの修正プログラムを含む、次回ソフトウェアの更新されるまで待つことです。

修正プログラムをダウンロードできる場合はこの資料の先頭に「修正プログラムのダウンロード」セクションです。 このセクションが表示されていない場合、は、マイクロソフト カスタマーサービス & サポート修正プログラムを入手するを問い合わせてください。

メモ 追加問題が発生する場合は、個別のサービス要求を作成した任意のトラブルシューティングが必要な場合。 通常のサポート料金が追加の質問およびこの特定の修正プログラムの対象とならない問題について適用されます。 一覧については、完了マイクロソフト カスタマーサービス & サポートの電話番号のまたは個別のサービス要求を作成する、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
メモ 「修正プログラムのダウンロード」フォームには、修正プログラムが利用する言語が表示されます。 お使いの言語が表示されない場合、修正プログラムがその言語に対応しないのでは。

前提条件

ファイル依存関係のための Microsoft Exchange Server 2003 Service Pack 2 (SP2) する必要がありますがサーバーにインストール、この修正プログラムを適用する前に。 関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください:
836993Exchange Server 2003 の最新の Service Pack の入手方法

再起動の要件

この修正プログラムの適用後、コンピュータを再起動する必要はありません。ただし、この修正プログラムを適用すると、次のサービスが自動的に再起動されます。
  • Microsoft Exchange インフォメーション ストア サービス
  • Microsoft Exchange MTA スタック
  • Microsoft Exchange システム アテンダント

修正プログラム置き換えに関する情報

修正プログラムをこの適用置き換えはられることに以前にリリースされた修正プログラムありません。

ファイル情報

英語版のこの修正プログラムにファイルの属性 (またはそれ以降のファイル属性) 次の表は、されている可能性もします。 日付およびこれらのファイルの時間で世界協定時刻 (UTC) と記載します。 各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。 UTC と現地時刻の差を検索するには、コントロール パネルの [日付と時刻 タイム ゾーン タブを使用します。
元に戻す全体を表示する
ファイル名ファイルのバージョンファイル サイズ日付時間プラットフォーム
Emsabp32.dll6.5.7652.15173,5682007 年 2 月 22 日02: 55x86

詳細

ロジックを再接続 MAPI アプリケーションのグローバル カタログの詳細については、"、次のマイクロソフト Web サイトを参照してください。
http://blogs.msdn.com/jasonjoh/archive/2004/12/21/329175.aspx

状況

マイクロソフトとして認識していますこの問題を記載されているいるマイクロソフト製品の問題。

プロパティ

文書番号: 929439 - 最終更新日: 2007年10月25日 - リビジョン: 4.4
この資料は以下の製品について記述したものです。
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
キーワード:?
kbqfe kbexchdev kbexpertiseinter kbhotfixserver kbautohotfix kbmt KB929439 KbMtja
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英語版 KB:929439
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