Windows XP から Windows Vista にアップグレードしたコンピュータでマルチ モニタが有効にならない

文書翻訳 文書翻訳
文書番号: 929456 - 対象製品
すべて展開する | すべて折りたたむ

現象

Windows XP ベースのコンピュータから Windows Vista にアップグレードすると、マルチ モニタが有効になりません。この問題は、複数のグラフィック アダプタがコンピュータに装着されている場合に発生する可能性があります。

原因

この問題は、Windows Vista のセットアップ プログラムでは、1 つのグラフィック アダプタしか検出および構成できないことが原因で発生します。装着されているすべてのグラフィック アダプタが、Windows Vista で構成される必要があります。

Windows Vista で複数のグラフィック アダプタをサポートするには、以下の条件を満たしている必要があります。
  • すべてのグラフィック アダプタで同じドライバ モデルを使用する必要があります。そのため、すべてのグラフィック アダプタで XDDM (Windows XP Display Driver Model) ドライバを使用するか、または、LDDM (Longhorn Display Driver Model) ドライバを使用する必要があります。
  • グラフィック アダプタで WDDM (Windows Vista Display Driver Model) ドライバを使用する場合は、すべてのグラフィック アダプタで同じドライバを使用する必要があります。たとえば、同じドライバを使用する 2 つのグラフィック アダプタを使用する方法や、Dualview のグラフィック アダプタを使用する方法があります。Dualview に関する詳細については、次のマイクロソフト Web サイトを参照してください。
    http://www.microsoft.com/windowsxp/evaluation/features/dualview.mspx

回避策

この問題を回避するには、WDDM ドライバをサポートする複数のグラフィック アダプタ構成を使用します。Windows Vista で、WDDM を使用して複数のグラフィック アダプタをサポートするには、以下のいずれかの構成を使用します。
  • Dualview グラフィック アダプタを使用する。
  • 2 つの同種のグラフィック アダプタを使用するデュアルレーンの PCI Express コンピュータ システムを使用する。
: 上記の構成の詳細については、「詳細」を参照してください。

詳細

以下に、Multimon (Multimonitor の短縮形) 機能について説明します。
  • デュアル表示

    デュアル表示とは、2 つのビデオ出力を持つ単一のグラフィック アダプタが装着されたコンピュータのことを指します。この種のアダプタは、デュアルヘッド グラフィック アダプタとも呼ばれます。多くのグラフィック アダプタは DVI 出力と VGA 出力を備えています。
  • 同種のマルチアダプタ

    同種のマルチアダプタとは、同じドライバを使用する 2 つのグラフィック アダプタが装着されたコンピュータのことを指します。たとえば、NVIDIA GeForce FX 5600 グラフィック アダプタと NVIDIA GeForce FX 5950 グラフィック アダプタが装着されたコンピュータなどが、これに該当します。
  • 異種のマルチアダプタ

    異種のマルチアダプタとは、異なるドライバを使用する 2 つのグラフィック アダプタが装着されたコンピュータのことを指します。たとえば、ATI Technologies Radeon 9800 シリーズのグラフィック アダプタと NVIDIA GeForce FX 5600 グラフィック アダプタが装着されたコンピュータなどが、これに該当します。
この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

プロパティ

文書番号: 929456 - 最終更新日: 2007年2月1日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Starter
キーワード:?
kbdisplay kbexpertisebeginner kbhardware kbtshoot kbprb KB929456
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com