Help and Support
 

powered byLive Search

Error code 0x80072F8F when you try to search for available updates on Windows Update and Microsoft Update sites

Article ID:929458
Last Review:August 25, 2008
Revision:2.0
On This Page

SYMPTOMS

When you search for available updates on the Windows Update Web site or on the Microsoft Update Web site, you may receive the following error code:
0x80072F8F

Back to the top

CAUSE

This issue may occur if the date and time on the computer varies too much from the valid date and time of the Secure Socket Layer (SSL) certificates that are used by the Windows Update Web site.

Back to the top

RESOLUTION

To resolve this issue, use the following methods in the order in which they are presented. If one method does not resolve this issue, go to the next method.

Back to the top

Method 1: Verify and adjust the date and time settings

To do this, follow these steps, as appropriate for the operating system that you are running.

Windows 2000, Windows XP, and Windows Server 2003

1.Click Start, and then click Run.
2.In the Open box, type Timedate.cpl, and then click OK.
3.On the Date and Time tab, make sure that the computer's date and time are correct. If the settings are incorrect, adjust them to the correct date and time.
4.Click OK to close the Date and Time Properties dialog box.
5.Try to install updates again.

Windows Vista and Windows Server 2008

1.Click the StartStart button, type timedate.cpl in the Start Search box, and then click Timedate.cpl on the programs list.
2.On the Date and Time tab, make sure that the computer's date and time are correct. If the settings are incorrect, click Change date and time.

User Account Control permission If you are prompted for an administrator password or confirmation, type the password, or provide confirmation.
3.In the Date and Time dialog box, use the following procedures:
To change the date

Under Date, click the left or right arrows to find the current month in the calendar, and then click the current date.
To change the time

Under Time, double-click the hour, minutes, or seconds that you want to change, and then click the arrows to increase or decrease the value.
4.When you finish changing the date and time settings, click OK.
5.Try to install updates again.

Back to the top

Method 2: Install the most current Microsoft root certificate update

Note Use this method if you are running Windows 2000, Windows XP, or Windows Server 2003.

To install the most current root certificate update, visit the following Microsoft Windows Update Web site:
http://update.microsoft.com/windowsupdate (http://update.microsoft.com/windowsupdate)
To find the root certificate update, use Windows Update to scan the computer, and then click Software, Optional. The root certificate update appears under the Optional Software Updates heading.

This item updates the list root certificates to the latest list that is accepted by Microsoft as part of the Microsoft Root Certificate Program. When you add more root certificates to the computer, you let a wider range of applications work seamlessly. These applications include applications that provide security-enhanced Web browsing, encrypted e-mail, and security-enhanced code delivery.

After you install this update, you may have to restart the computer. For more information about Microsoft Root Certificate Program members, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/ms995347.aspx (http://msdn2.microsoft.com/en-us/library/ms995347.aspx)
To install the latest Microsoft root certificate for Windows XP, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyId=F814EC0E-EE7E-435E-99F8-20B44D4531B0&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyId=F814EC0E-EE7E-435E-99F8-20B44D4531B0&displaylang=en)

Back to the top

Method 3: Click to clear the "Check for server certificate revocation" check box

Note Use this method if you are running Windows 2000, Windows XP, or Windows Server 2003.
1.Start Internet Explorer.
2. On the Tools menu, click Internet Options.

Note If you do not see the Internet Explorer menu bar, press the ALT key to display the menu.
3.Click the Advanced tab, and then locate the Security section.
4.Click to clear the Check for server certificate revocation check box, and then click OK.
5.Restart the computer.
6. Try to install updates again.

Back to the top

Method 4: Register the Softpub.dll, Wintrust.dll, Initpki.dll, and Mssip32.dll files

To do this, follow these steps, as appropriate for the operating system that you are running.

Windows 2000, Windows XP, and Windows Server 2003

1.Click Start, and then click Run.
2.In the Open box, type the following file names. Click OK after each file name:
regsvr32 Softpub.dll /s
regsvr32 Wintrust.dll /s
regsvr32 Initpki.dll /s
regsvr32 Mssip32.dll /s

Windows Vista and Windows Server 2008

1.Click StartStart button, type regsvr32 Softpub.dll /s in the Start Search box, and then click OK.

User Account Control permission If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
2.Repeat step 1 for the following file names:
regsvr32 Wintrust.dll /s
regsvr32 Initpki.dll /s
regsvr32 Mssip32.dll /s

Back to the top

MORE INFORMATION

For more information about this issue in Windows Vista or in Windows Server 2008, visit the following Microsoft Web site:
http://windowshelp.microsoft.com/Windows/en-US/Help/bc1393cf-9f9c-79c7-0f91-9337c2c412341033.mspx (http://windowshelp.microsoft.com/Windows/en-US/Help/bc1393cf-9f9c-79c7-0f91-9337c2c412341033.mspx)

Back to the top


APPLIES TO
Windows Vista Business
Windows Vista Enterprise
Windows Vista Home Basic
Windows Vista Home Premium
Windows Vista Ultimate
Windows Vista Enterprise 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Starter
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Datacenter Server
Microsoft Windows 2000 Professional Edition
Microsoft Windows 2000 Server
Microsoft Windows Server 2003, Web Edition
Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional
Windows Server 2008 Datacenter
Windows Server 2008 Enterprise
Windows Server 2008 Standard
Windows Server 2008 Datacenter without Hyper-V
Windows Server 2008 Enterprise without Hyper-V
Windows Server 2008 for Itanium-Based Systems
Windows Server 2008 Standard without Hyper-V

Back to the top

Keywords: 
kberrmsg kbexpertisebeginner kbtshoot kbprb KB929458

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.