При поиске доступных обновлений на веб-сайтах Центра обновления Windows и Центра обновления Майкрософт появляется сообщение об ошибке с кодом 0x80072F8F

Переводы статьи Переводы статьи
Код статьи: 929458 - Vizualiza?i produsele pentru care se aplic? acest articol.

Поддержка Windows Vista без пакетов обновления прекратится 13 апреля 2010 г. Чтобы продолжить получать обновления для системы безопасности Windows, установите пакет обновления 2 (SP2) для Windows Vista. Дополнительные сведения см. на следующем веб-сайте корпорации Майкрософт: Заканчивается поддержка некоторых версий Windows

Развернуть все | Свернуть все

В этой статье

Проблема

При поиске доступных обновлений на веб-сайтах Центра обновления Windows и Центра обновления Майкрософт появляется сообщение об ошибке со следующим кодом:
0x80072F8F

Причина

Причина этой проблемы может заключаться в различиях между датой и временем компьютера и допустимыми датой и временем SSL- сертификатов, которые используются на веб-сайте Центра обновления Windows.

Решение

Чтобы решить эту проблему, воспользуйтесь приведенными ниже способами в указанном порядке. Если не удается устранить проблему с помощью одного способа, воспользуйтесь следующим.

Способ 1. Проверьте и установите параметры даты и времени

Следуйте инструкциям для используемой операционной системы.

Windows 2000, Windows XP и Windows Server 2003

  1. В меню Пуск выберите пункт Выполнить.
  2. В поле Открыть введите Timedate.cpl и нажмите кнопку ОК.
  3. На вкладке Дата и время проверьте, правильно ли установлены дата и время. Если нет, установите правильные дату и время.
  4. Чтобы закрыть диалоговое окно Свойства даты и времени, нажмите кнопку О?К.
  5. Попробуйте установить обновления еще раз.

Windows Vista и Windows Server 2008

  1. Нажмите кнопку Пуск
    Свернуть это изображениеРазвернуть это изображение
    кнопка "Пуск"
    , в поле Начать поиск введите timedate.cpl, затем выберите Timedate.cpl в списке "Программы".
  2. На вкладке Дата и время проверьте, правильно ли установлены дата и время. Если нет, нажмите кнопку Изменить дату и время.

    Свернуть это изображениеРазвернуть это изображение
    Разрешение контроля учетных записей
    При запросе пароля администратора или его подтверждения введите пароль или подтвердите его.
  3. В диалоговом окне Дата и время выполните указанные ниже действия.
    • Изменение даты

      В области Дата нажмите правую или левую стрелку для выбора в календаре текущего месяца, а затем выберите текущую дату.
    • Изменение времени

      В области Время дважды щелкните час, минуты или секунды, которые требуется изменить, а затем с помощью стрелок увеличьте или уменьшите значение.
  4. После установки параметров даты и времени нажмите кнопку ОК.
  5. Попробуйте установить обновления еще раз.

Способ 2. Установите последнее обновление корневых сертификатов Майкрософт

Примечание. Используйте этот способ в системе Windows 2000, Windows XP или Windows Server 2003.

Загрузить последнее обновление корневых сертификатов можно на следующем веб-сайте Центра обновления Майкрософт:
http://update.microsoft.com/windowsupdate
Чтобы найти обновления корневых сертификатов, проверьте компьютер с помощью Центра обновлений Windows, а затем щелкните ссылку Дополнительное программное обеспечение. Обновление корневых сертификатов отобразится под заголовком Дополнительные обновления программного обеспечения.

Этот элемент обновляет список корневых сертификатов на компьютере до версии, принятой корпорацией Майкрософт в рамках программы корневых сертификатов Майкрософт. Корневые сертификаты упрощают работу многих приложений. К ним относятся приложения, обеспечивающие безопасную работу в Интернете, шифрование сообщений электронной почты и безопасную доставку кода.

После установки этого обновления может потребоваться перезагрузка компьютера. Дополнительные сведения об участниках программы корневых сертификатов Майкрософт см. на следующем веб-сайте корпорации Майкрософт:
http://msdn.microsoft.com/ru-ru/library/ms995347.aspx
Загрузить последний корневой сертификат для Windows XP можно на следующем веб-сайте корпорации Майкрософт:
http://www.microsoft.com/downloads/details.aspx?FamilyId=F814EC0E-EE7E-435E-99F8-20B44D4531B0&displaylang=ru

Способ 3. Снимите флажок "Проверять, не отозван ли сертификат сервера"

Примечание. Используйте этот способ в системе Windows 2000, Windows XP или Windows Server 2003.
  1. Запустите браузер Internet Explorer.
  2. В меню Сервис выберите команду Свойства обозревателя.

    Примечание. Если строка меню не отображается, нажмите клавишу ALT.
  3. Откройте вкладку Дополнительно и найдите раздел Безопасность.
  4. Снимите флажок Проверять, не отозван ли сертификат сервера и нажмите кнопку ОК.
  5. Перезагрузите компьютер.
  6. Попробуйте установить обновления еще раз.

Способ 4. Внесите в реестр DLL-файлы, которые могут вызывать проблему

Следуйте инструкциям для используемой операционной системы.

Windows 2000, Windows XP и Windows Server 2003

  1. В меню Пуск выберите пункт Выполнить.
  2. В поле Открыть введите указанные ниже имена файлов. Нажимайте кнопку ОК после каждого имени файла.
    • regsvr32 Softpub.dll /s
    • regsvr32 Wintrust.dll /s
    • regsvr32 Initpki.dll /s
    • regsvr32 Mssip32.dll /s

Windows Vista и Windows Server 2008

  1. Нажмите кнопку Пуск
    Свернуть это изображениеРазвернуть это изображение
    кнопка "Пуск"
    , в поле Начать поиск введите regsvr32 Softpub.dll /s и нажмите кнопку ОК.

    Свернуть это изображениеРазвернуть это изображение
    Разрешение контроля учетных записей
    При запросе пароля администратора или его подтверждения введите пароль или нажмите кнопку Продолжить.
  2. Повторите действие 1 для следующих файлов:
    • regsvr32 Wintrust.dll /s
    • regsvr32 Mssip32.dll /s

Дополнительная информация

Дополнительные сведения об этой проблеме в Windows Vista и Windows Server 2008 см. на следующем веб-сайте корпорации Майкрософт:
http://windows.microsoft.com/ru-ru/windows-vista/Windows-Update-error-80072f8f

Ссылки

Помощь в решении стандартных задач по обслуживанию системы в Windows Vista можно получить на следующем веб-сайте корпорации Майкрософт:

Свойства

Код статьи: 929458 - Последний отзыв: 25 марта 2010 г. - Revision: 3.1
Информация в данной статье относится к следующим продуктам.
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Starter
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • операционная система Microsoft Windows 2000 Server
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
Ключевые слова: 
kberrmsg kbexpertisebeginner kbtshoot kbprb KB929458

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com