Felkod 0x80072F8F visas när du försöker söka efter uppdateringar på webbplatserna Windows Update och Microsoft Update

Artikelöversättning Artikelöversättning
Artikel-id: 929458 - Visa produkter som artikeln gäller.

Support för Windows Vista utan installerade Service Pack-versioner upphör 13 april 2010. Om du vill fortsätta att få säkerhetsuppdateringar för Windows måste du se till att köra Windows Vista med Service Pack 2 (SP2). Mer information hittar du på den här Microsoft-webbsidan: Support upphör för vissa Windows-versioner

Visa alla | Dölj alla

På den här sidan

Symptom

När du söker efter uppdateringar på webbplatserna Windows Update och Microsoft Update visas följande felkod:
0x80072F8F

Orsak

Det här problemet uppstår om datorns datum och tid skiljer sig alltför mycket från datum och tid på SSL-certifikatet (Secure Sockets Layer) som används av webbplatsen Windows Update.

Lösning

Lös problemet genom att använda följande metoder i angiven ordning. Om problemet inte kan lösas med en metod går du vidare till nästa.

Metod 1: Kontrollera och justera datum och tid

Följ anvisningarna nedan som gäller ditt operativsystem.

Windows 2000, Windows XP och Windows Server 2003

  1. Klicka på Start och sedan på Kör.
  2. Skriv Timedate.cpl i rutan Öppna och klicka sedan på OK.
  3. På fliken Datum och tid kontrollerar du att datorns datum och tid är rätt angivna. Om inställningarna är fel justerar du dem.
  4. Stäng dialogrutan Egenskaper för datum och tid genom att klicka på OK.
  5. Försök att installera uppdateringarna igen.

Windows Vista och Windows Server 2008

  1. Klicka på Start
    Dölj bildenVisa bilden
    Start-knappen
    , skriv timedate.cpl i rutan Påbörja sökning och klicka sedan på Timedate.cpl i programlistan.
  2. På fliken Datum och tid kontrollerar du att datorns datum och tid är rätt angivna. Om inställningarna är fel klickar du på Ändra datum och tid.

    Dölj bildenVisa bilden
    Tillåtelse till kontroll av användarkonto
    Om du ombeds att ange ett administratörslösenord eller en bekräftelse skriver du lösenordet eller ger bekräftelsen.
  3. I dialogrutan Datum och tid använder du följande procedurer:
    • Ändra datum

      Under Datum klickar du på vänster eller höger pil tills du kommer till aktuell månad i kalendern. Klicka sedan på dagens datum.
    • Ändra tid

      Under Tid dubbelklickar du efter behov på timme, minuter eller sekunder, och klickar sedan på pilarna för att öka eller minska värdet.
  4. När du är klar med datum- och tidsinställningarna klickar du på OK.
  5. Försök att installera uppdateringarna igen.

Metod 2: Installera den senaste uppdateringen av Microsofts rotcertifikat

Obs! Använd den här metoden om du kör Windows 2000, Windows XP eller Windows Server 2003.

Om du vill installera den senaste rotcertifikatuppdateringen går du till följande Microsoft Windows Update-webbplats:
http://update.microsoft.com/windowsupdate
Du hittar uppdateringen av rotcertifikatet genom att genomsöka datorn med Windows Update. Klicka sedan på Programvara, tillvalsuppdatering. Rotcertifikatuppdateringen visas under rubriken Tillvalsuppdateringar för programvara.

Genom den här uppdateringen uppdateras listrotcertifikaten till den senaste listan som har godkänts av Microsoft inom ramen för Microsofts rotcertifikatprogram. När du lägger till flera rotcertifikat på en dator låter du en rad olika program fungera tillsammans utan problem. Programmen kan exempelvis vara program för webbläsning med utökad säkerhet, krypterad e-post och kodleverans med utökad säkerhet.

När du har installerat uppdateringen måste du kanske starta om datorn. Mer information om medlemmar av Microsofts rotcertifikatprogram hittar du på följande Microsoft-webbplats:
http://msdn.microsoft.com/sv-se/library/ms995347.aspx
Om du vill installera det senaste Microsoft-rotcertifikatet för Windows XP går du till följande Microsoft-webbplats:
http://www.microsoft.com/downloads/details.aspx?displaylang=sv&FamilyID=f814ec0e-ee7e-435e-99f8-20b44d4531b0

Metod 3: Avmarkera kryssrutan "Kontrollera om servercertifikat har återkallats"

Obs! Använd den här metoden om du kör Windows 2000, Windows XP eller Windows Server 2003.
  1. Starta Internet Explorer.
  2. Klicka på InternetalternativVerktyg-menyn.

    Obs! Om Internet Explorer-menyfältet inte visas trycker du på ALT-tangenten för att visa menyn.
  3. Klicka på fliken Avancerat och gå till avsnittet Säkerhet.
  4. Avmarkera kryssrutan Kontrollera om servercertifikat har återkallats och klicka sedan på OK.
  5. Starta om datorn.
  6. Försök att installera uppdateringarna igen.

Metod 4: Registrera Windows-.dll-filer som kan vara orsaken till problemet.

Följ anvisningarna som gäller ditt operativsystem.

Windows 2000, Windows XP och Windows Server 2003

  1. Klicka på Start och sedan på Kör.
  2. Skriv följande filnamn i rutan Öppna. Klicka på OK efter varje filnamn:
    • regsvr32 Softpub.dll /s
    • regsvr32 Wintrust.dll /s
    • regsvr32 Initpki.dll /s
    • regsvr32 Mssip32.dll /s

Windows Vista och Windows Server 2008

  1. Klicka på Start
    Dölj bildenVisa bilden
    Start-knappen
    , skriv regsvr32 Softpub.dll /s i rutan Påbörja sökning och klicka på OK.

    Dölj bildenVisa bilden
    Tillåtelse till kontroll av användarkonto
    Om du ombeds att ange ett administratörslösenord eller en bekräftelse skriver du lösenordet eller klickar på Fortsätt.
  2. Upprepa steg 1 för följande filnamn:
    • regsvr32 Wintrust.dll /s
    • regsvr32 Mssip32.dll /s

Mer Information

Mer information om det här problemet i Windows Vista eller Windows Server 2008 hittar du på följande Microsoft-webbplats:
http://windows.microsoft.com/sv-se/windows-vista/Windows-Update-error-80072f8f

Referenser

Om du vill ha hjälp med systemunderhållsåtgärder i Windows Vista går du till följande Microsoft-webbsida:
Vanliga systemunderhållsåtgärder

Egenskaper

Artikel-id: 929458 - Senaste granskning: den 25 mars 2010 - Revision: 3.1
Informationen i denna artikel gäller:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Starter
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
Nyckelord: 
kberrmsg kbexpertisebeginner kbtshoot kbprb KB929458

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com