Article ID: 929488 - Last Review: October 26, 2007 - Revision: 4.2

Error message when you attach a .docx file to a record in Microsoft Dynamics CRM 3.0: "File Upload Failure"

Expand all | Collapse all

SYMPTOMS

When you attach a .docx file to a record in Microsoft Dynamics CRM 3.0, you receive the following error message:
File Upload Failure.
There was a problem while attempting to upload the requested file. Check the file path and try again. There was a problem communicating with the Microsoft CRM server. The server might be unavailable. Try again later. If the problem persists, contact your system administrator.

CAUSE

This problem occurs because the number of characters cannot exceed 50 in the MIME-type field of the AnnotationBase table. However, the extensions of some 2007 Microsoft Office files contain more than 50 characters.

Note The Microsoft Dynamics CRM 3.0 database contains the AnnotationBase table.

RESOLUTION

This problem is fixed in Microsoft Dynamics CRM 3.0 Update Rollup 2. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
927751  (http://support.microsoft.com/kb/927751/ ) Update Rollup 2 is available for Microsoft Dynamics CRM 3.0
This problem is fixed in Update Rollup 1 for the Chinese Simplified version of Microsoft Dynamics 3.0 and for the Japanese version of Microsoft Dynamics CRM 3.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935730  (http://support.microsoft.com/kb/935730/ ) Update Rollup 1 for the Chinese Simplified version of Microsoft Dynamics CRM 3.0 and for the Japanese version of Microsoft Dynamics CRM 3.0 is available
This problem is fixed in Update Rollup 1 for Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935731  (http://support.microsoft.com/kb/935731/ ) Update Rollup 1 for Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers is available

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
887283  (http://support.microsoft.com/kb/887283/ ) Microsoft Business Solutions CRM software hotfix and update package naming standards

APPLIES TO
  • Microsoft CRM 3.0
  • Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers
Keywords: 
kberrmsg kbhotfixserver kbqfe kbmbsmigrate KB929488
 

Article Translations

 

Related Support Centers