Mensaje de error al solicitar un certificado desde un equipo que ejecuta Windows Server 2003 con Service Pack 1: "la solicitud de certificado error debido a una de la siguiente conditions?"

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Id. de artículo: 929494 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que copia el registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
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Síntomas

Cuando se utiliza el complemento certificados para solicitar un certificado de equipo o un certificado de usuario, puede recibir uno de los mensajes de error siguientes:

Mensaje 1

Hubo la solicitud de certificado error debido a una de las condiciones siguientes:
-La solicitud de certificado se envió a un comentario vea que no se inicia.
-No tiene los permisos para solicitar certificados de las entidades emisoras disponibles.

Mensaje 2

Hubo la solicitud de certificado error debido a una de las condiciones siguientes:
-La solicitud requería un certificado de intercambio de una entidad emisora de certificados (CA) que no se inicia.
-No tiene los permisos para solicitar certificados de las entidades emisoras disponibles.
Este problema puede producirse cuando Servicios de Certificate Server está habilitado en un equipo host que ejecuta Microsoft Windows Server 2003 con Service Pack 1 (SP1).

Causa

Este problema puede producirse si el equipo cliente falta la entrada de registro de EnableDCOM.

La entrada de registro de EnableDCOM se encuentra en la siguiente subclave del registro:
HKEY_LOCAL_MACHINE\Software\Microsoft\Ole

Solución

Para resolver este problema, confirme que el problema no está relacionado con la entidad emisora de certificados (CA). A continuación, agregue la entrada del registro que faltan.

Siga estos pasos para asegurarse de que el problema no está relacionado con la entidad emisora.

Nota Este procedimiento requiere que se utilice la utilidad Cominfo.exe. Para obtener la utilidad Cominfo.exe, póngase en contacto con servicios de soporte técnico de Microsoft. Para obtener una lista completa de los números de teléfono de los servicios de soporte técnico de Microsoft e información acerca de los costos de soporte, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
  1. Compruebe que la entidad emisora y todos sus certificados de entidad emisora primaria válido y de confianza.
  2. Asegúrese de que lista de control de acceso discrecional de plantilla de certificado (DACL) en la entidad emisora de CERTIFICADOS incluye el grupo Usuarios autenticados. Si el grupo Usuarios autenticados se quita de la DACL, la entidad emisora ya no puede leer la plantilla en Active Directory. Por lo tanto, la entidad emisora no puede emitir certificados.
  3. En el equipo cliente, escriba los comandos siguientes en el símbolo del sistema. Presione ENTRAR después de cada comando.
    certutil ?template
    certutil ?dump
    Nota El comando primero muestra permisos del usuario en las plantillas disponibles. Aparece cada plantilla de certificado que no puede ser utilizado por el usuario conectado actualmente un estado de "Acceso denegado". El segundo comando muestra una lista de entidades emisoras de certificados de empresa.
  4. Escriba el siguiente comando para buscar el nombre común (CN) de la entidad emisora y, a continuación, presione ENTRAR:
    certutil ?dump | findstr config
  5. Escriba el comando siguiente y, a continuación, presione ENTRAR:
    set config = CAMachineDNSName \ CACommonName
  6. Escriba el comando siguiente y, a continuación, presione ENTRAR:
    certutil ?config "% config %" ?ping
    Puede recibir un mensaje de "Acceso denegado".
  7. Escriba el comando siguiente para exportar un certificado de intercambio de CA y, a continuación, presione ENTRAR:
    certutil ?config "% config %" ?cainfo xchg
    Recibirá un mensaje similar al siguiente:
    Exportado certificado de Exchange a xchg.cer
  8. Escriba el comando siguiente y, a continuación, presione ENTRAR:
    certutil ?config "% config %" ?verify ?urlfetch xchg.cer
    Recibirá un mensaje similar al siguiente:
    CertUtil - Compruebe el error de comando: 0x8009310b (ASN: 267)
  9. Ejecute la utilidad Cominfo.exe para recopilar información de DCOM.

    La utilidad Cominfo.exe puede generar resultados similar al siguiente:
    DCOM instalado
    El valor de EnableDCOM no está presente en HKEY_LOCAL_MACHINE\Software\Microsoft\Ole. [Advertencia: es probable que obtiene error RPC_E_REMOTE_DISABLED si ejecuta aplicaciones DCOM en este equipo.]
    Este mensaje confirma que el problema está relacionado con la entrada del registro que faltan.
Para agregar la entrada de registro de EnableDCOM, siga estos pasos.

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Ole
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor alfanumérico .
  4. Escriba EnableDCOM y, a continuación, presione ENTRAR.
  5. Haga clic con el botón secundario del mouse en EnableDCOM y, a continuación, haga clic en Modificar .
  6. Escriba Y en el cuadro de datos de valor y, a continuación, haga clic en Aceptar .
  7. Editor de registro de salida.

Más información

Para obtener más información acerca de un problema similar, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
927066Mensaje de error cuando un equipo cliente solicita un certificado desde un equipo que ejecuta Windows Server 2003 con Service Pack 1: "el asistente no se puede iniciar debido de uno o más de las condiciones siguientes"
Para obtener más información acerca de los cambios en configuración de seguridad después de instale Windows Server 2003 Service Pack 1, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
903220Descripción de los cambios introducidos en configuración de seguridad después de instalar Windows Server 2003 Service Pack 1

Propiedades

Id. de artículo: 929494 - Última revisión: jueves, 11 de octubre de 2007 - Versión: 1.2
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palabras clave: 
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Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 929494

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