Messaggio di errore quando si richiede un certificato da un computer che esegue Windows Server 2003 con Service Pack 1: "ha avuto esito la richiesta di certificato negativo a causa di una delle conditions? seguente"

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importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
256986Descrizione del Registro di sistema di Microsoft Windows
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Sintomi

Quando si utilizza lo snap-in certificati per richiedere un certificato di computer o un certificato utente, si potrebbe essere visualizzato uno dei seguenti messaggi di errore:

Messaggio 1

Richiesta certificato non riuscita a causa di una delle seguenti condizioni:
-La richiesta di certificato Ŕ stata inoltrata a un commento di vedere non Ŕ stato avviato.
Non - si dispone di autorizzazioni per richiedere certificati dalle CA disponibili.

Messaggio 2

Richiesta certificato non riuscita a causa di una delle seguenti condizioni:
-La richiesta Ŕ necessario un certificato di exchange da un'autoritÓ di certificazione (CA) non Ŕ stato avviato.
Non - si dispone di autorizzazioni per richiedere certificati dalle CA disponibili.
Questo problema pu˛ verificarsi quando Servizi certificati Ŕ abilitato su un computer di host che esegue Microsoft Windows Server 2003 con Service Pack 1 (SP1).

Cause

Questo problema pu˛ verificarsi se il computer client manca la voce del Registro di sistema EnableDCOM.

La voce di registro di sistema di EnableDCOM si trova nella seguente sottochiave del Registro di sistema:
HKEY_LOCAL_MACHINE\Software\Microsoft\Ole

Risoluzione

Per risolvere il problema, verificare che il problema non Ŕ correlato all'autoritÓ di certificazione (CA). Quindi, aggiungere la voce del Registro di sistema mancante.

Attenersi alla seguente procedura per assicurarsi che il problema non Ŕ correlato all'autoritÓ di certificazione.

Nota Questa procedura richiede l'utilizzo dell'utilitÓ Cominfo.exe. Per ottenere l'utilitÓ Cominfo.exe, contattare il servizio di supporto clienti Microsoft. Per un elenco completo di numeri di telefono del supporto tecnico clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
  1. Verificare che la CA e tutti i relativi certificati CA padre siano attendibili e validi.
  2. Verificare che elenco di controllo di accesso discrezionale (DACL) del modello di certificato (DACL) sulla CA include il gruppo Authenticated Users. Se il gruppo Authenticated Users viene rimosso dall'elenco DACL, nella CA non Ŕ pi¨ possibile leggere il modello in Active Directory. Di conseguenza, la CA non pu˛ emettere certificati.
  3. Sul computer client, digitare i comandi seguenti al prompt dei comandi dei comandi. Premere INVIO dopo ciascun comando.
    certutil ?template
    certutil ?dump
    Nota Il comando primo Visualizza autorizzazioni dell'utente sui modelli disponibili. Uno stato di "Accesso negato" viene visualizzato per ogni modello di certificato non pu˛ essere utilizzato dall'utente attualmente connesso. Il secondo comando Visualizza un elenco di CA dell'organizzazione.
  4. Digitare il comando seguente per trovare il nome comune (CN) dell'autoritÓ di certificazione e quindi premere INVIO:
    certutil ?dump | findstr configurazione
  5. Digitare il comando seguente e premere INVIO:
    set config = CAMachineDNSName \ CACommonName
  6. Digitare il comando seguente e premere INVIO:
    certutil ?config "% config %" ?ping
    Puoi ricevere un messaggio di "Accesso negato".
  7. Digitare il seguente comando per esportare un certificato di exchange CA e quindi premere INVIO:
    certutil ?config "% config %" ?cainfo xchg
    ╚ possibile che venga visualizzato un messaggio analogo al seguente:
    Certificato di Exchange CA esportato per xchg.cer
  8. Digitare il comando seguente e premere INVIO:
    certutil ?config "% config %" ?verify ?urlfetch xchg.cer
    ╚ possibile che venga visualizzato un messaggio analogo al seguente:
    CertUtil - verifica il comando non riuscita: 0x8009310b (ASN: 267)
  9. Eseguire l'utilitÓ Cominfo.exe per raccogliere informazioni di DCOM.

    L'utilitÓ Cominfo.exe pu˛ produrre un output analogo al seguente:
    Installata di DCOM
    Il valore EnableDCOM non Ŕ presente in HKEY_LOCAL_MACHINE\Software\Microsoft\Ole. [Avviso: ╚ probabile ottenere l'errore RPC_E_REMOTE_DISABLED se si eseguono un'applicazione DCOM in questo computer.]
    Questo messaggio di conferma che il problema riguarda la voce del Registro di sistema mancante.
Per aggiungere la voce del Registro di sistema di EnableDCOM, attenersi alla seguente procedura.

avviso Pu˛ causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema Ŕ a rischio e pericolo dell'utente.
  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. Individuare e selezionare la seguente sottochiave:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Ole
  3. Scegliere Nuovo dal menu Modifica , quindi Valore stringa .
  4. Digitare EnableDCOM e quindi premere INVIO.
  5. Fare clic con il pulsante destro del mouse su EnableDCOM e quindi fare clic su Modifica .
  6. Digitare Y nella casella dati valore e quindi fare clic su OK .
  7. Uscire dall'editor del Registro di sistema.

Informazioni

Per ulteriori informazioni su un problema simile, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
927066Messaggio di errore quando un computer client richiede un certificato da un computer che esegue Windows Server 2003 con Service Pack 1: "Impossibile avviare la procedura guidata a causa di uno o pi¨ delle seguenti condizioni"
Per ulteriori informazioni sulle modifiche alle impostazioni di protezione DCOM dopo installare Windows Server 2003 Service Pack 1, fare clic il numero di articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
903220Descrizione delle modifiche alle impostazioni di protezione DCOM dopo aver installato Windows Server 2003 Service Pack 1

ProprietÓ

Identificativo articolo: 929494 - Ultima modifica: giovedý 11 ottobre 2007 - Revisione: 1.2
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
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Clicca qui per visualizzare la versione originale in inglese dell?articolo: 929494
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