เกิดข้อผิดพลาดเมื่อคุณร้องขอใบรับรองจากคอมพิวเตอร์ที่ใช้ Windows Server 2003 Service Pack 1: "การร้องขอใบรับรองที่ล้มเหลวเนื่องจากหนึ่ง conditions… ที่ต่อไปนี้"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 929494 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
สิ่งสำคัญบทความนี้ประกอบด้วยข้อมูลเกี่ยวกับวิธีการแก้ไขรีจิสทรี ควรตรวจสอบว่าได้สำรองรีจิสทรีก่อนที่จะปรับเปลี่ยน โปรดทำความเข้าใจกับวิธีการคืนค่ารีจิสทรีในกรณีที่เกิดปัญหา สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีสำรองข้อมูล คืนค่า และปรับเปลี่ยนรีจิสทรี โปรดคลิกที่หมายเลขบทความต่อไปนี้ เพื่อดูบทความใน Microsoft Knowledge Base::
256986คำอธิบายสำหรับ Microsoft Windows Registry
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

เมื่อคุณใช้ Certificates snap-in เพื่อร้องขอใบรับรองของคอมพิวเตอร์หรือใบรับรองของผู้ใช้ คุณอาจได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้อย่างใดอย่างหนึ่ง:

ข้อความที่ 1

การร้องขอใบรับรองล้มเหลวเนื่องจากหนึ่งมีเงื่อนไขใด ๆ ต่อไปนี้:
-การร้องขอใบรับรองถูกส่งไปยังข้อคิดเห็นดูเกี่ยวกับที่ไม่เริ่มทำงาน
-คุณไม่ต้องการอนุญาตใบรับรองที่ร้องขอจาก CAs ที่พร้อมใช้งาน

ข้อความ 2

การร้องขอใบรับรองล้มเหลวเนื่องจากหนึ่งมีเงื่อนไขใด ๆ ต่อไปนี้:
-การร้องขอต้องการแลกเปลี่ยนใบรับรองจากใบรับรองรับรอง (CA) ที่ไม่เริ่มทำงาน
-คุณไม่ต้องการอนุญาตใบรับรองที่ร้องขอจาก CAs ที่พร้อมใช้งาน
ปัญหานี้อาจเกิดขึ้นเมื่อมีการใช้งานบริการ Certificate ในโฮสต์คอมพิวเตอร์ที่ใช้ Microsoft Windows Server 2003 Service Pack 1 (SP1)

สาเหตุ

ปัญหานี้อาจเกิดขึ้นหากคอมพิวเตอร์ไคลเอนต์ไม่มีรายการรีจิสทรี EnableDCOM

รายการรีจิสทรี EnableDCOM จะอยู่ในคีย์ย่อยของรีจิสทรีต่อไปนี้:
HKEY_LOCAL_MACHINE\Software\Microsoft\Ole

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ ยืนยันว่า ปัญหาที่ไม่เกี่ยวข้องกับใบรับรอง (CA) จากนั้น เพิ่มรายการรีจิสทรีหายไป

ทำตามขั้นตอนเหล่านี้เพื่อให้แน่ใจว่า ปัญหาที่ไม่เกี่ยวข้องกับ CA

หมายเหตุ:กระบวนการนี้ต้องการให้คุณใช้โปรแกรมอรรถประโยชน์ Cominfo.exe เมื่อต้องการขอรับโปรแกรมอรรถประโยชน์ Cominfo.exe ติดต่อฝ่ายบริการสนับสนุนลูกค้าของ Microsoft สำหรับรายการทั้งหมดของหมายเลขโทรศัพท์ของบริการการสนับสนุนลูกค้าของ Microsoft และข้อมูลเกี่ยวกับการจ่ายสนับสนุน แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus/?ws=support
  1. ตรวจสอบว่า CA และเป็นหลัก CA รับรองจะเชื่อถือได้ และถูกต้อง
  2. ตรวจสอบให้แน่ใจว่า ของแม่แบบใบรับรองการเข้าถึง discretionary รายการการควบคุม (DACL) ใน CA ประกอบด้วยกลุ่มผู้ใช้ที่มีการรับรองความถูกต้อง ถ้ากลุ่มผู้ใช้ที่มีการรับรองความถูกต้องถูกเอาออกจากการ DACL, CA สามารถอ่านแม่แบบใน Active Directory มีอีกต่อไป ดังนั้น CA นั้นไม่สามารถออกใบรับรอง
  3. บนคอมพิวเตอร์ไคลเอนต์ พิมพ์คำสั่งต่อไปนี้ที่พร้อมท์รับคำสั่ง กด ENTER หลังจากแต่ละคำสั่ง
    certutil –template
    certutil –dump
    หมายเหตุ:คำสั่งแรกแสดงสิทธิ์ของผู้ใช้ในแม่แบบที่พร้อมใช้งาน สถานะที่ "การเข้าถึงถูกปฏิเสธ" ปรากฏขึ้นแต่ละแม่แบบใบรับรองที่ไม่ถูกใช้ โดยผู้ใช้ที่จะเข้าสู่ระบบในขณะนี้ คำสั่งที่สองแสดงรายการขององค์กร CAs
  4. พิมพ์คำสั่งต่อไปนี้เพื่อค้นหาชื่อทั่วไป (CN) ของ CA และกด enter:
    certutil –dump | การกำหนดค่า findstr
  5. พิมพ์คำสั่งต่อไปนี้ แล้วกด ENTER::
    การตั้งค่าการกำหนดค่า =CAMachineDNSName\CACommonName
  6. พิมพ์คำสั่งต่อไปนี้ แล้วกด ENTER::
    –ping "%การกำหนดค่า%" –config certutil
    คุณอาจได้รับข้อความแสดงข้อความ "การเข้าถึงถูกปฏิเสธ"
  7. พิมพ์คำสั่งต่อไปนี้เพื่อส่งออกใบรับรองการแลกเปลี่ยน CA และกด enter:
    certutil –config "%การกำหนดค่า%" –cainfo xchg
    คุณอาจจะได้รับข้อความที่มีลักษณะดังต่อไปนี้::
    ใบรับรอง Exchange CA ส่งออกไป xchg.cer
  8. พิมพ์คำสั่งต่อไปนี้ แล้วกด ENTER::
    certutil –config "%การกำหนดค่า%" –verify –urlfetch xchg.cer
    คุณอาจจะได้รับข้อความที่มีลักษณะดังต่อไปนี้::
    CertUtil - ตรวจสอบคำสั่ง FAILED: 0x8009310b (ASN: 267)
  9. เรียกใช้โปรแกรมอรรถประโยชน์ Cominfo.exe การรวบรวมข้อมูล DCOM

    โปรแกรมอรรถประโยชน์ Cominfo.exe อาจทำให้ผลลัพธ์ที่มีลักษณะดังต่อไปนี้:
    dcom ที่ติดตั้งไว้
    ค่า EnableDCOM ไม่อยู่ภายใต้ HKEY_LOCAL_MACHINE\Software\Microsoft\Ole [คำเตือน: คุณมีแนวโน้มที่จะได้รับข้อผิดพลาด RPC_E_REMOTE_DISABLED หากคุณเรียกใช้โปรแกรมประยุกต์ DCOM ในเครื่องนี้]
    ข้อความนี้ยืนยันว่า ปัญหาที่เกี่ยวข้องกับรายการรีจิสทรีหายไป
เมื่อต้องการเพิ่มรายการรีจิสทรี EnableDCOM ทำตามขั้นตอนเหล่านี้

คำเตือนปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้อง โดยใช้ตัวแก้ไขรีจิสทรี หรือ โดยใช้วิธีอื่น คุณอาจต้องติดตั้งระบบปฏิบัติการใหม่เพื่อแก้ไขปัญหาเหล่านี้ Microsoft ไม่รับประกันว่าจะสามารถแก้ไขปัญหาได้ คุณต้องยอมรับความเสี่ยงด้วยตนเองในการปรับเปลี่ยนรีจิสทรี
  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:regeditแล้ว คลิกตกลง.
  2. ค้นหาและคลิกที่คีย์ย่อยของรีจิสทรีต่อไปนี้::
    HKEY_LOCAL_MACHINE\Software\Microsoft\Ole
  3. ในการแก้ไขเมนู ให้ชี้ไปที่ใหม่แล้ว คลิกค่าสายอักขระ.
  4. ประเภท:EnableDCOMแล้ว กด ENTER
  5. คลิกขวาEnableDCOMแล้ว คลิกปรับเปลี่ยน.
  6. ประเภท:yในการข้อมูลค่า:กล่อง แล้วคลิกตกลง.
  7. ออกจาก "ตัวแก้ไขรีจิสทรี"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับปัญหาที่คล้ายกัน คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
927066เกิดข้อผิดพลาดเมื่อคอมพิวเตอร์แบบไคลเอ็นต์ร้องขอใบรับรองจากคอมพิวเตอร์ที่ใช้ Windows Server 2003 Service Pack 1: "ตัวช่วยสร้างไม่สามารถเริ่มต้นเนื่องจากความอย่างน้อยหนึ่งอย่างมีเงื่อนไขใด ๆ ต่อไปนี้"
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการเปลี่ยนแปลงการตั้งค่าการรักษาความปลอดภัย DCOM หลังจากที่คุณติดตั้ง Windows Server 2003 Service Pack 1 คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
903220คำอธิบายของการเปลี่ยนแปลงการตั้ง DCOM ค่าความปลอดภัยหลังจากที่คุณติดตั้ง Windows Server 2003 Service Pack 1

คุณสมบัติ

หมายเลขบทความ (Article ID): 929494 - รีวิวครั้งสุดท้าย: 15 มกราคม 2554 - Revision: 2.0
ใช้กับ
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
Keywords: 
kberrmsg kbtshoot kbexpertiseadvanced kbprb kbmt KB929494 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:929494

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com