Artigo: 929713 - Última revisão: sexta-feira, 26 de Outubro de 2007 - Revisão: 1.5

Um subsistema para aplicações baseadas em UNIX (SUA) aplicação poderá deixar de responder depois de instalar o SUA num computador baseado no Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Quando tenta executar um subsistema para aplicações baseadas em UNIX (SUA) aplicação num computador baseado no Windows Vista, a aplicação poderá deixar de responder.

Causa

Este problema ocorre porque o SUA foi concebido para ser executado automaticamente quando um ou mais das seguintes condições se verificar:
  • Reinicie o computador após a SUA instalação.
  • Uma aplicação ser executada com credenciais administrativas inicia SUA.
SUA não será iniciado se verifiquem as seguintes condições:
  • Um utilizador não tem credenciais administrativas instala o subsistema SUA.
  • O computador não foi reiniciado após a SUA instalação.
  • Não tiver executado uma aplicação de SUA utilizando credenciais de administrador.
Por conseguinte, uma aplicação de SUA que é executado sem credenciais administrativas pode deixar de responder.

Resolução

Para resolver este problema, utilize um dos seguintes métodos:
  • método 1

    Reinicie o computador baseado no Windows Vista. Por predefinição, o SUA é iniciado quando reiniciar o computador.
  • método 2

    Instale o opcional SUA software development kit (SDK).

    O ficheiro seguinte está disponível para transferência a partir do Centro de transferências da Microsoft:

    Reduzir esta imagemExpandir esta imagem
    Download
    Download the Utilities and SDK for Subsystem for UNIX-based Applications in Microsoft Windows Vista package now. (http://go.microsoft.com/fwlink/?LinkId=59121)

    Data de edição: 14 de Dezembro de 2006

    Para obter mais informações sobre como transferir ficheiros de suporte da Microsoft, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    119591  (http://support.microsoft.com/kb/119591/ ) Como obter ficheiros de suporte da Microsoft a partir de serviços online
    Microsoft procedeu de vírus neste ficheiro. Microsoft utilizou o mais recente software de detecção de vírus que estava disponível na data em que o ficheiro foi publicado. O ficheiro é alojado em servidores com segurança avançada o que ajuda a impedir alterações não autorizadas ao ficheiro.
  • método 3

    Execute o comando POSIX a partir de uma linha de comandos elevada. Para o fazer, siga estes passos:
    1. Clique em Iniciar
      Reduzir esta imagemExpandir esta imagem
      the Start button
      , clique em Todos os programas , clique em Acessórios , clique com o botão direito do rato em linha de comandos e, em seguida, clique em Executar como administrador .

      Reduzir esta imagemExpandir esta imagem
      User Account Control permission
      Se lhe for pedido para uma palavra-passe de administrador ou confirmação, escreva a palavra-passe ou clique em continuar .
    2. Na linha de comandos, escreva posix /u /c /bin/loginenv e, em seguida, prima ENTER.

      Para mais informações sobre a linha de comandos elevada no Windows Vista, visite o seguinte Web site da Microsoft:
      http://technet2.microsoft.com/WindowsVista/en/library/00d04415-2b2f-422c-b70e-b18ff918c2811033.mspx (http://technet2.microsoft.com/WindowsVista/en/library/00d04415-2b2f-422c-b70e-b18ff918c2811033.mspx)
    Por predefinição, o SUA é iniciado quando executar o comando POSIX a partir de uma linha de comandos elevada.

Ponto Da Situação

A Microsoft confirmou que este erro ocorre nos produtos do Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações sobre o SUA, visite o seguinte Web site da Microsoft:
http://technet2.microsoft.com/WindowsServer/en/Library/cd0e7ee9-05f0-4504-8caa-acc95c8c964b1033.mspx?mfr=true (http://technet2.microsoft.com/WindowsServer/en/Library/cd0e7ee9-05f0-4504-8caa-acc95c8c964b1033.mspx?mfr=true)
Para obter mais informações sobre utilitários e SDK para aplicações baseadas em UNIX, visite o seguinte Web site da Microsoft:
http://technet2.microsoft.com/WindowsServer/en/Library/ccb387e1-e686-43d1-acf6-2fc0d0eca6b91033.mspx?mfr=true (http://technet2.microsoft.com/WindowsServer/en/Library/ccb387e1-e686-43d1-acf6-2fc0d0eca6b91033.mspx?mfr=true)

A informação contida neste artigo aplica-se a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Palavras-chave: 
kbmt kbexpertiseinter kbtshoot kbexpertisebeginner kbbug KB929713 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 929713  (http://support.microsoft.com/kb/929713/en-us/ )